summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-10 16:37:04 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-10 16:37:04 +0000
commit2f0b7af795bddfd5765d1a7f75c64c6364a5c4d4 (patch)
treea5872d86a67fb7f1e3ed1722e4498ec279a87e21 /sci-biology/eugene
parentSet SITELISP through configure by Ulrich Müller (bug #336727). (diff)
downloadgentoo-2-2f0b7af795bddfd5765d1a7f75c64c6364a5c4d4.tar.gz
gentoo-2-2f0b7af795bddfd5765d1a7f75c64c6364a5c4d4.tar.bz2
gentoo-2-2f0b7af795bddfd5765d1a7f75c64c6364a5c4d4.zip
Fix overflows wrt bug 336604 and install path wrt bug 297536. Thanks to Diego for the reports.
(Portage version: 2.1.9/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/eugene')
-rw-r--r--sci-biology/eugene/ChangeLog10
-rw-r--r--sci-biology/eugene/eugene-3.6-r1.ebuild (renamed from sci-biology/eugene/eugene-3.6.ebuild)7
-rw-r--r--sci-biology/eugene/files/eugene-3.6-overflow.patch13
-rw-r--r--sci-biology/eugene/files/eugene-3.6-plugins.patch43
4 files changed, 70 insertions, 3 deletions
diff --git a/sci-biology/eugene/ChangeLog b/sci-biology/eugene/ChangeLog
index 87f2b44aaaf4..b847330dd4ac 100644
--- a/sci-biology/eugene/ChangeLog
+++ b/sci-biology/eugene/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-biology/eugene
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/eugene/ChangeLog,v 1.5 2010/05/07 19:31:27 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/eugene/ChangeLog,v 1.6 2010/09/10 16:37:04 xarthisius Exp $
+
+*eugene-3.6-r1 (10 Sep 2010)
+
+ 10 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org> -eugene-3.6.ebuild,
+ +eugene-3.6-r1.ebuild, +files/eugene-3.6-overflow.patch,
+ +files/eugene-3.6-plugins.patch:
+ Fix overflows wrt bug 336604 and install path wrt bug 297536. Thanks to
+ Diego for the reports.
*eugene-3.6 (07 May 2010)
diff --git a/sci-biology/eugene/eugene-3.6.ebuild b/sci-biology/eugene/eugene-3.6-r1.ebuild
index 95144de428a1..96f148007bc5 100644
--- a/sci-biology/eugene/eugene-3.6.ebuild
+++ b/sci-biology/eugene/eugene-3.6-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/eugene/eugene-3.6.ebuild,v 1.1 2010/05/07 19:31:27 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/eugene/eugene-3.6-r1.ebuild,v 1.1 2010/09/10 16:37:04 xarthisius Exp $
EAPI=2
-inherit autotools
+inherit autotools eutils
DESCRIPTION="Eukaryotic gene predictor"
HOMEPAGE="http://www.inra.fr/mia/T/EuGene/"
@@ -29,6 +29,9 @@ DEPEND="media-libs/gd[png]
RDEPEND="${DEPEND}"
src_prepare() {
+ # https://mulcyber.toulouse.inra.fr/tracker/index.php?func=detail&aid=1170
+ epatch "${FILESDIR}"/${P}-overflow.patch \
+ "${FILESDIR}"/${P}-plugins.patch
if ( ! use doc ); then
sed -i -e '/SUBDIRS/ s/doc//' \
-e '/INSTALL.*doc/ s/\(.*\)//' \
diff --git a/sci-biology/eugene/files/eugene-3.6-overflow.patch b/sci-biology/eugene/files/eugene-3.6-overflow.patch
new file mode 100644
index 000000000000..7222530ad771
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-3.6-overflow.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=336607
+
+--- eugene-3.6/src/Sensor.cc
++++ eugene-3.6/src/Sensor.cc
+@@ -224,7 +224,7 @@
+ //--------------------------
+ void Signals :: PrintS ()
+ {
+- char t[7];
++ char t[10];
+ char s = '+';
+
+ switch (type) {
diff --git a/sci-biology/eugene/files/eugene-3.6-plugins.patch b/sci-biology/eugene/files/eugene-3.6-plugins.patch
new file mode 100644
index 000000000000..1e910a13d5b1
--- /dev/null
+++ b/sci-biology/eugene/files/eugene-3.6-plugins.patch
@@ -0,0 +1,43 @@
+http://bugs.gentoo.org/show_bug.cgi?id=297536
+
+--- eugene-3.6/src/Makefile.am
++++ eugene-3.6/src/Makefile.am
+@@ -20,7 +20,7 @@
+
+ SUBDIRS = Parametrization GDIF . SensorPlugins
+
+-AM_CXXFLAGS = $(eugene_cxxflags) -DDEFAULT_EUGENE_DIR=\"${pkgdatadir}\"
++AM_CXXFLAGS = $(eugene_cxxflags) -DDEFAULT_EUGENE_DIR=\"${pkgdatadir}\" -DLIB_DIR=\"${libdir}\"
+ AM_CFLAGS =
+
+ bin_PROGRAMS = eugene
+--- eugene-3.6/src/MSensor.cc
++++ eugene-3.6/src/MSensor.cc
+@@ -97,7 +97,7 @@
+ std::string use_name;
+
+ if (!IsInitialized) {
+- PluginsDir = (std::string)PAR.getC("eugene_dir")+"/"+PLUGINS_DIR+"/";
++ PluginsDir = (std::string)LIB_DIR+"/eugene/"+PLUGINS_DIR+"/";
+
+ // On récupère les couples nom de sensor/priorité du .par
+ PAR.ResetIter();
+--- eugene-3.6/Makefile.am
++++ eugene-3.6/Makefile.am
+@@ -125,7 +125,7 @@
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Style
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Javascripts
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/web/Images
+- $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) -d $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models
+ $(INSTALL) -d $(DESTDIR)/$(pkgdatadir)/models/WAM
+@@ -144,6 +144,6 @@
+ $(INSTALL) -m 644 $(srcdir)/web/Images/*jpg $(DESTDIR)/$(pkgdatadir)/web/Images
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.obo $(DESTDIR)/$(pkgdatadir)/cfg
+ $(INSTALL) -m 644 $(srcdir)/cfg/*.par $(DESTDIR)/$(pkgdatadir)/cfg
+- $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(pkgdatadir)/plugins
++ $(INSTALL) src/SensorPlugins/*/*.so $(DESTDIR)/$(libdir)/eugene/plugins
+ $(INSTALL) $(srcdir)/Procedures/Eval/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Eval
+ $(INSTALL) $(srcdir)/Procedures/Get/egn_* $(DESTDIR)/$(pkgdatadir)/Procedures/Get