summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-10-31 21:18:17 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-10-31 21:18:17 +0000
commit71a5e4a51f3979b5ec85b50acc5ba04ad25724d6 (patch)
treeadb8c91a8fd2137abe10c0ac086af2fe3c64435a /sci-biology/gatk
parentVersion bump, fixes: https://launchpad.net/dulwich/+milestone/0.8.1 (diff)
downloadgentoo-2-71a5e4a51f3979b5ec85b50acc5ba04ad25724d6.tar.gz
gentoo-2-71a5e4a51f3979b5ec85b50acc5ba04ad25724d6.tar.bz2
gentoo-2-71a5e4a51f3979b5ec85b50acc5ba04ad25724d6.zip
New package, ebuild written by me
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/gatk')
-rw-r--r--sci-biology/gatk/ChangeLog11
-rw-r--r--sci-biology/gatk/gatk-1.2.ebuild44
-rw-r--r--sci-biology/gatk/gatk-9999.ebuild45
-rw-r--r--sci-biology/gatk/metadata.xml9
4 files changed, 109 insertions, 0 deletions
diff --git a/sci-biology/gatk/ChangeLog b/sci-biology/gatk/ChangeLog
new file mode 100644
index 000000000000..2672b2663a32
--- /dev/null
+++ b/sci-biology/gatk/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-biology/gatk
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/gatk/ChangeLog,v 1.1 2011/10/31 21:18:17 weaver Exp $
+
+*gatk-9999 (31 Oct 2011)
+*gatk-1.2 (31 Oct 2011)
+
+ 31 Oct 2011; Andrey Kislyuk <weaver@gentoo.org> +gatk-1.2.ebuild,
+ +gatk-9999.ebuild, +metadata.xml:
+ New package, ebuild written by me
+
diff --git a/sci-biology/gatk/gatk-1.2.ebuild b/sci-biology/gatk/gatk-1.2.ebuild
new file mode 100644
index 000000000000..c15c610ed329
--- /dev/null
+++ b/sci-biology/gatk/gatk-1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/gatk/gatk-1.2.ebuild,v 1.1 2011/10/31 21:18:17 weaver Exp $
+
+EAPI=4
+
+MY_HASH=885c33a
+
+EGIT_REPO_URI="https://github.com/broadgsa/gatk.git"
+
+EANT_BUILD_TARGET="dist"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+#inherit java-pkg-2 java-ant-2 git
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Genome Analysis Toolkit"
+HOMEPAGE="http://www.broadinstitute.org/gsa/wiki/index.php/The_Genome_Analysis_Toolkit"
+SRC_URI="https://github.com/broadgsa/gatk/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+COMMON_DEPS=""
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEPS}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPS}"
+
+S="${WORKDIR}/broadgsa-gatk-${MY_HASH}"
+
+src_prepare() {
+ sed -i '/property name="ivy.home"/ s|${user.home}|'${WORKDIR}'|' build.xml || die
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ java-pkg_dolauncher GenomeAnalysisTK --jar GenomeAnalysisTK.jar
+ java-pkg_dolauncher AnalyzeCovariates --jar AnalyzeCovariates.jar
+}
diff --git a/sci-biology/gatk/gatk-9999.ebuild b/sci-biology/gatk/gatk-9999.ebuild
new file mode 100644
index 000000000000..b2e0ca49c1b1
--- /dev/null
+++ b/sci-biology/gatk/gatk-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/gatk/gatk-9999.ebuild,v 1.1 2011/10/31 21:18:17 weaver Exp $
+
+EAPI=4
+
+MY_HASH=885c33a
+
+EGIT_REPO_URI="https://github.com/broadgsa/gatk.git"
+
+EANT_BUILD_TARGET="dist"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+#inherit java-pkg-2 java-ant-2 git
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Genome Analysis Toolkit"
+HOMEPAGE="http://www.broadinstitute.org/gsa/wiki/index.php/The_Genome_Analysis_Toolkit"
+#SRC_URI="https://github.com/broadgsa/gatk/tarball/${PV} -> ${P}.tar.gz"
+SRC_URI=""
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+COMMON_DEPS=""
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEPS}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPS}"
+
+S="${WORKDIR}/broadgsa-gatk-${MY_HASH}"
+
+src_prepare() {
+ sed -i '/property name="ivy.home"/ s|${user.home}|'${WORKDIR}'|' build.xml || die
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ java-pkg_dolauncher GenomeAnalysisTK --jar GenomeAnalysisTK.jar
+ java-pkg_dolauncher AnalyzeCovariates --jar AnalyzeCovariates.jar
+}
diff --git a/sci-biology/gatk/metadata.xml b/sci-biology/gatk/metadata.xml
new file mode 100644
index 000000000000..3302123e5718
--- /dev/null
+++ b/sci-biology/gatk/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <herd>sci-biology</herd>
+</pkgmetadata>