summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-04-20 11:11:20 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-04-20 11:11:20 +0000
commit0d9c961e6c2acdb89c9c11c14eb5a2d04aaed35d (patch)
treea3dd3d56cf71318eeb8417cb0778e81350837754 /sci-biology/paml
parentalpha/ia64/sparc/x86 stable (diff)
downloadgentoo-2-0d9c961e6c2acdb89c9c11c14eb5a2d04aaed35d.tar.gz
gentoo-2-0d9c961e6c2acdb89c9c11c14eb5a2d04aaed35d.tar.bz2
gentoo-2-0d9c961e6c2acdb89c9c11c14eb5a2d04aaed35d.zip
Version bump (fixes bug #218232).
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'sci-biology/paml')
-rw-r--r--sci-biology/paml/ChangeLog9
-rw-r--r--sci-biology/paml/paml-4a.ebuild4
-rw-r--r--sci-biology/paml/paml-4b.ebuild40
3 files changed, 49 insertions, 4 deletions
diff --git a/sci-biology/paml/ChangeLog b/sci-biology/paml/ChangeLog
index c2a2b9967f02..76b367db7884 100644
--- a/sci-biology/paml/ChangeLog
+++ b/sci-biology/paml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/paml
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/ChangeLog,v 1.2 2007/11/22 13:26:59 markusle Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/ChangeLog,v 1.3 2008/04/20 11:11:20 markusle Exp $
+
+*paml-4b (20 Apr 2008)
+
+ 20 Apr 2008; Markus Dittrich <markusle@gentoo.org> +paml-4b.ebuild:
+ Version bump (fixes bug #218232).
*paml-4a (22 Nov 2007)
diff --git a/sci-biology/paml/paml-4a.ebuild b/sci-biology/paml/paml-4a.ebuild
index ded1fad3745c..a47b92d6794e 100644
--- a/sci-biology/paml/paml-4a.ebuild
+++ b/sci-biology/paml/paml-4a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/paml-4a.ebuild,v 1.1 2007/11/22 13:26:59 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/paml-4a.ebuild,v 1.2 2008/04/20 11:11:20 markusle Exp $
inherit toolchain-funcs
diff --git a/sci-biology/paml/paml-4b.ebuild b/sci-biology/paml/paml-4b.ebuild
new file mode 100644
index 000000000000..58aab90bf711
--- /dev/null
+++ b/sci-biology/paml/paml-4b.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/paml-4b.ebuild,v 1.1 2008/04/20 11:11:20 markusle Exp $
+
+inherit toolchain-funcs
+
+MY_PV="${PV:0:1}"
+MY_P="${PN}${MY_PV}"
+DESCRIPTION="Phylogenetic Analysis by Maximum Likelihood"
+HOMEPAGE="http://abacus.gene.ucl.ac.uk/software/paml.html"
+SRC_URI="http://abacus.gene.ucl.ac.uk/software/${PN}${PV}.tar.gz"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ cd src
+ emake \
+ -f Makefile.UNIX \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ pushd "${S}"/src
+ dobin baseml codeml basemlg mcmctree pamp evolver yn00 chi2
+ popd
+ dodoc README.txt doc/*
+ insinto /usr/share/${PN}/control
+ doins *.ctl || die "Failed to install control files"
+ insinto /usr/share/${PN}/dat
+ doins stewart* *.dat dat/* || die "Failed to install data files"
+ insinto /usr/share/${PN}
+ doins -r examples/ || die "Failed to install examples"
+}