summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-18 16:04:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-18 16:04:00 +0000
commit0e8984b52d11f97f055adb0acf0579ca0be3503c (patch)
tree8f07a8a73667caa23e7bb74a3166406d68f79e46 /sci-biology/poa/poa-2-r1.ebuild
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #337121 (diff)
downloadgentoo-2-0e8984b52d11f97f055adb0acf0579ca0be3503c.tar.gz
gentoo-2-0e8984b52d11f97f055adb0acf0579ca0be3503c.tar.bz2
gentoo-2-0e8984b52d11f97f055adb0acf0579ca0be3503c.zip
Respecting LDFLAGS, 337856
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/poa/poa-2-r1.ebuild')
-rw-r--r--sci-biology/poa/poa-2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-biology/poa/poa-2-r1.ebuild b/sci-biology/poa/poa-2-r1.ebuild
new file mode 100644
index 000000000000..a44fe8e66a71
--- /dev/null
+++ b/sci-biology/poa/poa-2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/poa/poa-2-r1.ebuild,v 1.1 2010/09/18 16:04:00 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+MY_P="${PN}V${PV}"
+
+DESCRIPTION="Fast multiple sequence alignments using partial-order graphs"
+HOMEPAGE="http://bioinfo.mbi.ucla.edu/poa/"
+SRC_URI="mirror://sourceforge/poamsa/${MY_P}.tar.gz"
+
+# According to SF project page
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-respect-flags.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ OPT_CFLAGS="${CFLAGS}" \
+ poa || die "make failed"
+}
+
+src_install() {
+ dobin "${S}"/poa "${S}"/make_pscores.pl || die
+ dolib.a "${S}"/liblpo.a || die
+ dodoc "${S}"/README "${S}"/multidom.* || die
+ insinto /usr/share/poa
+ doins "${S}"/*.mat || die
+}
+
+pkg_postinst() {
+ elog "poa requires a score matrix as the first argument."
+ elog "This package installs two examples to ${EROOT}usr/share/poa/."
+}