summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-16 11:23:30 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-16 11:23:30 +0000
commit5d6bc31312f89887210db619fb16894cf8d433c3 (patch)
treeda0580cc44687ab868976103b0ed946d2180f683 /sci-biology
parentversion bump (diff)
downloadgentoo-2-5d6bc31312f89887210db619fb16894cf8d433c3.tar.gz
gentoo-2-5d6bc31312f89887210db619fb16894cf8d433c3.tar.bz2
gentoo-2-5d6bc31312f89887210db619fb16894cf8d433c3.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/psipred/ChangeLog8
-rw-r--r--sci-biology/psipred/files/3.1-Makefile.patch38
-rw-r--r--sci-biology/psipred/files/3.1-path.patch38
-rw-r--r--sci-biology/psipred/psipred-3.1.ebuild48
4 files changed, 131 insertions, 1 deletions
diff --git a/sci-biology/psipred/ChangeLog b/sci-biology/psipred/ChangeLog
index 970c787dc9e5..b947e301b829 100644
--- a/sci-biology/psipred/ChangeLog
+++ b/sci-biology/psipred/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/psipred
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/psipred/ChangeLog,v 1.2 2010/05/06 18:27:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/psipred/ChangeLog,v 1.3 2010/05/16 11:23:30 jlec Exp $
+
+*psipred-3.1 (16 May 2010)
+
+ 16 May 2010; Justin Lecher <jlec@gentoo.org> +files/3.1-Makefile.patch,
+ +psipred-3.1.ebuild, +files/3.1-path.patch:
+ Version bump
*psipred-3.0 (06 May 2010)
*psipred-2.6.1-r1 (06 May 2010)
diff --git a/sci-biology/psipred/files/3.1-Makefile.patch b/sci-biology/psipred/files/3.1-Makefile.patch
new file mode 100644
index 000000000000..0c70b6868565
--- /dev/null
+++ b/sci-biology/psipred/files/3.1-Makefile.patch
@@ -0,0 +1,38 @@
+diff --git a/src/Makefile b/src/Makefile
+index abed8af..26061fa 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -6,9 +6,9 @@
+ #### CFLAGS Flags to pass to C compiler.
+
+ INCDIR = .
+-CC = cc
++CC ?= gcc
+
+-CFLAGS = -O
++CFLAGS ?= -O2
+ LIBS = -lm
+
+ all: psipred psipass2 chkparse seq2mtx pfilt
+@@ -20,16 +20,16 @@ clean:
+ /bin/rm -f psipred psipass2 chkparse seq2mtx pfilt
+
+ psipred: sspred_avpred.c ssdefs.h sspred_net.h
+- $(CC) $(CFLAGS) sspred_avpred.c $(LIBS) -o psipred
++ $(CC) $(CFLAGS) $(LDFLAGS) sspred_avpred.c $(LIBS) -o psipred
+
+ psipass2: sspred_hmulti.c ssdefs.h sspred_net2.h
+- $(CC) $(CFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
++ $(CC) $(CFLAGS) $(LDFLAGS) sspred_hmulti.c $(LIBS) -o psipass2
+
+ chkparse: chkparse.c
+- $(CC) $(CFLAGS) chkparse.c $(LIBS) -o chkparse
++ $(CC) $(CFLAGS) $(LDFLAGS) chkparse.c $(LIBS) -o chkparse
+
+ seq2mtx: seq2mtx.c
+- $(CC) $(CFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
++ $(CC) $(CFLAGS) $(LDFLAGS) seq2mtx.c $(LIBS) -o seq2mtx
+
+ pfilt: pfilt.c
+- $(CC) $(CFLAGS) pfilt.c $(LIBS) -o pfilt
++ $(CC) $(CFLAGS) $(LDFLAGS) pfilt.c $(LIBS) -o pfilt
diff --git a/sci-biology/psipred/files/3.1-path.patch b/sci-biology/psipred/files/3.1-path.patch
new file mode 100644
index 000000000000..564e9c8a1ef9
--- /dev/null
+++ b/sci-biology/psipred/files/3.1-path.patch
@@ -0,0 +1,38 @@
+diff --git a/runpsipred b/runpsipred
+index 4ccf44e..34dee99 100755
+--- a/runpsipred
++++ b/runpsipred
+@@ -14,13 +14,13 @@
+ set dbname = uniref90filt
+
+ # Where the NCBI programs have been installed
+-set ncbidir = /usr/local/bin
++set ncbidir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V2 programs have been installed
+-set execdir = ./bin
++set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V2 data files have been installed
+-set datadir = ./data
++set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
+
+ set basename = $1:r
+ set rootname = $basename:t
+diff --git a/runpsipred_single b/runpsipred_single
+index 1f7680b..7bd5bc3 100755
+--- a/runpsipred_single
++++ b/runpsipred_single
+@@ -10,10 +10,10 @@
+ # NOTE: Script modified to be more cluster friendly (DTJ April 2008)
+
+ # Where the PSIPRED V3 programs have been installed
+-set execdir = ./bin
++set execdir = @GENTOO_PORTAGE_EPREFIX@/usr/bin
+
+ # Where the PSIPRED V3 data files have been installed
+-set datadir = ./data
++set datadir = @GENTOO_PORTAGE_EPREFIX@/usr/share/psipred/data
+
+ set basename = $1:r
+ set rootname = $basename:t
diff --git a/sci-biology/psipred/psipred-3.1.ebuild b/sci-biology/psipred/psipred-3.1.ebuild
new file mode 100644
index 000000000000..3201132f6781
--- /dev/null
+++ b/sci-biology/psipred/psipred-3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/psipred/psipred-3.1.ebuild,v 1.1 2010/05/16 11:23:30 jlec Exp $
+
+EAPI="3"
+
+inherit eutils prefix toolchain-funcs versionator
+
+MY_P="${PN}$(delete_all_version_separators)"
+
+DESCRIPTION="Protein Secondary Structure Prediction"
+HOMEPAGE="http://bioinf.cs.ucl.ac.uk/psipred/"
+SRC_URI="http://bioinf.cs.ucl.ac.uk/downloads/${PN}/${MY_P}.tar.gz"
+
+LICENSE="psipred"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ sci-biology/ncbi-tools
+ sci-biology/ncbi-tools++"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ rm -f bin/*
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ epatch "${FILESDIR}"/${PV}-path.patch
+ eprefixify runpsipred*
+}
+
+src_compile() {
+ emake -C src CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake -C src DESTDIR="${D}" install || die "installation failed"
+ dobin runpsipred* bin/* BLAST+/runpsipred* || die
+ insinto /usr/share/${PN}
+ doins -r data || die "failed to install data"
+ dodoc README || die "nothing to read"
+}
+
+pkg_postinst() {
+ elog "Please use the update_blastdb.pl in order to"
+ elog "maintain your own local blastdb"
+}