summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-30 16:49:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-30 16:49:34 +0000
commit67ee054350248e31085a8e44e3beb3ef70609be9 (patch)
treeb754f750f531b9ed56bb7cdd27d51d81e1517e0e /sci-biology
parentFix building with GCC 4.4 and -Wl,--as-needed. (diff)
downloadgentoo-2-67ee054350248e31085a8e44e3beb3ef70609be9.tar.gz
gentoo-2-67ee054350248e31085a8e44e3beb3ef70609be9.tar.bz2
gentoo-2-67ee054350248e31085a8e44e3beb3ef70609be9.zip
Fix building with GCC 4.4 and GLIBC 2.10+ wrt #279572.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/amos/ChangeLog6
-rw-r--r--sci-biology/amos/amos-2.0.8.ebuild14
-rw-r--r--sci-biology/amos/files/amos-2.0.8-gcc44.patch117
3 files changed, 130 insertions, 7 deletions
diff --git a/sci-biology/amos/ChangeLog b/sci-biology/amos/ChangeLog
index fc5eae2fe31c..cd63f255d364 100644
--- a/sci-biology/amos/ChangeLog
+++ b/sci-biology/amos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/amos
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/ChangeLog,v 1.4 2009/03/15 17:58:50 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/ChangeLog,v 1.5 2009/07/30 16:49:34 ssuominen Exp $
+
+ 30 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> amos-2.0.8.ebuild,
+ +files/amos-2.0.8-gcc44.patch:
+ Fix building with GCC 4.4 and GLIBC 2.10+ wrt #279572.
15 Mar 2009; Markus Meier <maekke@gentoo.org> amos-2.0.8.ebuild:
amd64/x86 stable, bug #261786
diff --git a/sci-biology/amos/amos-2.0.8.ebuild b/sci-biology/amos/amos-2.0.8.ebuild
index 18236ac5f113..867df2b0fb68 100644
--- a/sci-biology/amos/amos-2.0.8.ebuild
+++ b/sci-biology/amos/amos-2.0.8.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/amos-2.0.8.ebuild,v 1.2 2009/03/15 17:58:50 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/amos/amos-2.0.8.ebuild,v 1.3 2009/07/30 16:49:34 ssuominen Exp $
-EAPI="1"
-inherit qt3 eutils
+EAPI=2
+inherit eutils qt3
DESCRIPTION="A Modular, Open-Source whole genome assembler"
HOMEPAGE="http://amos.sourceforge.net/"
@@ -19,12 +19,14 @@ RDEPEND="${DEPEND}
dev-perl/DBI
sci-biology/mummer"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
src_compile() {
- econf || die "econf failed"
- # TODO: fix parallel make. Notified upstream
emake -j1 || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
}
diff --git a/sci-biology/amos/files/amos-2.0.8-gcc44.patch b/sci-biology/amos/files/amos-2.0.8-gcc44.patch
new file mode 100644
index 000000000000..00a37be1d18c
--- /dev/null
+++ b/sci-biology/amos/files/amos-2.0.8-gcc44.patch
@@ -0,0 +1,117 @@
+diff -ur amos-2.0.8.orig/src/Align/align.cc amos-2.0.8/src/Align/align.cc
+--- amos-2.0.8.orig/src/Align/align.cc 2008-03-19 16:07:24.000000000 +0200
++++ amos-2.0.8/src/Align/align.cc 2009-07-30 19:40:51.000000000 +0300
+@@ -247,7 +247,7 @@
+ // Add incr_val to the after count in this Vote_t for ch .
+
+ {
+- char * p;
++ const char * p;
+
+ p = strchr (ALPHABET, tolower (ch));
+ if (p == NULL)
+@@ -285,7 +285,7 @@
+ // count for a blank.
+
+ {
+- char * p;
++ const char * p;
+
+ p = strchr (ALPHABET, tolower (ch));
+ if (p == NULL)
+@@ -357,7 +357,7 @@
+
+ {
+ int i;
+- char * p;
++ const char * p;
+
+ for (i = 0; i <= ALPHABET_SIZE; i ++)
+ here [i] = after [i] = 0;
+diff -ur amos-2.0.8.orig/src/Align/align_poly.cc amos-2.0.8/src/Align/align_poly.cc
+--- amos-2.0.8.orig/src/Align/align_poly.cc 2006-03-30 05:03:12.000000000 +0300
++++ amos-2.0.8/src/Align/align_poly.cc 2009-07-30 19:43:44.000000000 +0300
+@@ -247,7 +247,7 @@
+ // Add 1 to the after count in this Vote_t for ch .
+
+ {
+- char * p;
++ const char * p;
+
+ p = strchr (ALPHABET, tolower (ch));
+ if (p == NULL)
+@@ -285,7 +285,7 @@
+ // count for a blank.
+
+ {
+- char * p;
++ const char * p;
+
+ p = strchr (ALPHABET, tolower (ch));
+ if (p == NULL)
+@@ -357,7 +357,7 @@
+
+ {
+ int i;
+- char * p;
++ const char * p;
+
+ for (i = 0; i <= ALPHABET_SIZE; i ++)
+ here [i] = after [i] = 0;
+diff -ur amos-2.0.8.orig/src/AMOS/IDMap_AMOS.cc amos-2.0.8/src/AMOS/IDMap_AMOS.cc
+--- amos-2.0.8.orig/src/AMOS/IDMap_AMOS.cc 2006-11-21 17:45:46.000000000 +0200
++++ amos-2.0.8/src/AMOS/IDMap_AMOS.cc 2009-07-30 19:30:03.000000000 +0300
+@@ -10,6 +10,7 @@
+ #include "IDMap_AMOS.hh"
+ #include <string>
+ #include <sstream>
++#include <cstdio>
+ #include <cstring>
+ using namespace AMOS;
+ using namespace std;
+diff -ur amos-2.0.8.orig/src/AMOS/Message_AMOS.cc amos-2.0.8/src/AMOS/Message_AMOS.cc
+--- amos-2.0.8.orig/src/AMOS/Message_AMOS.cc 2005-01-07 23:53:05.000000000 +0200
++++ amos-2.0.8/src/AMOS/Message_AMOS.cc 2009-07-30 19:32:21.000000000 +0300
+@@ -7,6 +7,8 @@
+ //!
+ ////////////////////////////////////////////////////////////////////////////////
+
++#include <cstdio>
++
+ #include "Message_AMOS.hh"
+ using namespace AMOS;
+ using namespace std;
+diff -ur amos-2.0.8.orig/src/Common/amp.cc amos-2.0.8/src/Common/amp.cc
+--- amos-2.0.8.orig/src/Common/amp.cc 2006-10-25 16:56:41.000000000 +0300
++++ amos-2.0.8/src/Common/amp.cc 2009-07-30 19:33:59.000000000 +0300
+@@ -1,6 +1,7 @@
+ #include "amp.hh"
+ #include <new>
+ #include <iostream>
++#include <cstdio>
+ #include <cstring>
+ #include <ctime>
+ using namespace std;
+diff -ur amos-2.0.8.orig/src/Foundation/FileSystem.cc amos-2.0.8/src/Foundation/FileSystem.cc
+--- amos-2.0.8.orig/src/Foundation/FileSystem.cc 2005-07-09 00:52:03.000000000 +0300
++++ amos-2.0.8/src/Foundation/FileSystem.cc 2009-07-30 19:35:48.000000000 +0300
+@@ -55,7 +55,7 @@
+ {
+ // Check to see if path was given
+
+- char * end_of_path = strrchr(filename, PATH_DELIMINATOR);
++ const char * end_of_path = strrchr(filename, PATH_DELIMINATOR);
+
+ if (end_of_path)
+ {
+diff -ur amos-2.0.8.orig/src/Foundation/Options.cc amos-2.0.8/src/Foundation/Options.cc
+--- amos-2.0.8.orig/src/Foundation/Options.cc 2008-06-22 18:19:07.000000000 +0300
++++ amos-2.0.8/src/Foundation/Options.cc 2009-07-30 19:37:40.000000000 +0300
+@@ -26,6 +26,7 @@
+ */
+
+ #include "Options.hh"
++#include <cstdio>
+ #include <cstring>
+
+ //! Constructor takes command line options in standard argc, argv format