summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Stadler <centic@gentoo.org>2006-06-30 16:15:01 +0000
committerDominik Stadler <centic@gentoo.org>2006-06-30 16:15:01 +0000
commit32271905e635dcfe5147c4e857fe33e5f416a0f3 (patch)
treeac9a0f0d9b88f7936e41d4613916feac9bc92ae0 /sci-calculators/abakus
parentStable on amd64. (diff)
downloadgentoo-2-32271905e635dcfe5147c4e857fe33e5f416a0f3.tar.gz
gentoo-2-32271905e635dcfe5147c4e857fe33e5f416a0f3.tar.bz2
gentoo-2-32271905e635dcfe5147c4e857fe33e5f416a0f3.zip
Add new version 0.91, fixes Bug 137517
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'sci-calculators/abakus')
-rw-r--r--sci-calculators/abakus/ChangeLog7
-rw-r--r--sci-calculators/abakus/abakus-0.91.ebuild41
-rw-r--r--sci-calculators/abakus/files/digest-abakus-0.913
3 files changed, 50 insertions, 1 deletions
diff --git a/sci-calculators/abakus/ChangeLog b/sci-calculators/abakus/ChangeLog
index 1aa7e9d066ae..232e71721b55 100644
--- a/sci-calculators/abakus/ChangeLog
+++ b/sci-calculators/abakus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-calculators/abakus
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/abakus/ChangeLog,v 1.5 2006/04/30 17:10:37 centic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/abakus/ChangeLog,v 1.6 2006/06/30 16:15:01 centic Exp $
+
+*abakus-0.91 (30 Jun 2006)
+
+ 30 Jun 2006; Dominik Stadler <centic@gentoo.org> +abakus-0.91.ebuild:
+ Add new version 0.91, fixes Bug 137517
30 Apr 2006; Dominik Stadler <centic@gentoo.org> abakus-0.90.ebuild:
Enable use of gmp/mpfr-library and gmp-use-flag
diff --git a/sci-calculators/abakus/abakus-0.91.ebuild b/sci-calculators/abakus/abakus-0.91.ebuild
new file mode 100644
index 000000000000..12d3945fde35
--- /dev/null
+++ b/sci-calculators/abakus/abakus-0.91.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/abakus/abakus-0.91.ebuild,v 1.1 2006/06/30 16:15:01 centic Exp $
+
+inherit kde
+
+DESCRIPTION="Abakus is a simple calculator for kde, similar to bc with a nice gui."
+HOMEPAGE="http://grammarian.homelinux.net/abakus/"
+SRC_URI="http://www.kde-apps.org/content/files/16751-${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# leave gmp out for now, does not work for me
+IUSE="debug" # gmp
+
+DEPEND=">=dev-util/scons-0.96.1
+ gmp? ( dev-libs/mpfr )"
+#RDEPEND=""
+
+need-kde 3.3
+
+src_compile() {
+ local myconf="kdeincludes=$(kde-config --prefix)/include prefix=/usr"
+ use amd64 && myconf="${myconf} libsuffix=64"
+ use debug && myconf="${myconf} debug=full"
+
+# use gmp && myconf="${myconf} mpfr=yes"
+# use gmp || myconf="${myconf} mpfr=no"
+
+ einfo "Calling configure with: ${myconf}"
+
+ scons configure ${myconf} || die "configure failed"
+ scons ${MAKEOPTS} || die "scons failed"
+}
+
+src_install() {
+ DESTDIR="${D}/usr" scons install
+ dodoc AUTHORS COPYING README
+}
+
diff --git a/sci-calculators/abakus/files/digest-abakus-0.91 b/sci-calculators/abakus/files/digest-abakus-0.91
new file mode 100644
index 000000000000..67aa0b5eb9a6
--- /dev/null
+++ b/sci-calculators/abakus/files/digest-abakus-0.91
@@ -0,0 +1,3 @@
+MD5 56eaa5d98caa96973c09d62ae7da3061 16751-abakus-0.91.tar.bz2 380025
+RMD160 36ad0199169aff4f8d9ad876accb1b00256b915a 16751-abakus-0.91.tar.bz2 380025
+SHA256 54815bcbb49086d7c5434e33837391845bbccd24a22039f890fb2a721e609381 16751-abakus-0.91.tar.bz2 380025