summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-02-04 08:37:25 +0000
committerJeroen Roovers <jer@gentoo.org>2014-02-04 08:37:25 +0000
commit0e48064f61f4045e944bda24c18ac14713b7f988 (patch)
treef56b23a25fb9251ee8e66178dee3f64eb241b659 /sci-calculators
parentFiner control on gles2 vs. opengl USE, bug #500150. Actually properly allow r... (diff)
downloadgentoo-2-0e48064f61f4045e944bda24c18ac14713b7f988.tar.gz
gentoo-2-0e48064f61f4045e944bda24c18ac14713b7f988.tar.bz2
gentoo-2-0e48064f61f4045e944bda24c18ac14713b7f988.zip
Fix XML encoding.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/ChangeLog10
-rw-r--r--sci-calculators/units/files/units-2.02-UTF8.patch19
-rw-r--r--sci-calculators/units/units-2.02-r1.ebuild35
3 files changed, 62 insertions, 2 deletions
diff --git a/sci-calculators/units/ChangeLog b/sci-calculators/units/ChangeLog
index bffbf53de2df..b2abffe0c730 100644
--- a/sci-calculators/units/ChangeLog
+++ b/sci-calculators/units/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/units
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/ChangeLog,v 1.66 2013/09/07 13:40:04 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/ChangeLog,v 1.67 2014/02/04 08:37:25 jer Exp $
+
+*units-2.02-r1 (04 Feb 2014)
+
+ 04 Feb 2014; Jeroen Roovers <jer@gentoo.org> +units-2.02-r1.ebuild,
+ +files/units-2.02-UTF8.patch:
+ Fix XML encoding.
07 Sep 2013; Jeroen Roovers <jer@gentoo.org> -units-2.01.ebuild:
Old.
diff --git a/sci-calculators/units/files/units-2.02-UTF8.patch b/sci-calculators/units/files/units-2.02-UTF8.patch
new file mode 100644
index 000000000000..51d73d804e87
--- /dev/null
+++ b/sci-calculators/units/files/units-2.02-UTF8.patch
@@ -0,0 +1,19 @@
+--- a/units_cur 2013-07-10 01:02:17.000000000 +0200
++++ b/units_cur 2014-02-04 09:13:07.613075137 +0100
+@@ -6,6 +6,7 @@
+ # Modified to use xml format output from timegenie instead of text file
+
+ import datetime
++import codecs
+ import sys
+ import urllib
+ import xml.etree.ElementTree as ET
+@@ -31,7 +32,7 @@
+ # print codes here
+
+ codes = [x.find('code').text for x in currencies]
+-names = [x.find('description').text for x in currencies]
++names = [x.find('description').text.encode('utf-8') for x in currencies]
+ values = [x.find('rate').text for x in currencies]
+
+ names = [x.lower().replace(' ','') for x in names]
diff --git a/sci-calculators/units/units-2.02-r1.ebuild b/sci-calculators/units/units-2.02-r1.ebuild
new file mode 100644
index 000000000000..6a51434053ad
--- /dev/null
+++ b/sci-calculators/units/units-2.02-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/units-2.02-r1.ebuild,v 1.1 2014/02/04 08:37:25 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="http://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="
+ >=sys-libs/readline-4.1-r2
+"
+RDEPEND="
+ || (
+ dev-lang/python:2.5[xml]
+ dev-lang/python:2.6[xml]
+ dev-lang/python:2.7[xml]
+ )
+ ${DEPEND}
+"
+
+DOCS=( ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.01-install.patch
+ epatch "${FILESDIR}"/${PN}-2.02-UTF8.patch
+ eautoreconf
+}