summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-07 19:51:04 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-07 19:51:04 +0000
commitdf5f6dc9a7096d392b8f827ee2f92ed328225498 (patch)
tree8380347c144e025106c0eb8609acf79c0084e4a6 /sci-chemistry/azara
parentx86 stable, bug #301906 (diff)
downloadgentoo-2-df5f6dc9a7096d392b8f827ee2f92ed328225498.tar.gz
gentoo-2-df5f6dc9a7096d392b8f827ee2f92ed328225498.tar.bz2
gentoo-2-df5f6dc9a7096d392b8f827ee2f92ed328225498.zip
New ebuild
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/azara')
-rw-r--r--sci-chemistry/azara/ChangeLog10
-rw-r--r--sci-chemistry/azara/azara-2.7.ebuild69
-rw-r--r--sci-chemistry/azara/files/help-makefile.patch196
-rw-r--r--sci-chemistry/azara/metadata.xml10
4 files changed, 285 insertions, 0 deletions
diff --git a/sci-chemistry/azara/ChangeLog b/sci-chemistry/azara/ChangeLog
new file mode 100644
index 000000000000..07c003fc51c5
--- /dev/null
+++ b/sci-chemistry/azara/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/azara
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.1 2010/02/07 19:51:02 jlec Exp $
+
+*azara-2.7 (07 Feb 2010)
+
+ 07 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> +azara-2.7.ebuild,
+ +files/help-makefile.patch, +metadata.xml:
+ New Ebuild
+
diff --git a/sci-chemistry/azara/azara-2.7.ebuild b/sci-chemistry/azara/azara-2.7.ebuild
new file mode 100644
index 000000000000..ccbba37a70ab
--- /dev/null
+++ b/sci-chemistry/azara/azara-2.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/azara-2.7.ebuild,v 1.1 2010/02/07 19:51:02 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A suite of programmes to process and view NMR data"
+HOMEPAGE="http://www.bio.cam.ac.uk/azara/"
+SRC_URI="http://www.bio.cam.ac.uk/ccpn/download/${PN}/${P}-src.tar.gz"
+
+LICENSE="AZARA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="opengl X xpm"
+
+RDEPEND="
+ xpm? ( x11-libs/libXpm )
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ echo "" > ENVIRONMENT
+
+ epatch "${FILESDIR}"/help-makefile.patch
+}
+
+src_compile() {
+ local mymake
+ local xpmuse
+
+ mymake="${mymake} help nongui"
+ use X && mymake="${mymake} gui"
+ use opengl && mymake="${mymake} gl"
+ use xpm && XPMUSE="XPM_FLAG=-DUSE_XPM XPM_LIB=-lXpm"
+
+ emake -j1 CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ MATH_LIB="-lm" \
+ X11_INCLUDE_DIR="-I${EPREFIX}/usr/X11R6/include" \
+ MOTIF_INCLUDE_DIR="-I${EPREFIX}/usr/include" \
+ X11_LIB_DIR="-L${EPREFIX}/usr/$(get_libdir)" \
+ MOTIF_LIB_DIR="-L${EPREFIX}/usr/$(get_libdir)" \
+ ${XPMUSE} \
+ X11_LIB="-lX11" \
+ MOTIF_LIB="-lXm -lXt" \
+ GL_INCLUDE_DIR="-I${EPREFIX}/usr/X11R6/include -I${EPREFIX}/usr/include" \
+ GL_LIB_DIR="-I${EPREFIX}/usr/$(get_libdir)" \
+ GL_LIB="-lglut -lGLU -lGL -lXmu -lX11 -lXext" \
+ ENDIAN_FLAG="-DLITTLE_ENDIAN_DATA" \
+ ${mymake} || die
+}
+
+src_install() {
+ for bin in bin/*; do
+ dobin "${bin}" || die "failed to install ${bin}"
+ done
+
+ mv "${D}"/usr/bin/{,azara-}extract || die "failed to fix extract collision"
+
+ dodoc CHANGES* README* || die
+ dohtml -r html/* || die
+}
+
+pkg_postinst() {
+ einfo "Due to collision we moved the extract binary to azara-extract"
+}
diff --git a/sci-chemistry/azara/files/help-makefile.patch b/sci-chemistry/azara/files/help-makefile.patch
new file mode 100644
index 000000000000..5a42034734da
--- /dev/null
+++ b/sci-chemistry/azara/files/help-makefile.patch
@@ -0,0 +1,196 @@
+--- help/makefile 2002-11-01 13:27:27.000000000 +0100
++++ help/makefile.new 2008-12-24 14:45:56.141225333 +0100
+@@ -37,102 +37,102 @@
+ .c.o:; $(CC) -c $(CFLAGS) $<
+
+ hlp:
+- txt2hlp azara
+- txt2hlp combine
+- txt2hlp components
+- txt2hlp connect
+- txt2hlp contours
+- txt2hlp deflate
+- txt2hlp extract
+- txt2hlp peak_find
+- txt2hlp peak_fit
+- txt2hlp plot1
+- txt2hlp plot2
+- txt2hlp process
+- txt2hlp project
+- txt2hlp slides
+- txt2hlp reflate
+- txt2hlp unblock
+- txt2hlp viewer
+- txt2hlp plot2/baseline
+- txt2hlp plot2/data
+- txt2hlp plot2/extract
+- txt2hlp plot2/levels
+- txt2hlp plot2/object
+- txt2hlp plot2/output
+- txt2hlp plot2/peak
+- txt2hlp plot2/peaks
+- txt2hlp plot2/phase
+- txt2hlp plot2/property
+- txt2hlp plot2/region
+- txt2hlp plot2/rowcol
+- txt2hlp plot2/save
+- txt2hlp plot2/tracking
+- txt2hlp plot1/button
+- txt2hlp plot1/data
+- txt2hlp plot1/object
+- txt2hlp plot1/output
+- txt2hlp plot1/property
+- txt2hlp plot1/region
+- txt2hlp plot1/slider
+- txt2hlp plot1/text
++ ./txt2hlp azara
++ ./txt2hlp combine
++ ./txt2hlp components
++ ./txt2hlp connect
++ ./txt2hlp contours
++ ./txt2hlp deflate
++ ./txt2hlp extract
++ ./txt2hlp peak_find
++ ./txt2hlp peak_fit
++ ./txt2hlp plot1
++ ./txt2hlp plot2
++ ./txt2hlp process
++ ./txt2hlp project
++ ./txt2hlp slides
++ ./txt2hlp reflate
++ ./txt2hlp unblock
++ ./txt2hlp viewer
++ ./txt2hlp plot2/baseline
++ ./txt2hlp plot2/data
++ ./txt2hlp plot2/extract
++ ./txt2hlp plot2/levels
++ ./txt2hlp plot2/object
++ ./txt2hlp plot2/output
++ ./txt2hlp plot2/peak
++ ./txt2hlp plot2/peaks
++ ./txt2hlp plot2/phase
++ ./txt2hlp plot2/property
++ ./txt2hlp plot2/region
++ ./txt2hlp plot2/rowcol
++ ./txt2hlp plot2/save
++ ./txt2hlp plot2/tracking
++ ./txt2hlp plot1/button
++ ./txt2hlp plot1/data
++ ./txt2hlp plot1/object
++ ./txt2hlp plot1/output
++ ./txt2hlp plot1/property
++ ./txt2hlp plot1/region
++ ./txt2hlp plot1/slider
++ ./txt2hlp plot1/text
+
+ html:
+- txt2html azara
+- txt2html combine
+- txt2html components
+- txt2html connect
+- txt2html contours
+- txt2html deflate
+- txt2html extract
+- txt2html peak_find
+- txt2html peak_fit
+- txt2html plot1
+- txt2html plot2
+- txt2html process
+- txt2html project
+- txt2html slides
+- txt2html reflate
+- txt2html unblock
+- txt2html viewer
+- txt2html plot2/baseline
+- txt2html plot2/data
+- txt2html plot2/extract
+- txt2html plot2/levels
+- txt2html plot2/object
+- txt2html plot2/output
+- txt2html plot2/peak
+- txt2html plot2/peaks
+- txt2html plot2/phase
+- txt2html plot2/property
+- txt2html plot2/region
+- txt2html plot2/rowcol
+- txt2html plot2/save
+- txt2html plot2/tracking
+- txt2html plot1/button
+- txt2html plot1/data
+- txt2html plot1/object
+- txt2html plot1/output
+- txt2html plot1/property
+- txt2html plot1/region
+- txt2html plot1/slider
+- txt2html plot1/text
+- txt2html CHANGES
+- txt2html INSTALL
+- txt2html README-2.7
+- txt2html CHANGES-1.0-1
+- txt2html CHANGES-1.0-2
+- txt2html CHANGES-1.0-3
+- txt2html CHANGES-2.0-0
+- txt2html CHANGES-2.5-0
+- txt2html CHANGES-2.6-0
+- txt2html CHANGES-2.7-0
+- txt2html LICENSE
++ ./txt2html azara
++ ./txt2html combine
++ ./txt2html components
++ ./txt2html connect
++ ./txt2html contours
++ ./txt2html deflate
++ ./txt2html extract
++ ./txt2html peak_find
++ ./txt2html peak_fit
++ ./txt2html plot1
++ ./txt2html plot2
++ ./txt2html process
++ ./txt2html project
++ ./txt2html slides
++ ./txt2html reflate
++ ./txt2html unblock
++ ./txt2html viewer
++ ./txt2html plot2/baseline
++ ./txt2html plot2/data
++ ./txt2html plot2/extract
++ ./txt2html plot2/levels
++ ./txt2html plot2/object
++ ./txt2html plot2/output
++ ./txt2html plot2/peak
++ ./txt2html plot2/peaks
++ ./txt2html plot2/phase
++ ./txt2html plot2/property
++ ./txt2html plot2/region
++ ./txt2html plot2/rowcol
++ ./txt2html plot2/save
++ ./txt2html plot2/tracking
++ ./txt2html plot1/button
++ ./txt2html plot1/data
++ ./txt2html plot1/object
++ ./txt2html plot1/output
++ ./txt2html plot1/property
++ ./txt2html plot1/region
++ ./txt2html plot1/slider
++ ./txt2html plot1/text
++ ./txt2html CHANGES
++ ./txt2html INSTALL
++ ./txt2html README-2.7
++ ./txt2html CHANGES-1.0-1
++ ./txt2html CHANGES-1.0-2
++ ./txt2html CHANGES-1.0-3
++ ./txt2html CHANGES-2.0-0
++ ./txt2html CHANGES-2.5-0
++ ./txt2html CHANGES-2.6-0
++ ./txt2html CHANGES-2.7-0
++ ./txt2html LICENSE
+
+ clean:
+ rm *.o
+
+ realclean:
+ rm *.o
+- rm txt2hlp
+- rm txt2html
++ rm ./txt2hlp
++ rm ./txt2html
diff --git a/sci-chemistry/azara/metadata.xml b/sci-chemistry/azara/metadata.xml
new file mode 100644
index 000000000000..4aaae064be71
--- /dev/null
+++ b/sci-chemistry/azara/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher (jlec)</name>
+ </maintainer>
+</pkgmetadata>
+