summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-04 17:02:15 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-04 17:02:15 +0000
commitdafe1f72650973093cf13698620dcd342f864864 (patch)
treea81fc03023ac2ad32656e43020ad1721df842a5e /sci-chemistry/ccp4-apps/files
parentMaintenance. EAPI=3. Depend on x11-libs/gtk+:2 (diff)
downloadgentoo-2-dafe1f72650973093cf13698620dcd342f864864.tar.gz
gentoo-2-dafe1f72650973093cf13698620dcd342f864864.tar.bz2
gentoo-2-dafe1f72650973093cf13698620dcd342f864864.zip
Streamline configure
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ccp4-apps/files')
-rw-r--r--sci-chemistry/ccp4-apps/files/6.1.3-clipper-mmdbold-ggc-4.3.patch22
-rw-r--r--sci-chemistry/ccp4-apps/files/6.1.3-fix-setup-bash-incompatibility.patch11
-rw-r--r--sci-chemistry/ccp4-apps/files/6.1.3-rename-rapper-ng.patch60
-rw-r--r--sci-chemistry/ccp4-apps/files/6.1.3-rename-rapper.patch77
-rw-r--r--sci-chemistry/ccp4-apps/files/6.1.3-rename-truncate.patch42
-rw-r--r--sci-chemistry/ccp4-apps/files/6.1.3-setup.patch336
6 files changed, 60 insertions, 488 deletions
diff --git a/sci-chemistry/ccp4-apps/files/6.1.3-clipper-mmdbold-ggc-4.3.patch b/sci-chemistry/ccp4-apps/files/6.1.3-clipper-mmdbold-ggc-4.3.patch
deleted file mode 100644
index 66186609a668..000000000000
--- a/sci-chemistry/ccp4-apps/files/6.1.3-clipper-mmdbold-ggc-4.3.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- ccp4-6.0.99e.orig/lib/clipper/clipper/mmdbold/clipper_mmdb.cpp 2008-07-31 13:23:13.000000000 -0700
-+++ ccp4-6.0.99e/lib/clipper/clipper/mmdbold/clipper_mmdb.cpp 2008-07-31 13:47:35.000000000 -0700
-@@ -43,7 +43,7 @@
-
- #include <set>
- #include <algorithm>
--
-+#include <string.h>
-
- namespace clipper {
-
---- ccp4-6.0.99e.orig/lib/clipper/clipper/mmdbold/clipper_mmdb_wrapper.cpp.orig 2008-07-31 13:49:53.000000000 -0700
-+++ ccp4-6.0.99e/lib/clipper/clipper/mmdbold/clipper_mmdb_wrapper.cpp 2008-07-31 13:50:25.000000000 -0700
-@@ -40,7 +40,7 @@
- //L MA 02111-1307 USA
-
- #include "clipper_mmdb_wrapper.h"
--
-+#include <string.h>
-
- namespace clipper {
-
diff --git a/sci-chemistry/ccp4-apps/files/6.1.3-fix-setup-bash-incompatibility.patch b/sci-chemistry/ccp4-apps/files/6.1.3-fix-setup-bash-incompatibility.patch
deleted file mode 100644
index d98f54cdb3c1..000000000000
--- a/sci-chemistry/ccp4-apps/files/6.1.3-fix-setup-bash-incompatibility.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ccp4-6.0.99e.orig/include/ccp4.setup-bash 2008-07-31 10:37:22.000000000 -0700
-+++ ccp4-6.0.99e/include/ccp4.setup-bash 2008-07-31 12:47:14.000000000 -0700
-@@ -181,7 +181,7 @@
-
- #Python path for the subprocess fixed module
-
--if ($ccp4_first_in_path) then
-+if [ $ccp4_first_in_path -eq 1 ]; then
- setenv PYTHONPATH ${CCP4}/share/python:${PYTHONPATH}
- else
- setenv PYTHONPATH ${PYTHONPATH}:${CCP4}/share/python
diff --git a/sci-chemistry/ccp4-apps/files/6.1.3-rename-rapper-ng.patch b/sci-chemistry/ccp4-apps/files/6.1.3-rename-rapper-ng.patch
new file mode 100644
index 000000000000..a5144cfa5d33
--- /dev/null
+++ b/sci-chemistry/ccp4-apps/files/6.1.3-rename-rapper-ng.patch
@@ -0,0 +1,60 @@
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 70781f3..b2dcc25 100755
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -760,7 +760,7 @@ chainsawobjs = chainsaw.o
+ pdbcur : $(pdbcurobjs)
+ @$(SETFLAGS) ; rm -f pdbcur; eval $(CXX) $${mmdb_app_FLAGS-"$(CXXFLAGS)"} -o pdbcur $(pdbcurobjs) $(LDCXXFLAGS)
+ ncont : $(ncontobjs)
+- @$(SETFLAGS) ; rm -f ncont; eval $(CXX) $${mmdb_app_FLAGS-"$(CXXFLAGS)"} -o ncont $(ncontobjs) $(LDCXXFLAGS)
++ @$(SETFLAGS) ; rm -f ncont; eval $(CXX) $${mmdb_app_FLAGS-"$(CXXFLAGS)"} -o ncont $(ncontobjs) $(LDCXXFLAGS) -lmmdb
+ coord_format : $(coord_formatobjs)
+ @$(SETFLAGS) xxx=1 ; \
+ rm -f coord_format; \
+diff --git a/src/rapper/LOOP/Makefile.am b/src/rapper/LOOP/Makefile.am
+index 85f212e..2608c6d 100755
+--- a/src/rapper/LOOP/Makefile.am
++++ b/src/rapper/LOOP/Makefile.am
+@@ -15,12 +15,12 @@ params.cpp typed_value.cpp misc.cpp residue.cpp atom.cpp psa.cpp edm_sidechains.
+ hash_table.cpp surface.cpp parse.cpp band.cpp edensity.cpp read_map.cpp iterator.cpp \
+ residue_range.cpp pop_search_frags.cpp saxs.cpp lib_choral.cpp pdf.cpp WeightedDistribMean.cpp
+
+-rapper_LDADD = ../gc7.0/libgc.la ../libxml2/libxml2.la
++rapper_LDADD = @GC_LIBS@ @LIBXML_LIBS@
+
+ pkgdatadir = $(datadir)/rapper
+ dist_pkgdata_DATA = params.xml
+
+-INCLUDES = -I. -I../gc7.0/include -I../libxml2/include
++INCLUDES = -I. @LIBXML_CFLAGS@ @GC_CFLAGS@
+ #SUBDIRS = \
+ #@PYTHON_USE_TRUE@ python
+
+diff --git a/src/rapper/Makefile.am b/src/rapper/Makefile.am
+index e78b10d..486b931 100755
+--- a/src/rapper/Makefile.am
++++ b/src/rapper/Makefile.am
+@@ -1,3 +1,3 @@
+-SUBDIRS = libxml2 gc7.0 LOOP data
++SUBDIRS = LOOP data
+
+ EXTRA_DIST =
+diff --git a/src/rapper/configure.ac b/src/rapper/configure.ac
+index 5e4ef69..268a579 100755
+--- a/src/rapper/configure.ac
++++ b/src/rapper/configure.ac
+@@ -48,6 +48,13 @@ AM_CONDITIONAL(AMDEP, test "x$enable_dependency_tracking" != xno)
+
+ AC_SUBST(rapper_LDFLAGS)
+
+-AC_CONFIG_SUBDIRS([gc7.0 libxml2])
++PKG_CHECK_MODULES([LIBXML],[libxml-2.0])
++AC_SUBST([LIBXML_CFLAGS])
++AC_SUBST([LIBXML_LIBS])
++
++PKG_CHECK_MODULES([GC],[bdw-gc])
++AC_SUBST([GC_CFLAGS])
++AC_SUBST([GC_LIBS])
++
+ #AC_OUTPUT(Makefile LOOP/Makefile LOOP/python/Makefile data/Makefile)
+ AC_OUTPUT(Makefile LOOP/Makefile data/Makefile)
diff --git a/sci-chemistry/ccp4-apps/files/6.1.3-rename-rapper.patch b/sci-chemistry/ccp4-apps/files/6.1.3-rename-rapper.patch
deleted file mode 100644
index a71c1354436c..000000000000
--- a/sci-chemistry/ccp4-apps/files/6.1.3-rename-rapper.patch
+++ /dev/null
@@ -1,77 +0,0 @@
---- src/rapper/LOOP/Makefile.in 2008-05-29 16:39:40.000000000 +0200
-+++ src/rapper/LOOP/Makefile.in.new 2009-03-12 20:40:03.157602172 +0100
-@@ -111,9 +111,9 @@
- pyexecdir = @pyexecdir@
- pythondir = @pythondir@
- rapper_LDFLAGS = @rapper_LDFLAGS@
--bin_PROGRAMS = rapper
-+bin_PROGRAMS = rappermc
-
--rapper_SOURCES = \
-+rappermc_SOURCES = \
- kip.h aaconv.cpp atomconv.cpp kip_snake.cpp \
- kip_pdb.cpp measure.cpp lib_frags.cpp ran2.cpp \
- heap.cpp queue.cpp 3Dgeom.cpp space_grid.cpp list.cpp search_residue.cpp bitfield.cpp \
-@@ -129,7 +129,7 @@
- residue_range.cpp pop_search_frags.cpp saxs.cpp lib_choral.cpp pdf.cpp WeightedDistribMean.cpp
-
-
--rapper_LDADD = ../gc7.0/libgc.la ../libxml2/libxml2.la
-+rappermc_LDADD = ../gc7.0/libgc.la ../libxml2/libxml2.la
- dist_pkgdata_DATA = params.xml
-
- INCLUDES = -I. -I../gc7.0/include -I../libxml2/include
-@@ -139,7 +139,7 @@
- bin_PROGRAMS = rapper$(EXEEXT)
- PROGRAMS = $(bin_PROGRAMS)
-
--am_rapper_OBJECTS = aaconv.$(OBJEXT) atomconv.$(OBJEXT) \
-+am_rappermc_OBJECTS = aaconv.$(OBJEXT) atomconv.$(OBJEXT) \
- kip_snake.$(OBJEXT) kip_pdb.$(OBJEXT) measure.$(OBJEXT) \
- lib_frags.$(OBJEXT) ran2.$(OBJEXT) heap.$(OBJEXT) \
- queue.$(OBJEXT) 3Dgeom.$(OBJEXT) space_grid.$(OBJEXT) \
-@@ -164,8 +164,8 @@
- iterator.$(OBJEXT) residue_range.$(OBJEXT) \
- pop_search_frags.$(OBJEXT) saxs.$(OBJEXT) lib_choral.$(OBJEXT) \
- pdf.$(OBJEXT) WeightedDistribMean.$(OBJEXT)
--rapper_OBJECTS = $(am_rapper_OBJECTS)
--rapper_DEPENDENCIES = ../gc7.0/libgc.la ../libxml2/libxml2.la
-+rappermc_OBJECTS = $(am_rapper_OBJECTS)
-+rappermc_DEPENDENCIES = ../gc7.0/libgc.la ../libxml2/libxml2.la
-
- DEFS = @DEFS@
- DEFAULT_INCLUDES = -I. -I$(srcdir)
-@@ -233,11 +233,11 @@
- CCLD = $(CC)
- LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
- $(AM_LDFLAGS) $(LDFLAGS) -o $@
--DIST_SOURCES = $(rapper_SOURCES)
-+DIST_SOURCES = $(rappermc_SOURCES)
- DATA = $(dist_pkgdata_DATA)
-
- DIST_COMMON = $(dist_pkgdata_DATA) Makefile.am Makefile.in
--SOURCES = $(rapper_SOURCES)
-+SOURCES = $(rappermc_SOURCES)
-
- all: all-am
-
---- src/rapper/LOOP/Makefile.am 2008-01-24 15:08:17.000000000 +0100
-+++ src/rapper/LOOP/Makefile.am.new 2009-03-12 23:01:56.697533874 +0100
-@@ -1,6 +1,6 @@
--bin_PROGRAMS = rapper
-+bin_PROGRAMS = rappermc
-
--rapper_SOURCES = \
-+rappermc_SOURCES = \
- kip.h aaconv.cpp atomconv.cpp kip_snake.cpp \
- kip_pdb.cpp measure.cpp lib_frags.cpp ran2.cpp \
- heap.cpp queue.cpp 3Dgeom.cpp space_grid.cpp list.cpp search_residue.cpp bitfield.cpp \
-@@ -15,7 +15,7 @@
- hash_table.cpp surface.cpp parse.cpp band.cpp edensity.cpp read_map.cpp iterator.cpp \
- residue_range.cpp pop_search_frags.cpp saxs.cpp lib_choral.cpp pdf.cpp WeightedDistribMean.cpp
-
--rapper_LDADD = ../gc7.0/libgc.la ../libxml2/libxml2.la
-+rappermc_LDADD = ../gc7.0/libgc.la ../libxml2/libxml2.la
-
- pkgdatadir = $(datadir)/rapper
- dist_pkgdata_DATA = params.xml
diff --git a/sci-chemistry/ccp4-apps/files/6.1.3-rename-truncate.patch b/sci-chemistry/ccp4-apps/files/6.1.3-rename-truncate.patch
deleted file mode 100644
index 43bfcf7c7a0e..000000000000
--- a/sci-chemistry/ccp4-apps/files/6.1.3-rename-truncate.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-coreutils now installs a binary called truncate.
-
---- src/Makefile.in.orig 2009-03-02 23:25:45.000000000 -0800
-+++ src/Makefile.in 2009-03-02 23:25:53.000000000 -0800
-@@ -41,7 +41,7 @@
- professs r500 rantan rebatch reindex revise rfcorr rotamer rotmat \
- rstats rwcontents sapi scaleit scalepack2mtz seqwt sfall sigmaa sortmtz sortwater \
- stgrid stnet surface tffc tracer \
--truncate unique vecref vectors volume watertidy watncs watpeak \
-+ftruncate unique vecref vectors volume watertidy watncs watpeak \
- wilson $(CIFTARGETS)
-
- BALBESTARGETS = search_DB get_structure_DB f2cif check_file_DB check_cell_sg \
-@@ -982,7 +982,7 @@
- surface: $(srcdir)/surface.f
- tffc: $(srcdir)/tffc.f
- tracer: $(srcdir)/tracer.f
--truncate: $(srcdir)/truncate.f
-+ftruncate: $(srcdir)/truncate.f
- unique: $(srcdir)/unique.f
- vecref: $(srcdir)/vecref.f
- vectors: $(srcdir)/vectors.f
---- examples/unix/runnable/truncate.exam.orig 2009-03-02 23:35:04.000000000 -0800
-+++ examples/unix/runnable/truncate.exam 2009-03-02 23:35:11.000000000 -0800
-@@ -15,7 +15,7 @@
- exit 1
- fi
- #
--truncate hklin $CCP4_SCR/aucn_mrg.mtz \
-+ftruncate hklin $CCP4_SCR/aucn_mrg.mtz \
- hklout $CCP4_SCR/aucn_trn.mtz <<EOF-trunc
- title DMSO red aucn2 Data - mosflm
- truncate yes
-@@ -28,7 +28,7 @@
- # do this if you already have Fs but want to look at the
- # output graphs of TRUNCATE
-
--truncate hklin $CEXAM/rnase/rnase18.mtz <<EOF
-+ftruncate hklin $CEXAM/rnase/rnase18.mtz <<EOF
- title Analysis of rnase data
- labin F=FNAT SIGF=SIGFNAT
- nresidue 192
diff --git a/sci-chemistry/ccp4-apps/files/6.1.3-setup.patch b/sci-chemistry/ccp4-apps/files/6.1.3-setup.patch
deleted file mode 100644
index c85c688debe4..000000000000
--- a/sci-chemistry/ccp4-apps/files/6.1.3-setup.patch
+++ /dev/null
@@ -1,336 +0,0 @@
-diff --git a/include/ccp4.setup-bash b/include/ccp4.setup-bash
-index 9848101..d76fe3b 100755
---- a/include/ccp4.setup-bash
-+++ b/include/ccp4.setup-bash
-@@ -37,8 +37,8 @@ fi
- # This is usually the directory in which you ran the tar command to unpack the
- # code, and is assumed to be shared between machines at a multi-machine site.
-
--setenv CCP4_MASTER /xtal
--setenv CCP4 $CCP4_MASTER/ccp4-6.1.2
-+setenv CCP4_MASTER /usr
-+setenv CCP4 $CCP4_MASTER
-
- # Check for existence of CCP4_MASTER
- if (! test -d $CCP4_MASTER) ; then
-@@ -54,7 +54,7 @@ fi
- # files. A dedicated scratch filesystem is probably better than (/usr)/tmp
- # BINSORT_SCR: a scratch directory for binsort's use; normally same as CCP4_SCR
-
--setenv CCP4_SCR /tmp/$USER
-+setenv CCP4_SCR /tmp/$USER
- # check to see if this exists and if not try to make it
- test -d $CCP4_SCR || mkdir $CCP4_SCR
- test -d $CCP4_SCR || \
-@@ -70,7 +70,7 @@ setenv CCP4I_TOP ${CCP4}/ccp4i
- # For 'standard' installations this is /usr/local/bin
- # but note the SGI distributed version of Tcl/Tk is not
- # appropriate version
--setenv CCP4I_TCLTK /usr/local/bin
-+setenv CCP4I_TCLTK /usr/bin
- # CCP4I_HELP - directory contain ccp4i help - default is $CCP4I_TOP/help
- setenv CCP4I_HELP ${CCP4I_TOP}/help
-
-@@ -128,7 +128,7 @@ setenv GFORTRAN_UNBUFFERED_ALL Y
- # # for multiple systems
- # foo)
- setenv CBIN $CCP4/bin
-- setenv CLIB $CCP4/lib
-+ setenv CLIB $CCP4/GENTOOLIBDIR
-
- setenv CCP4_BROWSER firefox
-
-@@ -188,9 +188,9 @@ fi
- #Python path for the subprocess fixed module
-
- if [ $ccp4_first_in_path -eq 1 ]; then
-- setenv PYTHONPATH ${CCP4}/share/python:${PYTHONPATH}
-+ setenv PYTHONPATH ${CCP4}/share/ccp4/smartie:${CCP4I_TOP}/python:${PYTHONPATH}
- else
-- setenv PYTHONPATH ${PYTHONPATH}:${CCP4}/share/python
-+ setenv PYTHONPATH ${PYTHONPATH}:${CCP4}/share/ccp4/smartie:${CCP4I_TOP}/python
- fi
-
- ### PLOT_COMMAND PRINT_COMMAND for the XCCPJIFFY programs to compile ###
-@@ -292,14 +292,12 @@ test -r $CCP4/include/ccp4.msg && cat $CCP4/include/ccp4.msg
-
- ### dbCCP4i database handler setup ###
-
--setenv DBCCP4I_TOP ${CCP4}/share/dbccp4i
-+setenv DBCCP4I_TOP ${CCP4}/share/ccp4/dbccp4i
-
- ### IMOSFLM environment is now defined here
-
- setenv MOSFLM_EXEC ${CBIN}/ipmosflm
- setenv MOSFLM_WISH ${CCP4I_TCLTK}/wish
--setenv IMOSFLM_VERSION "1.0.0"
--
-
- ### MMCIFDIC is now defined here. cif_mmdic.lib is a binary file ===
- # so on multiple installs it need to be unique and not in $CLIBD
-@@ -309,21 +307,13 @@ setenv MMCIFDIC $CLIB/cif_mmdic.lib
- ### MOLREPLIB Point to the location of the files bs-zeros.dat ps.resource symlib.blc
- # They are distributed with CCP4 in $CLIBD. This env must have the trailing \ or /
-
--setenv MOLREPLIB $CCP4/lib/data/monomers/
-+setenv MOLREPLIB $CCP4/share/ccp4/data/monomers/
-
- ### CRANK points to location of Crank automation suite within ccp4i
-
--setenv CRANK $CCP4/ccp4i/crank
-+setenv CRANK $CCP4I_TOP/bin/crank
- setenv CCP4_CRANK 1
-
--### XIA2 setup
--# XIAROOT directory (default is under the share folder)
--
--if test -e $CCP4/share/XIAROOT/setup.sh
--then
--. $CCP4/share/XIAROOT/setup.sh
--fi
--
- # Note: The PATH is updated with the xia2 Applications directory in the
- # construct below.
-
-@@ -339,7 +329,7 @@ fi
- # They are distributed with CCP4 in $CLIBD/monomers. This env must have
- # the trailing \ or /
-
--setenv CLIBD_MON $CCP4/lib/data/monomers/
-+setenv CLIBD_MON $CCP4/share/ccp4/data/monomers/
-
- ### PUBLIC_FONT84, CCP4_HELPDIR, HELPDIR, MOSHELPFILE ###
- # (essential for the relevant programs)
-@@ -347,10 +337,10 @@ setenv PUBLIC_FONT84 $CLIB/font84.dat # plot84 fonts [used by plot84lib]
-
- # location of VMS-style help files required for mosflm [used by hlplib, chelp,
- # chlp, (ip)mosflm]:
--setenv CCP4_HELPDIR $CCP4/help/ # NB trailing /
-+setenv CCP4_HELPDIR $CCP4I_TOP/help/ # NB trailing /
-
- # Rasmol path. Needed for prog. to find rasmol.hlp
--setenv RASMOLPATH $CCP4/x-windows/RasMol/src
-+setenv RASMOLPATH $CCP4/GENTOOLIBDIR/rasmol
-
- # CCP4 executables and scripts live in $CBIN and $CETC respectively; put them
- # on the path in an appropriate order for scripts to be used as wrappers for
-@@ -373,32 +363,14 @@ done
-
- # Optional (useful) additional environment variables
- setenv CCP4 $CCP4
-- setenv CDOC $CCP4/doc
-- setenv CHTML $CCP4/html
-- setenv CETC $CCP4/etc
-- setenv CEXAM $CCP4/examples
-+ setenv CDOC $DBCCP4I_TOP/doc
-+ setenv CHTML $CCP4I_TOP/html
-+ setenv CETC $CCP4I_TOP/etc
-+ setenv CEXAM $CLIB/ccp4/examples
- setenv CINCL $CCP4/include
-- setenv CLIBD $CCP4/lib/data
-- setenv CLIBS $CCP4/lib/src
-- setenv CPROG $CCP4/src
-+ setenv CLIBD $CCP4/share/ccp4/data
-
- if [ "`basename $SHELL`" != "ksh" ]; then
--# useful aliases, at least for developers
-- alias ccp4 'pushd $CCP4>/dev/null'
-- alias xtal 'pushd $CCP4_MASTER>/dev/null'
-- alias cbin 'pushd $CBIN>/dev/null'
-- alias cetc 'pushd $CETC>/dev/null'
-- alias cprog 'pushd $CPROG>/dev/null'
-- alias cincl 'pushd $CINCL>/dev/null'
-- alias clib 'pushd $CLIB>/dev/null'
-- alias clibd 'pushd $CLIBD>/dev/null'
-- alias clibs 'pushd $CLIBS>/dev/null'
-- alias cbin 'pushd $CBIN>/dev/null'
-- alias cexam 'pushd $CEXAM>/dev/null'
-- alias cdoc 'pushd $CDOC>/dev/null'
-- alias chtml 'pushd $CHTML>/dev/null'
-- alias ccp4help '$CCP4_BROWSER $CHTML/INDEX.html \&'
--
- ### laue, lget, linkimages ###
-
- ### only if we have the Laue software suite...
-@@ -430,23 +402,6 @@ if [ "`basename $SHELL`" != "ksh" ]; then
- alias lbin 'pushd $CBIN>/dev/null'
-
- fi
--
-+else
- unset alias # clean up
- fi # ksh test
--
--# Set-up cctbx environment
--test -r $CCP4/lib/cctbx/cctbx_build/setpaths.sh && . $CCP4/lib/cctbx/cctbx_build/setpaths.sh
--
--# Set-up phaser environment
--if ( test -d $CCP4/src/phaser) ; then
-- phaser_mtype=`$CCP4/src/phaser/bin/machine_type`
-- phaser_version=`grep PHASER_VERSION $CCP4/src/phaser/conf/version.sh | awk '{print $3}'`
-- phaser_setup_file="${CCP4}/src/phaser/phaser-${phaser_version}/build/${phaser_mtype}/setpaths.sh"
-- test -r $phaser_setup_file && . $phaser_setup_file
--fi
--
--#BALBES root configuration
--if ( test -d $CCP4/share/balbes/BALBES_0.0.1)
--then
-- setenv BALBES_ROOT $CCP4/share/balbes/BALBES_0.0.1
--fi
-diff --git a/include/ccp4.setup-csh b/include/ccp4.setup-csh
-index 42f0820..ed3c671 100755
---- a/include/ccp4.setup-csh
-+++ b/include/ccp4.setup-csh
-@@ -24,8 +24,8 @@
- # This is usually the directory in which you ran the tar command to unpack the
- # code, and is assumed to be shared between machines at a multi-machine site.
-
--setenv CCP4_MASTER /xtal
--setenv CCP4 $CCP4_MASTER/ccp4-6.1.2
-+setenv CCP4_MASTER /usr
-+setenv CCP4 $CCP4_MASTER
-
- # Check for existence of CCP4_MASTER
- if (! -e $CCP4_MASTER) then
-@@ -57,7 +57,7 @@ setenv CCP4I_TOP ${CCP4}/ccp4i
- # For 'standard' installations this is /usr/local/bin
- # but note the SGI distributed version of Tcl/Tk is not
- # appropriate version
--setenv CCP4I_TCLTK /usr/local/bin
-+setenv CCP4I_TCLTK /usr/bin
- # CCP4I_HELP - directory contain ccp4i help - default is $CCP4I_TOP/help
- setenv CCP4I_HELP ${CCP4I_TOP}/help
-
-@@ -115,7 +115,7 @@ setenv GFORTRAN_UNBUFFERED_ALL Y
- # # for multiple systems
- # case 'foo':
- setenv CBIN $CCP4/bin
-- setenv CLIB $CCP4/lib
-+ setenv CLIB $CCP4/GENTOOLIBDIR
-
- setenv CCP4_BROWSER firefox
-
-@@ -180,9 +180,9 @@ endif
- #Python path for the subprocess fixed module
- if (${?PYTHONPATH}) then
- if ($ccp4_first_in_path) then
-- setenv PYTHONPATH ${CCP4}/share/python:${PYTHONPATH}
-+ setenv PYTHONPATH ${CCP4}/share/ccp4/smartie:${CCP4I_TOP}/python:${PYTHONPATH}
- else
-- setenv PYTHONPATH ${PYTHONPATH}:${CCP4}/share/python
-+ setenv PYTHONPATH ${PYTHONPATH}:${CCP4}/share/ccp4/smartie:${CCP4I_TOP}/python
- endif
- else
- setenv PYTHONPATH ${CCP4}/share/python
-@@ -284,13 +284,12 @@ if (-e $CCP4/include/ccp4.msg) cat $CCP4/include/ccp4.msg
-
- ### dbCCP4i database handler setup ###
-
--setenv DBCCP4I_TOP ${CCP4}/share/dbccp4i
-+setenv DBCCP4I_TOP ${CCP4}/share/ccp4/dbccp4i
-
- ### IMOSFLM environment is now defined here
-
- setenv MOSFLM_EXEC ${CBIN}/ipmosflm
- setenv MOSFLM_WISH ${CCP4I_TCLTK}/wish
--setenv IMOSFLM_VERSION "1.0.0"
-
- ### MMCIFDIC is now defined here. cif_mmdic.lib is a binary file ===
- # so on multiple installs it need to be unique and not in $CLIBD
-@@ -300,20 +299,13 @@ setenv MMCIFDIC $CLIB/cif_mmdic.lib
- ### MOLREPLIB Point to the location of the files bs-zeros.dat ps.resource symlib.blc
- # They are distributed with CCP4 in $CLIBD. This env must have the trailing \ or /
-
--setenv MOLREPLIB $CCP4/lib/data/monomers/
-+setenv MOLREPLIB $CCP4/share/ccp4/data/monomers/
-
- ### CRANK points to location of Crank automation suite within ccp4i
-
--setenv CRANK $CCP4/ccp4i/crank
-+setenv CRANK $CCP4I_TOP/bin/crank
- setenv CCP4_CRANK 1
-
--### XIA2 setup
--# XIAROOT directory (default is under the share folder)
--
--if (-e $CCP4/share/XIAROOT/setup.csh) then
-- source $CCP4/share/XIAROOT/setup.csh
--endif
--
- # Note: The PATH is updated with the xia2 Applications directory in the
- # construct below.
-
-@@ -328,7 +320,7 @@ endif
- # They are distributed with CCP4 in $CLIBD/monomers. This env must have
- # the trailing \ or /
-
--setenv CLIBD_MON $CCP4/lib/data/monomers/
-+setenv CLIBD_MON $CCP4/share/ccp4/data/monomers/
-
- ### PUBLIC_FONT84, CCP4_HELPDIR, HELPDIR, MOSHELPFILE ###
- # (essential for the relevant programs)
-@@ -339,7 +331,7 @@ setenv PUBLIC_FONT84 $CLIB/font84.dat # plot84 fonts [used by plot84lib]
- setenv CCP4_HELPDIR $CCP4/help/ # NB trailing /
-
- # Rasmol path. Needed for prog. to find rasmol.hlp
--setenv RASMOLPATH $CCP4/x-windows/RasMol/src
-+setenv RASMOLPATH $CCP4/GENTOOLIBDIR/rasmol
-
- # CCP4 executables and scripts live in $CBIN and $CETC respectively; put them
- # on the path in an appropriate order for scripts to be used as wrappers for
-@@ -366,30 +358,12 @@ end
-
- # Optional (useful) additional environment variables
- setenv CCP4 $CCP4
-- setenv CDOC $CCP4/doc
-- setenv CHTML $CCP4/html
-- setenv CETC $CCP4/etc
-- setenv CEXAM $CCP4/examples
-+ setenv CDOC $DBCCP4I_TOP/doc
-+ setenv CHTML $CCP4I_TOP/html
-+ setenv CETC $CCP4I_TOP/etc
-+ setenv CEXAM $CLIB/ccp4/examples
- setenv CINCL $CCP4/include
-- setenv CLIBD $CCP4/lib/data
-- setenv CLIBS $CCP4/lib/src
-- setenv CPROG $CCP4/src
--
--# useful aliases, at least for developers
-- alias ccp4 'pushd $CCP4>/dev/null'
-- alias xtal 'pushd $CCP4_MASTER>/dev/null'
-- alias cbin 'pushd $CBIN>/dev/null'
-- alias cetc 'pushd $CETC>/dev/null'
-- alias cprog 'pushd $CPROG>/dev/null'
-- alias cincl 'pushd $CINCL>/dev/null'
-- alias clib 'pushd $CLIB>/dev/null'
-- alias clibd 'pushd $CLIBD>/dev/null'
-- alias clibs 'pushd $CLIBS>/dev/null'
-- alias cbin 'pushd $CBIN>/dev/null'
-- alias cexam 'pushd $CEXAM>/dev/null'
-- alias cdoc 'pushd $CDOC>/dev/null'
-- alias chtml 'pushd $CHTML>/dev/null'
-- alias ccp4help '$CCP4_BROWSER $CHTML/INDEX.html &'
-+ setenv CLIBD $CCP4/share/ccp4/data
-
- ### laue, lget, linkimages ###
-
-@@ -421,19 +395,3 @@ end
- #
-
- endif
--
--# Set-up cctbx environment
--if (-e $CCP4/lib/cctbx/cctbx_build/setpaths.csh) source $CCP4/lib/cctbx/cctbx_build/setpaths.csh
--
--# Set-up phaser environment
--if (-d $CCP4/src/phaser) then
-- set phaser_mtype = `$CCP4/src/phaser/bin/machine_type`
-- set phaser_version = `grep PHASER_VERSION $CCP4/src/phaser/conf/version.csh | awk '{print $3}'`
-- set phaser_setup_file = "${CCP4}/src/phaser/phaser-${phaser_version}/build/${phaser_mtype}/setpaths.csh"
-- if (-e $phaser_setup_file) source $phaser_setup_file
--endif
--
--#BALBES root configuration
--if ( -d $CCP4/share/balbes/BALBES_0.0.1) then
-- setenv BALBES_ROOT $CCP4/share/balbes/BALBES_0.0.1
--endif