summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-24 16:34:18 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-24 16:34:18 +0000
commitd07534a6cf03c0a1361b7d9ae7f59914a30445ff (patch)
treefde1b392716b98d772f09f6e793c79af57bf75d7 /sci-chemistry/elem/elem-1.0.3-r1.ebuild
parentMoving to sci-chemistry/elem (diff)
downloadgentoo-2-d07534a6cf03c0a1361b7d9ae7f59914a30445ff.tar.gz
gentoo-2-d07534a6cf03c0a1361b7d9ae7f59914a30445ff.tar.bz2
gentoo-2-d07534a6cf03c0a1361b7d9ae7f59914a30445ff.zip
Moved from app-sci/elem to sci-chemistry/elem.
Diffstat (limited to 'sci-chemistry/elem/elem-1.0.3-r1.ebuild')
-rw-r--r--sci-chemistry/elem/elem-1.0.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/elem/elem-1.0.3-r1.ebuild b/sci-chemistry/elem/elem-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..24fbab7b1ca7
--- /dev/null
+++ b/sci-chemistry/elem/elem-1.0.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/elem/elem-1.0.3-r1.ebuild,v 1.1 2004/12/24 16:34:18 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="periodic table of the elements"
+HOMEPAGE="http://elem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elem/${PN}-src-${PV}-Linux.tgz"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/libc
+ x11-libs/xforms"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e 's:\(^LIBS = .*\):\1 -lXpm:' -i Makefile || die "sed failed"
+}
+
+src_compile () {
+ emake COMPILER="$(tc-getCC)" FLAGS="${CFLAGS}" all || die "Build failed."
+}
+
+src_install () {
+ into /usr
+ dobin elem elem-de elem-en
+ dohtml -r doc/*
+}
+