summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2010-05-16 02:54:06 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2010-05-16 02:54:06 +0000
commita2943dfdadd6a36d0dcb5a3e8f69cdca970034c4 (patch)
tree2bcaa5e9adc029eb0bafdd9bbdba8e5a2250cda5 /sci-chemistry/gchemutils/gchemutils-0.10.12.ebuild
parentremove old (diff)
downloadgentoo-2-a2943dfdadd6a36d0dcb5a3e8f69cdca970034c4.tar.gz
gentoo-2-a2943dfdadd6a36d0dcb5a3e8f69cdca970034c4.tar.bz2
gentoo-2-a2943dfdadd6a36d0dcb5a3e8f69cdca970034c4.zip
Adding latest gchemutils and removing old, broken version. Closing bugs #256314 #303363 #312415 - thanks for the reports :)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gchemutils/gchemutils-0.10.12.ebuild')
-rw-r--r--sci-chemistry/gchemutils/gchemutils-0.10.12.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-chemistry/gchemutils/gchemutils-0.10.12.ebuild b/sci-chemistry/gchemutils/gchemutils-0.10.12.ebuild
new file mode 100644
index 000000000000..a837a2bb7c67
--- /dev/null
+++ b/sci-chemistry/gchemutils/gchemutils-0.10.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gchemutils/gchemutils-0.10.12.ebuild,v 1.1 2010/05/16 02:54:06 je_fro Exp $
+
+EAPI=2
+GCONF_DEBUG=no
+MY_P=gnome-chemistry-utils-${PV}
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="C++ classes and Gtk+-2 widgets related to chemistry"
+HOMEPAGE="http://www.nongnu.org/gchemutils/"
+SRC_URI="http://savannah.nongnu.org/download/gchemutils/0.10/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="gnome-base/libglade:2.0
+ >=gnome-base/libgnomeprintui-2.4
+ >=gnome-extra/libgsf-1.14[gnome]
+ >=x11-libs/goffice-0.6.5:0.6[gnome]
+ x11-libs/gtkglext
+ app-text/gnome-doc-utils
+ >=sci-chemistry/openbabel-2.1.1
+ sci-chemistry/bodr
+ sci-chemistry/chemical-mime-data"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ app-text/rarian
+ dev-util/intltool"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ gnome2_src_prepare
+# epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ eautoreconf
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --docdir=/usr/share/doc/${PN}/html \
+ --disable-update-databases \
+ --disable-mozilla-plugin
+}
+
+pkg_postinst() {
+ elog "You can safely ignore any 'Unknown media type in type blah' warnings above."
+ elog "For more info see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=420795 "
+}