summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-12 07:54:58 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-12 07:54:58 +0000
commit49f5951e3cc57ef06ae24a98066aed9d9cadffbc (patch)
tree326abd5719a05249e5014885e119a5bd531dd95d /sci-chemistry/molrep
parentVersion Bump (diff)
downloadgentoo-2-49f5951e3cc57ef06ae24a98066aed9d9cadffbc.tar.gz
gentoo-2-49f5951e3cc57ef06ae24a98066aed9d9cadffbc.tar.bz2
gentoo-2-49f5951e3cc57ef06ae24a98066aed9d9cadffbc.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/molrep')
-rw-r--r--sci-chemistry/molrep/ChangeLog8
-rw-r--r--sci-chemistry/molrep/molrep-10.2.38.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/sci-chemistry/molrep/ChangeLog b/sci-chemistry/molrep/ChangeLog
index 05d60deddc07..cfc4f43f4c7d 100644
--- a/sci-chemistry/molrep/ChangeLog
+++ b/sci-chemistry/molrep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/molrep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.2 2010/02/15 19:51:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.3 2010/03/12 07:54:58 jlec Exp $
+
+*molrep-10.2.38 (12 Mar 2010)
+
+ 12 Mar 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +molrep-10.2.38.ebuild:
+ Version Bump
15 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> molrep-10.2.35.ebuild,
metadata.xml:
diff --git a/sci-chemistry/molrep/molrep-10.2.38.ebuild b/sci-chemistry/molrep/molrep-10.2.38.ebuild
new file mode 100644
index 000000000000..f00fbabb678d
--- /dev/null
+++ b/sci-chemistry/molrep/molrep-10.2.38.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/molrep-10.2.38.ebuild,v 1.1 2010/03/12 07:54:58 jlec Exp $
+
+EAPI="3"
+
+inherit base multilib toolchain-funcs
+
+DESCRIPTION="molecular replacement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/molrep.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sci-libs/ccp4-libs-6.1.3
+ sci-libs/mmdb
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/10.2.35-respect-FLAGS.patch
+ )
+
+src_compile() {
+ cd "${S}"/src
+ emake clean || die
+ emake \
+ MR_FORT=$(tc-getFC) \
+ FFLAGS="${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ MR_LIBRARY="-L${EPREFIX}/usr/$(get_libdir) -lccp4f -lccp4c -lmmdb -lccif -llapack -lstdc++ -lm" \
+ || die
+}
+
+src_install() {
+ dobin bin/${PN} || die
+ dodoc readme doc/${PN}.rtf || die
+}