summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-03 12:14:00 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-03 12:14:00 +0000
commit06ecdc9eda884e67d60be6cd3ba9d03e38a1252d (patch)
treec8724402c6bbf0136b44ce57382ce7763460db32 /sci-chemistry/mongochem/mongochem-0.7.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-06ecdc9eda884e67d60be6cd3ba9d03e38a1252d.tar.gz
gentoo-2-06ecdc9eda884e67d60be6cd3ba9d03e38a1252d.tar.bz2
gentoo-2-06ecdc9eda884e67d60be6cd3ba9d03e38a1252d.zip
sci-chemistry/mongochem: Nre ebuild, written by me
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/mongochem/mongochem-0.7.0.ebuild')
-rw-r--r--sci-chemistry/mongochem/mongochem-0.7.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-chemistry/mongochem/mongochem-0.7.0.ebuild b/sci-chemistry/mongochem/mongochem-0.7.0.ebuild
new file mode 100644
index 000000000000..de918f885e98
--- /dev/null
+++ b/sci-chemistry/mongochem/mongochem-0.7.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mongochem/mongochem-0.7.0.ebuild,v 1.1 2014/02/03 12:14:00 jlec Exp $
+
+EAPI=5
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils vcs-snapshot
+
+DESCRIPTION="Application for managing large collections of chemical data"
+HOMEPAGE="http://www.openchemistry.org/"
+#SRC_URI="http://openchemistry.org/files/v0.5/${P}.tar.gz"
+SRC_URI="https://github.com/OpenChemistry/mongochem/archive/df36ebce92024dd4fd1c70eb37eb84e4c51120ff.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-db/mongodb[sharedclient]
+ dev-libs/boost[threads]
+ sci-libs/avogadrolibs[qt4]
+ sci-libs/chemkit
+ sci-libs/vtk[qt4,rendering]
+ sci-chemistry/molequeue
+"
+DEPEND="${RDEPEND}"