summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-23 11:33:46 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-23 11:33:46 +0000
commit744aabd8da3704adc7286ebc780fe89b64e0da58 (patch)
treebb034f521a37399346510967113151c5b98d1762 /sci-chemistry/openbabel-python
parentadd ~arm (diff)
downloadgentoo-2-744aabd8da3704adc7286ebc780fe89b64e0da58.tar.gz
gentoo-2-744aabd8da3704adc7286ebc780fe89b64e0da58.tar.bz2
gentoo-2-744aabd8da3704adc7286ebc780fe89b64e0da58.zip
sci-chemistry/openbabel-python: Add proposed enhancements by mgorny, #448118
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry/openbabel-python')
-rw-r--r--sci-chemistry/openbabel-python/ChangeLog6
-rw-r--r--sci-chemistry/openbabel-python/metadata.xml4
-rw-r--r--sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild22
3 files changed, 13 insertions, 19 deletions
diff --git a/sci-chemistry/openbabel-python/ChangeLog b/sci-chemistry/openbabel-python/ChangeLog
index 57faf7b391e6..507243214e52 100644
--- a/sci-chemistry/openbabel-python/ChangeLog
+++ b/sci-chemistry/openbabel-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/openbabel-python
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.9 2012/12/06 17:09:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/ChangeLog,v 1.10 2012/12/23 11:33:46 jlec Exp $
+
+ 23 Dec 2012; Justin Lecher <jlec@gentoo.org> openbabel-python-2.3.2.ebuild,
+ metadata.xml:
+ Add proposed enhancements by mgorny, #448118
*openbabel-python-2.3.2 (06 Dec 2012)
diff --git a/sci-chemistry/openbabel-python/metadata.xml b/sci-chemistry/openbabel-python/metadata.xml
index 500c61ee3c93..62809327b326 100644
--- a/sci-chemistry/openbabel-python/metadata.xml
+++ b/sci-chemistry/openbabel-python/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
- <longdescription>
+ <herd>sci-chemistry</herd>
+ <longdescription>
OpenBabel is a chemical toolbox designed to speak the many languages of
chemical data. It's an open, collaborative project allowing anyone to
search, convert, analyze, or store data from molecular modeling, chemistry,
diff --git a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
index e94d2f4a8343..fdd7976e70ef 100644
--- a/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
+++ b/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild,v 1.1 2012/12/06 17:09:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild,v 1.2 2012/12/23 11:33:46 jlec Exp $
EAPI=5
@@ -47,7 +47,6 @@ src_prepare() {
src_configure() {
my_impl_src_configure() {
- CMAKE_BUILD_DIR="${BUILD_DIR}"
local mycmakeargs="${mycmakeargs}
-DCMAKE_INSTALL_RPATH=
-DBINDINGS_ONLY=ON
@@ -67,29 +66,20 @@ src_configure() {
}
src_compile() {
- my_impl_src_compile() {
- CMAKE_BUILD_DIR="${BUILD_DIR}"
-
- cmake-utils_src_make bindings_python
- }
-
- python_foreach_impl my_impl_src_compile
+ python_foreach_impl cmake-utils_src_make bindings_python
}
src_test() {
- my_impl_src_test() {
- CMAKE_BUILD_DIR="${BUILD_DIR}"
- cmake-utils_src_test -R py
- }
-
- python_foreach_impl my_impl_src_test
+ python_foreach_impl cmake-utils_src_test -R py
}
src_install() {
my_impl_src_install() {
- cd "${BUILD_DIR}"
+ cd "${BUILD_DIR}" || die
cmake -DCOMPONENT=bindings_python -P cmake_install.cmake
+
+ python_optimize
}
python_foreach_impl my_impl_src_install