summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-07 05:35:44 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-07 05:35:44 +0000
commit160bb39d701a2e08e48601a11c61f8590bbb73b9 (patch)
treee414eda11bb7f15df4db01b1a2ad6ccb2c9e56c7 /sci-chemistry/platon
parent(#226637) Call eautomake wrapper instead of automake directly. (diff)
downloadgentoo-2-160bb39d701a2e08e48601a11c61f8590bbb73b9.tar.gz
gentoo-2-160bb39d701a2e08e48601a11c61f8590bbb73b9.tar.bz2
gentoo-2-160bb39d701a2e08e48601a11c61f8590bbb73b9.zip
(#183828) Bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'sci-chemistry/platon')
-rw-r--r--sci-chemistry/platon/ChangeLog10
-rw-r--r--sci-chemistry/platon/platon-20080702.ebuild76
2 files changed, 84 insertions, 2 deletions
diff --git a/sci-chemistry/platon/ChangeLog b/sci-chemistry/platon/ChangeLog
index 5a90c1d3f31f..c371b1481e64 100644
--- a/sci-chemistry/platon/ChangeLog
+++ b/sci-chemistry/platon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/platon
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.11 2007/07/22 07:21:34 dberkholz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/ChangeLog,v 1.12 2008/07/07 05:35:44 dberkholz Exp $
+
+*platon-20080702 (07 Jul 2008)
+
+ 07 Jul 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +platon-20080702.ebuild:
+ (#183828) Bump.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
platon-20060717.ebuild, platon-20070425.ebuild:
diff --git a/sci-chemistry/platon/platon-20080702.ebuild b/sci-chemistry/platon/platon-20080702.ebuild
new file mode 100644
index 000000000000..104437cfe255
--- /dev/null
+++ b/sci-chemistry/platon/platon-20080702.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/platon/platon-20080702.ebuild,v 1.1 2008/07/07 05:35:44 dberkholz Exp $
+
+inherit fortran toolchain-funcs flag-o-matic
+
+FORTRAN="g77 gfortran"
+DESCRIPTION="Versatile, SHELX-97 compatible, multipurpose crystallographic tool"
+HOMEPAGE="http://www.cryst.chem.uu.nl/platon/"
+SRC_URI="${P}.tar.gz"
+RESTRICT="fetch"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+# Can't do libf2c dependent on whether <gcc-4 is selected for the build,
+# so we must always require it
+RDEPEND="x11-libs/libX11
+ dev-libs/libf2c"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ einfo "Download ${A/-${PV}} from ftp://xraysoft.chem.uu.nl/pub/unix/,"
+ einfo "rename it to ${A} and place it"
+ einfo "in ${DISTDIR}."
+ einfo "If there is a digest mismatch, please file a bug"
+ einfo "at https://bugs.gentoo.org/ -- a version bump"
+ einfo "is probably required."
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gunzip platon.f.Z xdrvr.c.gz
+}
+
+src_compile() {
+ local F2C
+ # Needs signal_ and system_, which g77 and libf2c provide,
+ # but gfortran does not
+ if [[ ${FORTRANC} != g77 ]]; then
+ F2C="-lf2c"
+ fi
+
+ # easy to ICE, at least on gcc 4.3
+ strip-flags
+
+ COMMAND="$(tc-getCC) -c ${CFLAGS} xdrvr.c"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of xdrvr.c failed"
+ COMMAND="${FORTRANC} -c ${FFLAGS:- -O2} -fno-second-underscore platon.f"
+ echo ${COMMAND}
+ ${COMMAND} || die "Compilation of platon.f failed"
+ COMMAND="${FORTRANC} -o platon ${LDFLAGS} platon.o xdrvr.o -lX11 ${F2C}"
+ echo ${COMMAND}
+ ${COMMAND} || die "Linking failed"
+}
+
+src_install() {
+ dobin platon
+
+ dosym platon /usr/bin/pluton
+ dosym platon /usr/bin/s
+ dosym platon /usr/bin/cifchk
+ dosym platon /usr/bin/helena
+ dosym platon /usr/bin/stidy
+
+ insinto /usr/lib/platon
+ doins check.def
+
+ echo "CHECKDEF=\"/usr/lib/platon/check.def\"" > ${T}/env.d
+ newenvd ${T}/env.d 50platon
+
+ dodoc README.* VALIDATION.DOC
+}