summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-09 06:48:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-09 06:48:36 +0000
commit777d08fb89d6707e671fe96ad192e349a03a907d (patch)
treeafcb8bc8543bee29470f3dba2409cf268e8d058c /sci-chemistry/pymol-apbs-plugin
parentremoved old version which having problems with PYTHON ABIs stuff (diff)
downloadgentoo-2-777d08fb89d6707e671fe96ad192e349a03a907d.tar.gz
gentoo-2-777d08fb89d6707e671fe96ad192e349a03a907d.tar.bz2
gentoo-2-777d08fb89d6707e671fe96ad192e349a03a907d.zip
Version Bump, fixes for python.eclass usage
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-chemistry/pymol-apbs-plugin')
-rw-r--r--sci-chemistry/pymol-apbs-plugin/ChangeLog13
-rw-r--r--sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild48
-rw-r--r--sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild4
-rw-r--r--sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p18.ebuild57
4 files changed, 72 insertions, 50 deletions
diff --git a/sci-chemistry/pymol-apbs-plugin/ChangeLog b/sci-chemistry/pymol-apbs-plugin/ChangeLog
index aea3bc26a808..0e3884e07be2 100644
--- a/sci-chemistry/pymol-apbs-plugin/ChangeLog
+++ b/sci-chemistry/pymol-apbs-plugin/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sci-chemistry/pymol-apbs-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/ChangeLog,v 1.6 2010/03/23 13:53:50 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/ChangeLog,v 1.7 2010/06/09 06:48:36 jlec Exp $
+
+ 09 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ -pymol-apbs-plugin-0_p11.ebuild, pymol-apbs-plugin-0_p15.ebuild,
+ +pymol-apbs-plugin-0_p18.ebuild:
+ Version Bump, fixes for python.eclass usage, removed old version
+
+*pymol-apbs-plugin-0_p18 (09 Jun 2010)
+
+ 09 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ pymol-apbs-plugin-0_p15.ebuild, +pymol-apbs-plugin-0_p18.ebuild:
+ Version Bump, fixes for python.eclass usage
23 Mar 2010; Christian Faulhammer <fauli@gentoo.org>
pymol-apbs-plugin-0_p15.ebuild:
diff --git a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild
deleted file mode 100644
index 3df525ec13ba..000000000000
--- a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p11.ebuild,v 1.1 2010/02/01 21:40:04 jlec Exp $
-
-EAPI="2"
-
-inherit python
-
-MY_PV="${PV##*_p}"
-
-DESCRIPTION="APBS plugin for pymol"
-HOMEPAGE="http://sourceforge.net/projects/pymolapbsplugin/"
-SRC_URI="http://pymolapbsplugin.svn.sourceforge.net/viewvc/pymolapbsplugin/trunk/src/apbsplugin.py?revision=${MY_PV} -> ${P}.py"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LICENSE="pymol"
-IUSE=""
-
-RDEPEND="
- sci-chemistry/apbs
- sci-chemistry/pdb2pqr
- !<sci-chemistry/pymol-1.2.2-r1"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- cp "${DISTDIR}"/${P}.py "${WORKDIR}"/
-}
-
-src_install() {
- sed \
- -e "s:^APBS_BINARY_LOCATION.*:APBS_BINARY_LOCATION = \"${EPREFIX}/usr/bin/apbs\":g" \
- -e "s:^APBS_PSIZE_LOCATION.*:APBS_PSIZE_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/src/\":g" \
- -e "s:^APBS_PDB2PQR_LOCATION.*:APBS_PDB2PQR_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/\":g" \
- -e "s:^TEMPORARY_FILE_DIR.*:TEMPORARY_FILE_DIR = \"./\":g" \
- -i ${P}.py
-
- insinto $(python_get_sitedir)/pmg_tk/startup/
- newins ${P}.py apbs_tools.py || die
-}
-
-pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
-}
diff --git a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild
index 134fdb9725c8..28e963d5e031 100644
--- a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild
+++ b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild,v 1.6 2010/03/23 13:53:50 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p15.ebuild,v 1.7 2010/06/09 06:48:36 jlec Exp $
EAPI="3"
+
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
inherit python
diff --git a/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p18.ebuild b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p18.ebuild
new file mode 100644
index 000000000000..f98082487b27
--- /dev/null
+++ b/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p18.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-apbs-plugin/pymol-apbs-plugin-0_p18.ebuild,v 1.1 2010/06/09 06:48:36 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python
+
+MY_PV="${PV##*_p}"
+
+DESCRIPTION="APBS plugin for pymol"
+HOMEPAGE="http://sourceforge.net/projects/pymolapbsplugin/"
+SRC_URI="http://pymolapbsplugin.svn.sourceforge.net/viewvc/pymolapbsplugin/trunk/src/apbsplugin.py?revision=${MY_PV} -> ${P}.py"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+LICENSE="pymol"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ !<sci-chemistry/pymol-1.2.2-r1"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_unpack() {
+ mkdir "${S}"
+ cp "${DISTDIR}"/${P}.py "${S}"/
+ python_copy_sources
+}
+
+src_install() {
+ installation() {
+ sed \
+ -e "s:^APBS_BINARY_LOCATION.*:APBS_BINARY_LOCATION = \"${EPREFIX}/usr/bin/apbs\":g" \
+ -e "s:^APBS_PSIZE_LOCATION.*:APBS_PSIZE_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/src/\":g" \
+ -e "s:^APBS_PDB2PQR_LOCATION.*:APBS_PDB2PQR_LOCATION = \"${EPREFIX}/$(python_get_sitedir)/pdb2pqr/\":g" \
+ -e "s:^TEMPORARY_FILE_DIR.*:TEMPORARY_FILE_DIR = \"./\":g" \
+ -i ${P}.py
+
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ newins ${P}.py apbs_tools.py || die
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize pmg_tk/startup/apbs_tools.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup pmg_tk/startup/apbs_tools.py
+}