summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-05-13 18:04:58 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-05-13 18:04:58 +0000
commit485bc732cee582efe2b9afe47ad853dc4a622625 (patch)
treefaac51b161ee237820f61b89925aec18570c23a5 /sci-chemistry/pymol
parentStable on x86, #92393 (diff)
downloadgentoo-2-485bc732cee582efe2b9afe47ad853dc4a622625.tar.gz
gentoo-2-485bc732cee582efe2b9afe47ad853dc4a622625.tar.bz2
gentoo-2-485bc732cee582efe2b9afe47ad853dc4a622625.zip
Fixed multilib issue (bug #92103)
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog5
-rw-r--r--sci-chemistry/pymol/Manifest10
-rw-r--r--sci-chemistry/pymol/pymol-0.97.ebuild6
3 files changed, 12 insertions, 9 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 7a2a5e999891..3822b38dfc89 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.4 2005/05/04 15:02:39 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.5 2005/05/13 18:04:58 ribosome Exp $
+
+ 13 May 2005; Olivier Fisette <ribosome@gentoo.org> pymol-0.97.ebuild:
+ Fixed multilib issue (bug #92103).
04 May 2005; David Holm <dholm@gentoo.org> pymol-0.97.ebuild:
Readded to ~ppc. Please don't remove it without filing a proper bug report.
diff --git a/sci-chemistry/pymol/Manifest b/sci-chemistry/pymol/Manifest
index d219c587895f..7b88b54ed2e7 100644
--- a/sci-chemistry/pymol/Manifest
+++ b/sci-chemistry/pymol/Manifest
@@ -1,15 +1,15 @@
+MD5 8ca390e4c4cebbf9a13d0ad1c873b2de pymol-0.95.ebuild 1140
+MD5 6305e57aead6d7ccf8d2a5724f73c17f pymol-0.90.ebuild 1130
+MD5 16b9765991fbb51c11aedb1ac49559ae pymol-0.97.ebuild 1131
+MD5 b55788c23a8af52dc98ede88bf488985 pymol-0.88.ebuild 1030
MD5 b830449032d82b9cba0c3097192da202 ChangeLog 2982
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 b55788c23a8af52dc98ede88bf488985 pymol-0.88.ebuild 1030
-MD5 6305e57aead6d7ccf8d2a5724f73c17f pymol-0.90.ebuild 1130
-MD5 8ca390e4c4cebbf9a13d0ad1c873b2de pymol-0.95.ebuild 1140
-MD5 168fdd30d356eae7d66a1477ccc9aff7 pymol-0.97.ebuild 1112
+MD5 34d172ef31b5038e071b634d4e645cf1 files/pymol-gentoo.diff 1566
MD5 bc61462df500f324f8ba07a1c1f7bdf4 files/digest-pymol-0.88 64
MD5 6970b70ab3710cde34e422cba7cce5c2 files/digest-pymol-0.90 64
MD5 b674c205dd6279884c91077eec6e5442 files/digest-pymol-0.95 64
MD5 cb324029606a6b5048895957143c7a44 files/digest-pymol-0.97 64
MD5 1a6ba582a7928c370c8dfe44c8867e7c files/header_order.patch 905
MD5 929741dc2da6577e6e99c5542d68dbd5 files/nosplash-gentoo.patch 332
-MD5 34d172ef31b5038e071b634d4e645cf1 files/pymol-gentoo.diff 1566
MD5 e42746bf581479c61ff1e7cc5b978edd files/setup.py-gentoo.patch 311
MD5 af2da92225ab57969d18d16ed60324ce files/setup2.py-gentoo.patch 493
diff --git a/sci-chemistry/pymol/pymol-0.97.ebuild b/sci-chemistry/pymol/pymol-0.97.ebuild
index dd355a5a71b1..a413d49e972d 100644
--- a/sci-chemistry/pymol/pymol-0.97.ebuild
+++ b/sci-chemistry/pymol/pymol-0.97.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-0.97.ebuild,v 1.3 2005/05/04 15:02:39 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-0.97.ebuild,v 1.4 2005/05/13 18:04:58 ribosome Exp $
-inherit distutils eutils
+inherit distutils eutils multilib
DESCRIPTION="A Python-extensible molecular graphics system."
HOMEPAGE="http://pymol.sourceforge.net/"
@@ -32,7 +32,7 @@ src_unpack() {
src_install() {
distutils_src_install
cd ${S}
- PYTHONPATH=$(find ${D}/usr/lib -type d -name site-packages) ${python} setup2.py
+ PYTHONPATH=$(find ${D}/usr/$(get_libdir) -type d -name site-packages) ${python} setup2.py
local sedexp="s:${D%/}::g"
sed -e ${sedexp} pymol.com > pymol