summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-20 12:11:56 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-20 12:11:56 +0000
commit7a5aabb58f19bb975c52328397dfb89162eeab58 (patch)
treec1ecf4c70cb19c46100527ad8cb1d519b1b56d91 /sci-chemistry/pymol
parentamd64/x86 stable wrt #300393 (diff)
downloadgentoo-2-7a5aabb58f19bb975c52328397dfb89162eeab58.tar.gz
gentoo-2-7a5aabb58f19bb975c52328397dfb89162eeab58.tar.bz2
gentoo-2-7a5aabb58f19bb975c52328397dfb89162eeab58.zip
Version Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog7
-rw-r--r--sci-chemistry/pymol/pymol-1.2.3.ebuild105
2 files changed, 111 insertions, 1 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index 8334d17fb0b8..11b37f89a23b 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.56 2010/02/19 08:39:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.57 2010/02/20 12:11:56 jlec Exp $
+
+*pymol-1.2.3 (20 Feb 2010)
+
+ 20 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> +pymol-1.2.3.ebuild:
+ Version Bump
*pymol-1.2.2-r4 (19 Feb 2010)
diff --git a/sci-chemistry/pymol/pymol-1.2.3.ebuild b/sci-chemistry/pymol/pymol-1.2.3.ebuild
new file mode 100644
index 000000000000..43e9a8179b2b
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-1.2.3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.2.3.ebuild,v 1.1 2010/02/20 12:11:56 jlec Exp $
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="tk"
+REV="3868"
+
+inherit eutils distutils prefix
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="http://pymol.svn.sourceforge.net/viewvc/pymol/trunk/pymol.tar.gz?view=tar&pathrev=${REV} -> ${P}.tar.gz"
+
+LICENSE="PSF-2.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="apbs numpy shaders vmd"
+
+DEPEND="
+ dev-python/numpy
+ dev-python/pmw
+ media-libs/freetype:2
+ media-libs/libpng
+ media-video/mpeg-tools
+ sys-libs/zlib
+ virtual/glut
+ apbs? (
+ dev-libs/maloc
+ sci-chemistry/apbs
+ sci-chemistry/pdb2pqr
+ sci-chemistry/pymol-apbs-plugin
+ )"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.* 2.4"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.2.2-data-path.patch
+
+ epatch "${FILESDIR}"/1.2.2-prefix.patch && \
+ eprefixify setup.py
+
+ # Turn off splash screen. Please do make a project contribution
+ # if you are able though. #299020
+ epatch "${FILESDIR}"/1.2.1/nosplash-gentoo.patch
+
+ # Respect CFLAGS
+ sed -i \
+ -e "s:\(ext_comp_args=\).*:\1[]:g" \
+ "${S}"/setup.py || die "Failed running sed on setup.py"
+
+ use shaders && epatch "${FILESDIR}"/${PN}-1.2.2-shaders.patch
+
+ use vmd && epatch "${FILESDIR}"/${PN}-1.2.2-vmd.patch
+
+ use numpy && \
+ sed \
+ -e '/PYMOL_NUMPY/s:^#::g' \
+ -i setup.py
+
+ rm ./modules/pmg_tk/startup/apbs_tools.py || die
+
+ # python 3.* fix
+ # sed '452,465d' -i setup.py
+ distutils_src_prepare
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ distutils_src_install
+
+ # These environment variables should not go in the wrapper script, or else
+ # it will be impossible to use the PyMOL libraries from Python.
+ cat >> "${T}"/20pymol <<- EOF
+ PYMOL_PATH="${EPREFIX}/$(python_get_sitedir -f)/${PN}"
+ PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
+ PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
+ EOF
+
+ doenvd "${T}"/20pymol || die "Failed to install env.d file."
+
+ cat >> "${T}"/pymol <<- EOF
+ #!/bin/sh
+ $(PYTHON -f) -O \${PYMOL_PATH}/__init__.py \$*
+ EOF
+
+ dobin "${T}"/pymol || die "Failed to install wrapper."
+
+ insinto /usr/share/pymol
+ doins -r test data scripts || die "no shared data"
+
+ insinto /usr/share/pymol/examples
+ doins -r examples || die "Failed to install docs."
+
+ dodoc DEVELOPERS README || die "Failed to install docs."
+
+# rm "${D}"$(python_get_sitedir)/pmg_tk/startup/apbs_tools.py
+}