summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-13 20:07:43 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-13 20:07:43 +0000
commit9fc93740ff8bc6ad9097921a57e08d8a9bc2362a (patch)
tree09e90c2ef11d1a1cc953cc7fdfa24342fca62062 /sci-chemistry/tinker
parentUpdated sed handling and udev rules for syntax changes (see bug 301887). (diff)
downloadgentoo-2-9fc93740ff8bc6ad9097921a57e08d8a9bc2362a.tar.gz
gentoo-2-9fc93740ff8bc6ad9097921a57e08d8a9bc2362a.tar.bz2
gentoo-2-9fc93740ff8bc6ad9097921a57e08d8a9bc2362a.zip
Version Bump and old version removed, parallel build and die when build failed, bug 296888, 275533, 263006 & 241180
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/tinker')
-rw-r--r--sci-chemistry/tinker/ChangeLog5
-rw-r--r--sci-chemistry/tinker/tinker-5.1.ebuild38
2 files changed, 11 insertions, 32 deletions
diff --git a/sci-chemistry/tinker/ChangeLog b/sci-chemistry/tinker/ChangeLog
index 84d281f631fd..376c63a1514a 100644
--- a/sci-chemistry/tinker/ChangeLog
+++ b/sci-chemistry/tinker/ChangeLog
@@ -1,12 +1,13 @@
# ChangeLog for sci-chemistry/tinker
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.13 2010/02/13 19:35:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/ChangeLog,v 1.14 2010/02/13 20:07:43 jlec Exp $
*tinker-5.1 (13 Feb 2010)
13 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> -tinker-4.2-r1.ebuild,
+tinker-5.1.ebuild:
- Version Bump and old version removed
+ Version Bump and old version removed, parallel build and die when build failed,
+ bug 296888, 275533, 263006 & 241180
14 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
tinker-4.2-r1.ebuild:
diff --git a/sci-chemistry/tinker/tinker-5.1.ebuild b/sci-chemistry/tinker/tinker-5.1.ebuild
index 54b88ccdadda..7515a54b7d3c 100644
--- a/sci-chemistry/tinker/tinker-5.1.ebuild
+++ b/sci-chemistry/tinker/tinker-5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-5.1.ebuild,v 1.1 2010/02/13 19:35:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tinker/tinker-5.1.ebuild,v 1.2 2010/02/13 20:07:43 jlec Exp $
EAPI="2"
FORTRAN="gfortran ifc"
@@ -22,35 +22,13 @@ RESTRICT="mirror"
S="${WORKDIR}"/tinker/source
src_compile() {
- LINK="./link.make"
- COMPILE="./compile.make"
- LIBRARY="./library.make"
-
- # Need to make sure all of the appropriate config files are in place
- # for the build.
- # This should be easily customizable for other Fortran compilers, e.g. pg77.
- if [[ ${FORTRANC} == "ifort" ]]; then
- cp ../linux/intel/* .
- else
- cp ../linux/gfortran/* .
- fi
-
- cp ../make/* .
-
- # Prep build scripts
- sed -i -e "s:gfortran:${FORTRANC} ${LDFLAGS}:g" ${LINK}
- sed -r -i -e "s:^${FORTRANC}.+$:echo &\n&:" ${LINK}
-
- # Default to -O2 if FFLAGS is unset
- sed -i -e "s:-O:${FFLAGS:- -O2}:" ${COMPILE}
- sed -r -i -e "s:^${FORTRANC}.+$:echo &\n&:" ${COMPILE}
-
- einfo "Compiling ..."
- ${COMPILE} || die "compile failed"
- einfo "Building libraries ..."
- ${LIBRARY} || die "library creation failed"
- einfo "Linking ..."
- ${LINK} || die "link failed"
+ emake \
+ -f ../make/Makefile \
+ F77="${FORTRANC}" \
+ F77FLAGS=-c \
+ OPTFLAGS="${FFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ || die
}
src_install() {