summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-02-12 16:22:51 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-02-12 16:22:51 +0000
commite85098aea25837cb0f07efe72b94570597d25589 (patch)
tree0b7c14bd953a55f990e36e62386e9129f4b0be4f /sci-chemistry/votca-csg
parentalpha/ia64/s390/sh/sparc stable wrt #344827 (diff)
downloadgentoo-2-e85098aea25837cb0f07efe72b94570597d25589.tar.gz
gentoo-2-e85098aea25837cb0f07efe72b94570597d25589.tar.bz2
gentoo-2-e85098aea25837cb0f07efe72b94570597d25589.zip
Initial commit (bug #296707)
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/votca-csg')
-rw-r--r--sci-chemistry/votca-csg/ChangeLog10
-rw-r--r--sci-chemistry/votca-csg/metadata.xml12
-rw-r--r--sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild80
3 files changed, 102 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csg/ChangeLog b/sci-chemistry/votca-csg/ChangeLog
new file mode 100644
index 000000000000..858ffb8635b3
--- /dev/null
+++ b/sci-chemistry/votca-csg/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/votca-csg
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/ChangeLog,v 1.1 2011/02/12 16:22:51 ottxor Exp $
+
+*votca-csg-1.0.1 (12 Feb 2011)
+
+ 12 Feb 2011; Christoph Junghans <ottxor@gentoo.org> +votca-csg-1.0.1.ebuild,
+ +metadata.xml:
+ Initial commit (bug #296707)
+
diff --git a/sci-chemistry/votca-csg/metadata.xml b/sci-chemistry/votca-csg/metadata.xml
new file mode 100644
index 000000000000..9796135c481b
--- /dev/null
+++ b/sci-chemistry/votca-csg/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <use>
+ <flag name='gromacs'>Add support for gromacs file formats (sci-chemistry/gromacs)</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild b/sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild
new file mode 100644
index 000000000000..00005b6ad1ea
--- /dev/null
+++ b/sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/votca-csg/votca-csg-1.0.1.ebuild,v 1.1 2011/02/12 16:22:51 ottxor Exp $
+
+EAPI="3"
+
+inherit autotools bash-completion
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://csg.votca.googlecode.com/hg"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca coarse-graining engine"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc +gromacs static-libs"
+
+RDEPEND="=sci-libs/votca-tools-${PV}
+ gromacs? ( >=sci-chemistry/gromacs-4.0.7-r5 <sci-chemistry/gromacs-9999 )
+ dev-lang/perl
+ app-shells/bash
+ doc? ( >=app-text/txt2tags-2.5 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ #from bootstrap.sh
+ [ -z "${PV##*9999}" ] && \
+ emake -C share/scripts/inverse -f Makefile.am.in Makefile.am
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ local myconf="--disable-la-files --disable-rc-files"
+
+ if use gromacs; then
+ #prefer gromacs double-precision if it is there
+ if has_version sci-chemistry/gromacs[double-precision]; then
+ myconf="${myconf} --with-libgmx=libgmx_d"
+ else
+ myconf="${myconf} --with-libgmx=libgmx"
+ fi
+ else
+ myconf="${myconf} --without-libgmx"
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README NOTICE
+ if use doc; then
+ emake CHANGELOG || die "emake CHANGELOG failed"
+ dodoc CHANGELOG
+ fi
+
+ dobashcompletion scripts/csg-completion.bash ${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "Please read and cite:"
+ elog "VOTCA, J. Chem. Theory Comput. 5, 3211 (2009). "
+ elog "http://dx.doi.org/10.1021/ct900369w"
+ elog
+ bash-completion_pkg_postinst
+}