summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-13 11:04:23 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-13 11:04:23 +0000
commit188f571323391fd4f0ad05e837fc393eaba24d32 (patch)
tree9fd2cf07efcf9860700a973f14ff854bbb2f884b /sci-chemistry
parent~x86 keyword added. (diff)
downloadgentoo-2-188f571323391fd4f0ad05e837fc393eaba24d32.tar.gz
gentoo-2-188f571323391fd4f0ad05e837fc393eaba24d32.tar.bz2
gentoo-2-188f571323391fd4f0ad05e837fc393eaba24d32.zip
Version Bump; Move to new python eclasses
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/autodock/ChangeLog12
-rw-r--r--sci-chemistry/autodock/autodock-4.2.3-r1.ebuild4
-rw-r--r--sci-chemistry/autodock/autodock-4.2.6.ebuild102
-rw-r--r--sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch44
-rw-r--r--sci-chemistry/autodock/metadata.xml2
5 files changed, 158 insertions, 6 deletions
diff --git a/sci-chemistry/autodock/ChangeLog b/sci-chemistry/autodock/ChangeLog
index 9ffe85a823b2..93c2e1bef953 100644
--- a/sci-chemistry/autodock/ChangeLog
+++ b/sci-chemistry/autodock/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/autodock
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock/ChangeLog,v 1.9 2011/06/26 09:00:41 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock/ChangeLog,v 1.10 2015/03/13 11:04:23 jlec Exp $
+
+*autodock-4.2.6 (13 Mar 2015)
+
+ 13 Mar 2015; Justin Lecher <jlec@gentoo.org> +autodock-4.2.6.ebuild,
+ +files/autodock-4.2.6-buildsystem.patch, autodock-4.2.3-r1.ebuild,
+ metadata.xml:
+ Version Bump; Move to new python eclasses
26 Jun 2011; Justin Lecher <jlec@gentoo.org> autodock-4.2.3-r1.ebuild:
Straight out QA issues
@@ -41,4 +48,3 @@
+autodock-4.0.1.ebuild:
Initial import. Thanks to Luc Grenier <lgrenier@rsvs.ulaval.ca> for his
ebuild and for testing the package.
-
diff --git a/sci-chemistry/autodock/autodock-4.2.3-r1.ebuild b/sci-chemistry/autodock/autodock-4.2.3-r1.ebuild
index a3f213286ec6..9b30e285af32 100644
--- a/sci-chemistry/autodock/autodock-4.2.3-r1.ebuild
+++ b/sci-chemistry/autodock/autodock-4.2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock/autodock-4.2.3-r1.ebuild,v 1.3 2011/06/26 09:00:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock/autodock-4.2.3-r1.ebuild,v 1.4 2015/03/13 11:04:23 jlec Exp $
EAPI=3
diff --git a/sci-chemistry/autodock/autodock-4.2.6.ebuild b/sci-chemistry/autodock/autodock-4.2.6.ebuild
new file mode 100644
index 000000000000..9b987ef61355
--- /dev/null
+++ b/sci-chemistry/autodock/autodock-4.2.6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/autodock/autodock-4.2.6.ebuild,v 1.1 2015/03/13 11:04:23 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils python-any-r1 versionator
+
+MY_PN="autodocksuite"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A suite of automated docking tools"
+HOMEPAGE="http://autodock.scripps.edu/"
+SRC_URI="http://autodock.scripps.edu/downloads/autodock-registration/tars/dist$(delete_all_version_separators)/${MY_P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples openmp test"
+
+RDEPEND=""
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+S="${WORKDIR}/src"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buildsystem.patch
+)
+
+src_prepare() {
+ local i
+
+ epatch ${PATCHES[@]}
+
+ sed \
+ -e "s/\tcsh/\tsh/" \
+ -i auto{dock,grid}/Makefile.am || die
+ for i in autodock autogrid; do
+ pushd $i &>/dev/null
+ eautoreconf
+ popd &>/dev/null
+ done
+}
+
+src_configure() {
+ local i
+ for i in autodock autogrid; do
+ pushd $i &>/dev/null
+ econf $(use_enable openmp)
+ popd &>/dev/null
+ done
+}
+
+src_compile() {
+ emake -C autodock
+ emake -C autogrid
+}
+
+src_test() {
+ elog "Testing autodock"
+ cd "${S}/autodock/Tests" || die
+ cp ../*.dat . || die
+ ${EPYTHON} test_autodock4.py || die "AutoDock tests failed."
+ einfo "Testing autogrid"
+ cd "${S}/autogrid/Tests" || die
+ ${EPYTHON} test_autogrid4.py || die "AutoGrid tests failed."
+}
+
+src_install() {
+ if use openmp; then
+ newbin autodock/autodock4.omp ${PN}4
+ dobin autogrid/autogrid4
+ else
+ dobin autodock/autodock4 autogrid/autogrid4
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r \
+ autodock/{AD4_parameters.dat,AD4_PARM99.dat} \
+ $(usex examples "autodoc/EXAMPLES" "")
+
+ DOCS=(
+ RELEASENOTES
+ autodock/{AUTHORS,README}
+ autodock/USERGUIDES/AutoDock4.{0,1,2}_UserGuide.doc
+ autodock/USERGUIDES/AutoDock4.2_UserGuide.pdf
+ )
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "The AutoDock development team requests all users to fill out the"
+ elog "registration form at:"
+ echo
+ elog "\thttp://autodock.scripps.edu/downloads/autodock-registration"
+ echo
+ elog "The number of unique users of AutoDock is used by Prof. Arthur J."
+ elog "Olson and the Scripps Research Institude to support grant"
+ elog "applications."
+}
diff --git a/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch b/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
new file mode 100644
index 000000000000..ae44ffeb3159
--- /dev/null
+++ b/sci-chemistry/autodock/files/autodock-4.2.6-buildsystem.patch
@@ -0,0 +1,44 @@
+ src/autodock/Makefile.am | 6 +++---
+ src/autogrid/Makefile.am | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/autodock/Makefile.am b/src/autodock/Makefile.am
+index 799a3c4..911897b 100644
+--- a/src/autodock/Makefile.am
++++ b/src/autodock/Makefile.am
+@@ -459,7 +459,8 @@ endif
+
+ BUILT_SOURCES = $(autodock4_SOURCES) default_parameters.h
+
+-AM_CXXFLAGS = -O3 # Agressive optimization
++AM_CXXFLAGS =
++#AM_CXXFLAGS = -O3 # Agressive optimization
+ #AM_CXXFLAGS = -g # debug
+
+ # if gnu c++ compiler
+@@ -488,8 +489,7 @@ endif
+ AM_CPPFLAGS = -DNOSQRT \
+ -DUSE_DOUBLE \
+ -DUSE_8A_NBCUTOFF \
+- -DUSE_INT_AS_FOURBYTELONG \
+- -O3
++ -DUSE_INT_AS_FOURBYTELONG
+ # AM_LDFLAGS = -g # -g is MP debug
+
+
+diff --git a/src/autogrid/Makefile.am b/src/autogrid/Makefile.am
+index b531099..b78b380 100644
+--- a/src/autogrid/Makefile.am
++++ b/src/autogrid/Makefile.am
+@@ -94,9 +94,9 @@ autogrid4_SOURCES = main.cpp \
+ BUILT_SOURCES = default_parameters.h
+
+
+-AM_CFLAGS = -Wall -O3 # All warnings, Agressive optimization
++AM_CFLAGS = -Wall # All warnings, Agressive optimization
+
+-AM_CPPFLAGS = -Wall -O3 -I $(srcdir) -I$(srcdir)/../autodock # All warnings, Agressive optimization
++AM_CPPFLAGS = -Wall -I $(srcdir) -I$(srcdir)/../autodock # All warnings, Agressive optimization
+ AM_CPPFLAGS += -Wno-write-strings # increase compatibility with pre 4.x compilers for string handling
+ # M Pique - add USE_8A_NBCUTOFF
+ AM_CPPFLAGS += -DUSE_8A_NBCUTOFF
diff --git a/sci-chemistry/autodock/metadata.xml b/sci-chemistry/autodock/metadata.xml
index e42d0af60f42..51fdedab1b38 100644
--- a/sci-chemistry/autodock/metadata.xml
+++ b/sci-chemistry/autodock/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-chemistry</herd>
+ <herd>sci-chemistry</herd>
</pkgmetadata>