summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-06 13:07:18 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-06 13:07:18 +0000
commit251457901e7e6665c13edc568cfc6a9ee473aa2b (patch)
treee5a78742364847141a0daf294a9a8df89b23591d /sci-chemistry
parentKeyword ~ppc64 wrt #313563 (diff)
downloadgentoo-2-251457901e7e6665c13edc568cfc6a9ee473aa2b.tar.gz
gentoo-2-251457901e7e6665c13edc568cfc6a9ee473aa2b.tar.bz2
gentoo-2-251457901e7e6665c13edc568cfc6a9ee473aa2b.zip
Fixed prll compilation
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/refmac/ChangeLog6
-rw-r--r--sci-chemistry/refmac/files/5.6.0081-allow-dynamic-linking.patch184
-rw-r--r--sci-chemistry/refmac/refmac-5.6.0081.ebuild4
3 files changed, 191 insertions, 3 deletions
diff --git a/sci-chemistry/refmac/ChangeLog b/sci-chemistry/refmac/ChangeLog
index 3bb87107b4ac..713e3301bd0c 100644
--- a/sci-chemistry/refmac/ChangeLog
+++ b/sci-chemistry/refmac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/refmac
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.14 2010/07/06 06:34:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/ChangeLog,v 1.15 2010/07/06 13:07:18 jlec Exp $
+
+ 06 Jul 2010; Justin Lecher <jlec@gentoo.org>
+ +files/5.6.0081-allow-dynamic-linking.patch, refmac-5.6.0081.ebuild:
+ Fixed prll compilation
*refmac-5.6.0081 (06 Jul 2010)
diff --git a/sci-chemistry/refmac/files/5.6.0081-allow-dynamic-linking.patch b/sci-chemistry/refmac/files/5.6.0081-allow-dynamic-linking.patch
new file mode 100644
index 000000000000..33defbfc7086
--- /dev/null
+++ b/sci-chemistry/refmac/files/5.6.0081-allow-dynamic-linking.patch
@@ -0,0 +1,184 @@
+diff --git a/makefile_refmac.inc1 b/makefile_refmac.inc1
+index 3f858c8..a8ab515 100644
+--- a/makefile_refmac.inc1
++++ b/makefile_refmac.inc1
+@@ -89,9 +89,7 @@ messy_pdb.o \
+ bridge.o \
+ i0.o \
+ i1.o \
+-chbevl.o \
+-$(LLIBCIF) \
+-$(LLIBLAPACK)
++chbevl.o
+
+
+ SUBL = \
+@@ -124,9 +122,7 @@ cell_symm_subrs.o \
+ iheap_sort.o \
+ linalgebra.o \
+ math_refmac.o \
+-subnumrec.o \
+-$(LLIBLAPACK) \
+-$(LLIBCCP)
++subnumrec.o
+
+ #--------------------------------------------------------------------------------
+
+@@ -150,20 +146,20 @@ twin77mod.o: twin77mod.f
+ $(FC) $(FFLAGS) -c twin77mod.f
+
+
+-optimise_solvent_all.o: optimise_solvent_all.f90
++optimise_solvent_all.o: optimise_solvent_all.f90 atomf77mod.o
+ $(FC) $(FFLAGS) -c optimise_solvent_all.f90
+
+-ncs_rest.o: ncs_ncs_generate.f90 ncs_rest.f
+- $(FC) $(FFLAGS) -c ncs_ncs_generate.f90 ncs_rest.f
++ncs_rest.o: ncs_ncs_generate.o ncs_rest.f
++ $(FC) $(FFLAGS) -c ncs_rest.f
+
+-ncs_ncs_generate.o: ncs_ncs_generate.f90 align_refmac.f90
+- $(FC) $(FFLAGS) -c ncs_ncs_generate.f90 align_refmac.f90
++ncs_ncs_generate.o: ncs_ncs_generate.f90 align_refmac.o
++ $(FC) $(FFLAGS) -c ncs_ncs_generate.f90
+
+-lsq_exp2.o: dist_routines.f90 ncs_simil.f90 ridge.f90 local_tls.f90 lsq_exp2.f
+- $(FC) $(FFLAGS) -c dist_routines.f90 ncs_simil.f90 ridge.f90 local_tls.f90 lsq_exp2.f
++lsq_exp2.o: dist_routines.o ncs_simil.o ridge.o local_tls.o lsq_exp2.f
++ $(FC) $(FFLAGS) -c lsq_exp2.f
+
+-vdw_and_contacts.o: vdw_and_contacts.f local_tls.f90 ridge.f90
+- $(FC) $(FFLAGS) -c ridge.f90 local_tls.f90 vdw_and_contacts.f
++vdw_and_contacts.o: vdw_and_contacts.f local_tls.o ridge.o
++ $(FC) $(FFLAGS) -c vdw_and_contacts.f
+
+ dist_routines.o: dist_routines.f90
+ $(FC) $(FFLAGS) -c dist_routines.f90
+@@ -178,8 +174,8 @@ align_refmac.o: align_refmac.f90
+ $(FC) $(FFLAGS) -c align_refmac.f90
+
+
+-hkon_secder_tch.o: hkon_secder_tch.f local_tls.f90 ncs_simil.f90 optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 ncs_simil.f90 local_tls.f90 hkon_secder_tch.f
++hkon_secder_tch.o: hkon_secder_tch.f local_tls.o ncs_simil.o optimise_solvent_all.o optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c hkon_secder_tch.f
+
+ oppro_allocate.o: oppro_allocate.f filter_params.f90 optimise_solvent_all.f90
+ $(FC) $(FFLAGS) -c optimise_solvent_all.f90 filter_params.f90 oppro_allocate.f
+@@ -187,50 +183,50 @@ oppro_allocate.o: oppro_allocate.f filter_params.f90 optimise_solvent_all.f90
+ coords.o: coords.f90 atomf77mod.f
+ $(FC) $(FFLAGS) -c atomf77mod.f coords.f90
+
+-refpre_twin.o: refpre_twin.f coords.f90 automorphism.f90
+- $(FC) $(FFLAGS) -c coords.f90 automorphism.f90 refpre_twin.f
++refpre_twin.o: refpre_twin.f coords.o automorphism.o
++ $(FC) $(FFLAGS) -c refpre_twin.f
+
+ automorphism.o: automorphism.f90
+ $(FC) $(FFLAGS) -c automorphism.f90
+
+-mtz_write_twin.o: mtz_write_twin.f filter_params.f90
+- $(FC) $(FFLAGS) -c filter_params.f90 mtz_write_twin.f
++mtz_write_twin.o: mtz_write_twin.f filter_params.o
++ $(FC) $(FFLAGS) -c mtz_write_twin.f
+
+ filter_params.o: filter_params.f90
+ $(FC) $(FFLAGS) -c filter_params.f90
+
+-rcard_tor1.o: rcard_tor1.f filter_params.f90 local_tls.f90 ridge.f90 optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 filter_params.f90 local_tls.f90 ridge.f90 rcard_tor1.f
++rcard_tor1.o: rcard_tor1.f filter_params.o local_tls.o ridge.o optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c rcard_tor1.f
+
+-local_tls.o: local_tls.f90 linalgebra_f90.f90
+- $(FC) $(FFLAGS) -c linalgebra_f90.f90 local_tls.f90
++local_tls.o: local_tls.f90 linalgebra_f90.o
++ $(FC) $(FFLAGS) -c local_tls.f90
+
+ linalgebra_f90.o: linalgebra_f90.f90
+ $(FC) $(FFLAGS) -c linalgebra_f90.f90
+
+-make_refmac_dummy.o: make_refmac_dummy.f optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 make_refmac_dummy.f
++make_refmac_dummy.o: make_refmac_dummy.f optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c make_refmac_dummy.f
+
+-ml_scaling_double.o: ml_scaling_double.f optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 ml_scaling_double.f
++ml_scaling_double.o: ml_scaling_double.f optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c ml_scaling_double.f
+
+-refall_twin.o: refall_twin.f optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 refall_twin.f
++refall_twin.o: refall_twin.f optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c refall_twin.f
+
+-rharvest.o: rharvest.f optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 rharvest.f
++rharvest.o: rharvest.f optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c rharvest.f
+
+-solvent_contr_mask.o: solvent_contr_mask.f optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 solvent_contr_mask.f
++solvent_contr_mask.o: solvent_contr_mask.f optimise_solvent_all.o atomf77mod.o
++ $(FC) $(FFLAGS) -c atomf77mod.f solvent_contr_mask.f
+
+-subag_scale_hessian.o: subag_scale_hessian.f optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 subag_scale_hessian.f
++subag_scale_hessian.o: subag_scale_hessian.f optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c subag_scale_hessian.f
+
+-subcf_scale1.o: subcf_scale1.f optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 subcf_scale1.f
++subcf_scale1.o: subcf_scale1.f optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c subcf_scale1.f
+
+-refmac_xml.o: refmac_xml.f optimise_solvent_all.f90
+- $(FC) $(FFLAGS) -c optimise_solvent_all.f90 refmac_xml.f
++refmac_xml.o: refmac_xml.f optimise_solvent_all.o
++ $(FC) $(FFLAGS) -c refmac_xml.f
+
+ hkl_pack.o: hkl_pack.f90
+ $(FC) $(FFLAGS) -c hkl_pack.f90
+@@ -239,30 +235,31 @@ subvag.o: subvag.f hkl_pack.f90
+ $(FC) $(FFLAGS) -c hkl_pack.f90 subvag.f
+
+ refmac: $(SUBR)
+- $(FC) $(FFLAGS) -o refmac${VERSION} ${SUBR} $(LLIBOTHERS) $(LLIBCCP)
++ $(FC) $(FFLAGS) $(LDFLAGS) -o refmac${VERSION} ${SUBR} $(LLIBOTHERS) $(LLIBCCP) $(LLIBCIF) $(LLIBLAPACK)
+
+-mol2_file.o: mol2_file.f odb_files.f90
+- $(FC) $(FFLAGS) -c odb_files.f90 mol2_file.f
++mol2_file.o: mol2_file.f odb_files.o
++ $(FC) $(FFLAGS) -c mol2_file.f
+
+-odb_files.o: odb_files.f90 elements_module.f90 enerf77mod.f
+- $(FC) $(FFLAGS) -c elements_module.f90 enerf77mod.f odb_files.f90
++odb_files.o: odb_files.f90 elements_module.o enerf77mod.f
++ $(FC) $(FFLAGS) -c enerf77mod.f odb_files.f90
+
+ elements_module.o: elements_module.f90
+ $(FC) $(FFLAGS) -c elements_module.f90
+
+-make_lib2.o: make_lib2.f odb_files.f90
+- $(FC) $(FFLAGS) -c odb_files.f90 make_lib2.f
++make_lib2.o: make_lib2.f odb_files.o
++ $(FC) $(FFLAGS) -c make_lib2.f
+
+ pdb2libcheck.o: pdb2libcheck.f90
+ $(FC) $(FFLAGS) -c pdb2libcheck.f90
+
+-libcheck.o: libcheck.f elements_module.f90 pdb2libcheck.f90
+- $(FC) $(FFLAGS) -c elements_module.f90 pdb2libcheck.f90 libcheck.f
++libcheck.o: libcheck.f elements_module.o pdb2libcheck.o
++ $(FC) $(FFLAGS) -c libcheck.f
+
+ libcheck: $(SUBL)
+- $(FC) $(FFLAGS) -o libcheck${VERSION} $(SUBL)
++ $(FC) $(FFLAGS) $(LDFLAGS) -o libcheck${VERSION} $(SUBL) $(LLIBCCP) $(LLIBCIF) $(LLIBLAPACK)
+
+ clean:
+ /bin/rm *.o
+
+ bridge.o: bridge.cpp llhood.h covmat.h Gauss.h tabfunc.h
++ $(CXX) $(CXXFLAGS) -c bridge.cpp
diff --git a/sci-chemistry/refmac/refmac-5.6.0081.ebuild b/sci-chemistry/refmac/refmac-5.6.0081.ebuild
index 19b0a2303aa7..85f3d85a551c 100644
--- a/sci-chemistry/refmac/refmac-5.6.0081.ebuild
+++ b/sci-chemistry/refmac/refmac-5.6.0081.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.6.0081.ebuild,v 1.1 2010/07/06 06:34:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/refmac/refmac-5.6.0081.ebuild,v 1.2 2010/07/06 13:07:18 jlec Exp $
EAPI="2"
@@ -29,7 +29,7 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}"
PATCHES=(
- "${FILESDIR}"/${PV/81/80}-allow-dynamic-linking.patch
+ "${FILESDIR}"/${PV}-allow-dynamic-linking.patch
)
src_prepare() {