summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-28 21:37:00 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-28 21:37:00 +0000
commit67a7e8559a9d66f86aea49dd5ebe4ae352e4ce88 (patch)
tree9eff4268f0035b10c582d72e7ab63ee555a2a911 /sci-chemistry
parentdhclient comes from dhcp[client]; thanks to Maciej Mrozowski. (diff)
downloadgentoo-2-67a7e8559a9d66f86aea49dd5ebe4ae352e4ce88.tar.gz
gentoo-2-67a7e8559a9d66f86aea49dd5ebe4ae352e4ce88.tar.bz2
gentoo-2-67a7e8559a9d66f86aea49dd5ebe4ae352e4ce88.zip
sci-chemistry/PyMca: Version Bump, restrict pypy
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/PyMca/ChangeLog10
-rw-r--r--sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild6
-rw-r--r--sci-chemistry/PyMca/PyMca-4.6.2.ebuild43
-rw-r--r--sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch16
-rw-r--r--sci-chemistry/PyMca/metadata.xml16
5 files changed, 78 insertions, 13 deletions
diff --git a/sci-chemistry/PyMca/ChangeLog b/sci-chemistry/PyMca/ChangeLog
index a3dd8425e3c0..f3fff3b122ee 100644
--- a/sci-chemistry/PyMca/ChangeLog
+++ b/sci-chemistry/PyMca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/PyMca
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/ChangeLog,v 1.3 2010/12/26 17:40:29 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/ChangeLog,v 1.4 2012/10/28 21:37:00 jlec Exp $
+
+*PyMca-4.6.2 (28 Oct 2012)
+
+ 28 Oct 2012; Justin Lecher <jlec@gentoo.org> PyMca-4.4.1_p1.ebuild,
+ +PyMca-4.6.2.ebuild, +files/PyMca-4.6.2-gentoo.patch, metadata.xml:
+ Version Bump, restrict pypy
26 Dec 2010; Justin Lecher <jlec@gentoo.org> +files/4.4.1_p1-impl-dec.patch,
PyMca-4.4.1_p1.ebuild:
diff --git a/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild b/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild
index de99abd6fbb3..88ea21e26c23 100644
--- a/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild
+++ b/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild,v 1.3 2010/12/26 17:40:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/PyMca-4.4.1_p1.ebuild,v 1.4 2012/10/28 21:37:00 jlec Exp $
EAPI=3
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-pypy-*"
inherit distutils eutils
diff --git a/sci-chemistry/PyMca/PyMca-4.6.2.ebuild b/sci-chemistry/PyMca/PyMca-4.6.2.ebuild
new file mode 100644
index 000000000000..bf58776d106c
--- /dev/null
+++ b/sci-chemistry/PyMca/PyMca-4.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/PyMca/PyMca-4.6.2.ebuild,v 1.1 2012/10/28 21:37:00 jlec Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-pypy-*"
+
+inherit distutils eutils
+
+MY_PV="${PV/_}"
+
+DESCRIPTION="X-ray Fluorescence Toolkit"
+HOMEPAGE="http://pymca.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/pymca/pymca/${PN}${PV/_p1}/pymca${MY_PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X hdf5 matplotlib"
+
+DEPEND="
+ dev-python/numpy
+ dev-python/sip
+ virtual/opengl
+ dev-python/pyopengl
+ X? (
+ dev-python/PyQt4
+ dev-python/pyqwt
+ )
+ hdf5? ( dev-python/h5py )
+ matplotlib? ( dev-python/matplotlib )"
+RDEPEND="${DEPEND}"
+
+#S="${WORKDIR}/${PN}${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ export SPECFILE_USE_GNU_SOURCE=1
+ distutils_src_prepare
+}
diff --git a/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch b/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch
new file mode 100644
index 000000000000..81dfaf038fa6
--- /dev/null
+++ b/sci-chemistry/PyMca/files/PyMca-4.6.2-gentoo.patch
@@ -0,0 +1,16 @@
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 0a77cdf..e7ba643 100644
+--- a/setup.py
++++ b/setup.py
+@@ -55,7 +55,7 @@ packages = ['PyMca','PyMca.PyMcaPlugins', 'PyMca.tests']
+ py_modules = []
+
+ # Specify all the required PyMca data
+-data_files = [(PYMCA_DATA_DIR, ['LICENSE.GPL',
++data_files = [(PYMCA_DATA_DIR, [
+ 'PyMca/PyMcaData/Scofield1973.dict',
+ 'changelog.txt',
+ 'PyMca/PyMcaData/McaTheory.cfg',
diff --git a/sci-chemistry/PyMca/metadata.xml b/sci-chemistry/PyMca/metadata.xml
index 587ced5941ce..f843ca9d3d30 100644
--- a/sci-chemistry/PyMca/metadata.xml
+++ b/sci-chemistry/PyMca/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<longdescription>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
The PyMca Toolkit is a collection of Python tools for visualization and
analysis of energy-dispersive X-ray fluorescence data. It builds its graphic
interface and plotting routines on top of the C++ libraries Qt and Qwt
@@ -13,7 +13,7 @@ through their respective Python bindings PyQt and PyQwt. Nevertheless,
the data analysis routines can be used independently of any graphical
interface.
</longdescription>
-<use>
- <flag name='matplotlib'>Support for plotting through matplotlib</flag>
-</use>
+ <use>
+ <flag name="matplotlib">Support for plotting through matplotlib</flag>
+ </use>
</pkgmetadata>