summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-19 09:02:50 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-19 09:02:50 +0000
commit7de9f3e49606a04051e7c6047a994f60d37eebc1 (patch)
tree7ae1edee5cadd98e1d38b5f79fb393dd6c19a348 /sci-electronics/kicad/kicad-20070115.ebuild
parentAdded ~ppc64; bug #178310 (diff)
downloadgentoo-2-7de9f3e49606a04051e7c6047a994f60d37eebc1.tar.gz
gentoo-2-7de9f3e49606a04051e7c6047a994f60d37eebc1.tar.bz2
gentoo-2-7de9f3e49606a04051e7c6047a994f60d37eebc1.zip
Fix wxwidgets.eclass usage to work with upcoming changes.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-electronics/kicad/kicad-20070115.ebuild')
-rw-r--r--sci-electronics/kicad/kicad-20070115.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-electronics/kicad/kicad-20070115.ebuild b/sci-electronics/kicad/kicad-20070115.ebuild
index 559c5b5501d2..fdc56fd09f1e 100644
--- a/sci-electronics/kicad/kicad-20070115.ebuild
+++ b/sci-electronics/kicad/kicad-20070115.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.3 2007/04/12 13:11:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070115.ebuild,v 1.4 2007/05/19 09:02:50 dirtyepic Exp $
inherit wxwidgets
@@ -15,12 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc64 x86"
IUSE="unicode doc examples minimal"
-DEPEND=">=x11-libs/wxGTK-2.6
+DEPEND="=x11-libs/wxGTK-2.6*
media-gfx/wings"
pkg_setup() {
- # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
- WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+ # Tell wxwidgets.eclass the version we need.
+ WX_GTK_VER="2.6"
# Check for proper wxGTK USE flags.
if use unicode; then
@@ -28,7 +28,7 @@ pkg_setup() {
else
need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
fi
- built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+ built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
}
src_unpack() {