summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-29 08:44:56 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-29 08:44:56 +0000
commit6f52161944e2fbd458fe8100e3ce67f4adc0c1a0 (patch)
tree5f52d18d73e7e82337d097cc2afbd6b88e0fd937 /sci-electronics/klayout
parentFix underlinking wrt #369115 (diff)
downloadgentoo-2-6f52161944e2fbd458fe8100e3ce67f4adc0c1a0.tar.gz
gentoo-2-6f52161944e2fbd458fe8100e3ce67f4adc0c1a0.tar.bz2
gentoo-2-6f52161944e2fbd458fe8100e3ce67f4adc0c1a0.zip
Fix compilation with gcc-4.6, bug 369055
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/klayout')
-rw-r--r--sci-electronics/klayout/ChangeLog6
-rw-r--r--sci-electronics/klayout/files/klayout-0.21.10-gcc46.patch11
-rw-r--r--sci-electronics/klayout/klayout-0.21.10.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/sci-electronics/klayout/ChangeLog b/sci-electronics/klayout/ChangeLog
index d3ebd61df267..1762edb38d5d 100644
--- a/sci-electronics/klayout/ChangeLog
+++ b/sci-electronics/klayout/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/klayout
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.5 2011/05/28 22:41:30 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.6 2011/05/29 08:44:55 dilfridge Exp $
+
+ 29 May 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ klayout-0.21.10.ebuild, +files/klayout-0.21.10-gcc46.patch:
+ Fix compilation with gcc-4.6, bug 369055
*klayout-0.21.10 (28 May 2011)
diff --git a/sci-electronics/klayout/files/klayout-0.21.10-gcc46.patch b/sci-electronics/klayout/files/klayout-0.21.10-gcc46.patch
new file mode 100644
index 000000000000..4041af6d6c45
--- /dev/null
+++ b/sci-electronics/klayout/files/klayout-0.21.10-gcc46.patch
@@ -0,0 +1,11 @@
+diff -ruN klayout-0.21.10.orig/src/tlStableVector.h klayout-0.21.10/src/tlStableVector.h
+--- klayout-0.21.10.orig/src/tlStableVector.h 2011-05-07 20:53:35.000000000 +0200
++++ klayout-0.21.10/src/tlStableVector.h 2011-05-29 10:34:20.000000000 +0200
+@@ -25,6 +25,7 @@
+ #ifndef HDR_tlStableVector
+ #define HDR_tlStableVector
+
++#include <stddef.h>
+ #include <vector>
+ #include <iterator>
+
diff --git a/sci-electronics/klayout/klayout-0.21.10.ebuild b/sci-electronics/klayout/klayout-0.21.10.ebuild
index a8d246dcaaad..b6fd16b9f4d8 100644
--- a/sci-electronics/klayout/klayout-0.21.10.ebuild
+++ b/sci-electronics/klayout/klayout-0.21.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.21.10.ebuild,v 1.1 2011/05/28 22:41:30 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.21.10.ebuild,v 1.2 2011/05/29 08:44:55 dilfridge Exp $
EAPI=3
@@ -26,6 +26,8 @@ DEPEND="${RDEPEND}"
all_ruby_prepare() {
# now we generate the stub build configuration file for the home-brew build system
cp "${FILESDIR}/${PN}-0.21.7-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
+
+ epatch "${FILESDIR}/${P}-gcc46.patch"
}
each_ruby_configure() {