summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-06-30 11:48:33 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-06-30 11:48:33 +0000
commit929c569b8516c99560614ff7b0f24fd6acc0ac4d (patch)
tree7985c65101401dfe2aa868416de90b02b6d1db43 /sci-electronics/klayout
parentAdd game splitted from gnome-games by upstream (diff)
downloadgentoo-2-929c569b8516c99560614ff7b0f24fd6acc0ac4d.tar.gz
gentoo-2-929c569b8516c99560614ff7b0f24fd6acc0ac4d.tar.bz2
gentoo-2-929c569b8516c99560614ff7b0f24fd6acc0ac4d.zip
Version bump; does not build yet, needs further investigation.
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'sci-electronics/klayout')
-rw-r--r--sci-electronics/klayout/ChangeLog8
-rw-r--r--sci-electronics/klayout/klayout-0.22.8.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/sci-electronics/klayout/ChangeLog b/sci-electronics/klayout/ChangeLog
index b6236fbb7d63..e36b9108c637 100644
--- a/sci-electronics/klayout/ChangeLog
+++ b/sci-electronics/klayout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/klayout
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.16 2013/06/19 04:19:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.17 2013/06/30 11:48:33 dilfridge Exp $
+
+*klayout-0.22.8 (30 Jun 2013)
+
+ 30 Jun 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +klayout-0.22.8.ebuild:
+ Version bump; does not build yet, needs further investigation.
19 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switch to sci-electronics herd
diff --git a/sci-electronics/klayout/klayout-0.22.8.ebuild b/sci-electronics/klayout/klayout-0.22.8.ebuild
new file mode 100644
index 000000000000..5655de7d9d57
--- /dev/null
+++ b/sci-electronics/klayout/klayout-0.22.8.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.22.8.ebuild,v 1.1 2013/06/30 11:48:33 dilfridge Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+# note: define maximally ONE implementation here
+
+RUBY_OPTIONAL=no
+inherit eutils multilib toolchain-funcs ruby-ng
+
+DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
+HOMEPAGE="http://www.klayout.de/"
+SRC_URI="http://178.77.72.242/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtgui:4[qt3support]
+ $(ruby_implementations_depend)
+"
+DEPEND="${RDEPEND}"
+
+all_ruby_prepare() {
+ # now we generate the stub build configuration file for the home-brew build system
+ cp "${FILESDIR}/${PN}-0.21.7-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
+}
+
+each_ruby_configure() {
+ local rbflags
+ rbflags="-rblib $(ruby_get_libruby) -rbinc $(ruby_get_hdrdir)"
+
+ ./build.sh \
+ -dry-run \
+ -platform linux-gentoo \
+ -bin bin \
+ -qtbin /usr/bin \
+ -qtinc /usr/include/qt4 \
+ -qtlib /usr/$(get_libdir)/qt4 \
+ ${rbflags} || die "Configuration failed"
+}
+
+each_ruby_compile() {
+ cd build.linux-gentoo
+ tc-export CC CXX AR LD RANLIB
+ export AR="${AR} -r"
+ emake all
+}
+
+each_ruby_install() {
+ cd build.linux-gentoo
+ emake install
+
+ cd ..
+ dobin bin/klayout
+
+ insinto /usr/share/${PN}/testdata/gds
+ doins testdata/gds/*.gds
+ insinto /usr/share/${PN}/testdata/oasis
+ doins testdata/oasis/*.oas testdata/oasis/*.ot
+
+ insinto /usr/share/${PN}
+ doins -r testdata/ruby
+}