summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-28 22:41:30 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-05-28 22:41:30 +0000
commitcd7c1481bff3aa699f30ee0e4f1e5067289cf6c3 (patch)
treeffc0e17e0d0e1f4abb481a70e149f44294162cea /sci-electronics/klayout
parentFix compilation against sci-geosciences/gpsd-2.96, bug 367567 (diff)
downloadgentoo-2-cd7c1481bff3aa699f30ee0e4f1e5067289cf6c3.tar.gz
gentoo-2-cd7c1481bff3aa699f30ee0e4f1e5067289cf6c3.tar.bz2
gentoo-2-cd7c1481bff3aa699f30ee0e4f1e5067289cf6c3.zip
Version bump
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/klayout')
-rw-r--r--sci-electronics/klayout/ChangeLog8
-rw-r--r--sci-electronics/klayout/klayout-0.21.10.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/sci-electronics/klayout/ChangeLog b/sci-electronics/klayout/ChangeLog
index 44d10bfa3b95..d3ebd61df267 100644
--- a/sci-electronics/klayout/ChangeLog
+++ b/sci-electronics/klayout/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/klayout
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.4 2011/03/30 21:49:59 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/ChangeLog,v 1.5 2011/05/28 22:41:30 dilfridge Exp $
+
+*klayout-0.21.10 (28 May 2011)
+
+ 28 May 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +klayout-0.21.10.ebuild:
+ Version bump
*klayout-0.21.7 (30 Mar 2011)
diff --git a/sci-electronics/klayout/klayout-0.21.10.ebuild b/sci-electronics/klayout/klayout-0.21.10.ebuild
new file mode 100644
index 000000000000..a8d246dcaaad
--- /dev/null
+++ b/sci-electronics/klayout/klayout-0.21.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/klayout/klayout-0.21.10.ebuild,v 1.1 2011/05/28 22:41:30 dilfridge Exp $
+
+EAPI=3
+
+USE_RUBY="ruby18"
+# note: define maximally ONE implementation here
+
+RUBY_OPTIONAL=yes
+
+inherit eutils multilib toolchain-funcs ruby-ng
+
+DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
+HOMEPAGE="http://www.klayout.de/"
+SRC_URI="http://www.klayout.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ruby"
+
+RDEPEND="x11-libs/qt-gui:4[qt3support]"
+DEPEND="${RDEPEND}"
+
+all_ruby_prepare() {
+ # now we generate the stub build configuration file for the home-brew build system
+ cp "${FILESDIR}/${PN}-0.21.7-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
+}
+
+each_ruby_configure() {
+ local rbflags
+
+ if use ruby ; then
+ rbflags="-rblib $(ruby_get_libruby) -rbinc $(ruby_get_hdrdir)"
+ fi
+
+ ./build.sh \
+ -dry-run \
+ -platform linux-gentoo \
+ -bin bin \
+ -qtbin /usr/bin \
+ -qtinc /usr/include/qt4 \
+ -qtlib /usr/$(get_libdir)/qt4 \
+ ${rbflags} || die "Configuration failed"
+}
+
+each_ruby_compile() {
+ cd build.linux-gentoo
+ tc-export CC CXX AR LD RANLIB
+ export AR="${AR} -r"
+ emake all || die "Build failed"
+}
+
+each_ruby_install() {
+ cd build.linux-gentoo
+ emake install || die "make install failed"
+
+ cd ..
+ dobin bin/klayout || die
+
+ insinto /usr/share/${PN}/testdata/gds
+ doins testdata/gds/*.gds || die "Installation of gds testdata failed"
+ insinto /usr/share/${PN}/testdata/oasis
+ doins testdata/oasis/*.oas testdata/oasis/*.ot || die "Installation of oasis testdata failed"
+
+ if use ruby; then
+ insinto /usr/share/${PN}
+ doins -r testdata/ruby || die "Installation of ruby testdata failed"
+ fi
+}