summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2011-03-22 06:29:22 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2011-03-22 06:29:22 +0000
commit6fc05e903a29e361a259298673860153b182e1dc (patch)
treef9ca811130f906b35b9c97befa24b989b8b9c0fb /sci-electronics/linsmith
parentfixup minor repoman complaints (diff)
downloadgentoo-2-6fc05e903a29e361a259298673860153b182e1dc.tar.gz
gentoo-2-6fc05e903a29e361a259298673860153b182e1dc.tar.bz2
gentoo-2-6fc05e903a29e361a259298673860153b182e1dc.zip
Version bump. fixes bug #358439. Thanks for reporting Pacho
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/linsmith')
-rw-r--r--sci-electronics/linsmith/ChangeLog7
-rw-r--r--sci-electronics/linsmith/linsmith-0.99.21.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sci-electronics/linsmith/ChangeLog b/sci-electronics/linsmith/ChangeLog
index 0cfab4c1f73c..228a9df6cd5d 100644
--- a/sci-electronics/linsmith/ChangeLog
+++ b/sci-electronics/linsmith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/linsmith
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.2 2011/03/02 20:19:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/ChangeLog,v 1.3 2011/03/22 06:29:22 tomjbe Exp $
+
+*linsmith-0.99.21 (22 Mar 2011)
+
+ 22 Mar 2011; Thomas Beierlein <tomjbe@gentoo.org> +linsmith-0.99.21.ebuild:
+ Version bump. fixes bug #358439.
02 Mar 2011; Justin Lecher <jlec@gentoo.org> linsmith-0.99.12.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-electronics/linsmith/linsmith-0.99.21.ebuild b/sci-electronics/linsmith/linsmith-0.99.21.ebuild
new file mode 100644
index 000000000000..ec9eba7aab7d
--- /dev/null
+++ b/sci-electronics/linsmith/linsmith-0.99.21.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/linsmith/linsmith-0.99.21.ebuild,v 1.1 2011/03/22 06:29:22 tomjbe Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Smith charting program, mainly designed for educational use."
+HOMEPAGE="http://www.jcoppens.com/soft/linsmith/index.en.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome
+ gnome-base/libgnomecanvas
+ gnome-base/libgnomeui"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # This patch is to prevent make install copying
+ # the examples in /usr/share/linsmith
+ # Now they are cp to the correct location.
+ epatch \
+ "${FILESDIR}"/${PN}-datafiles.patch
+
+ # fix QA warnings about 'maintainer mode'
+ eautoreconf
+}
+
+src_install() {
+ # Delete this file, otherwise it is installed with the pixmaps.
+ rm pixmaps/Makefile.am~
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto "/usr/share/${PN}"
+ doins datafiles/conv0809 || die
+
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO || die
+ doman doc/linsmith.1 || die
+
+ domenu linsmith.desktop || die
+ doicon linsmith_icon.xpm || die
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins doc/manual.pdf || die
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins datafiles/*.circ datafiles/*.load || die
+ fi
+}