summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-02-22 08:22:34 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2015-02-22 08:22:34 +0000
commit9f2d48e0210f0eb0ef89333a01c422b04a1c0042 (patch)
treeda2b4f3201755a9deb4c1de6a0f2f2a1d27e328a /sci-electronics/xnec2c
parentDepend on dev-lang/perl[ithreads] by OKUMURA N. Shin-ya (bug #540910). (diff)
downloadgentoo-2-9f2d48e0210f0eb0ef89333a01c422b04a1c0042.tar.gz
gentoo-2-9f2d48e0210f0eb0ef89333a01c422b04a1c0042.tar.bz2
gentoo-2-9f2d48e0210f0eb0ef89333a01c422b04a1c0042.zip
Minor maintenance release
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'sci-electronics/xnec2c')
-rw-r--r--sci-electronics/xnec2c/ChangeLog9
-rw-r--r--sci-electronics/xnec2c/xnec2c-3.2.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/sci-electronics/xnec2c/ChangeLog b/sci-electronics/xnec2c/ChangeLog
index cbf5c36fab3c..10071c3252f3 100644
--- a/sci-electronics/xnec2c/ChangeLog
+++ b/sci-electronics/xnec2c/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/xnec2c
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.22 2014/12/29 08:03:13 tomjbe Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.23 2015/02/22 08:22:34 tomjbe Exp $
+
+*xnec2c-3.2 (22 Feb 2015)
+
+ 22 Feb 2015; Thomas Beierlein <tomjbe@gentoo.org> +xnec2c-3.2.ebuild:
+ Minor maintenance release
*xnec2c-3.1 (29 Dec 2014)
diff --git a/sci-electronics/xnec2c/xnec2c-3.2.ebuild b/sci-electronics/xnec2c/xnec2c-3.2.ebuild
new file mode 100644
index 000000000000..14f54e7be24d
--- /dev/null
+++ b/sci-electronics/xnec2c/xnec2c-3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/xnec2c-3.2.ebuild,v 1.1 2015/02/22 08:22:34 tomjbe Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A GTK+ graphical interactive version of nec2c"
+HOMEPAGE="http://www.qsl.net/5b4az/pages/nec2.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/nec2/xnec2c/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ glib-gettextize --force --copy || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS README doc/*.txt
+ use doc && dohtml -r doc/*.html doc/images
+ insinto /usr/share/doc/${PF}/examples
+ use examples && doins examples/*
+}