summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2008-07-17 00:12:09 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2008-07-17 00:12:09 +0000
commitd59f2b4f0e7138260730ff1b7f3fa0d69d2275b2 (patch)
tree0f42b1f2bedd10c2a06b862002750e065927dd0a /sci-electronics
parent(#231705) Remove unnecessary dep on libX11; dep on xproto instead. (diff)
downloadgentoo-2-d59f2b4f0e7138260730ff1b7f3fa0d69d2275b2.tar.gz
gentoo-2-d59f2b4f0e7138260730ff1b7f3fa0d69d2275b2.tar.bz2
gentoo-2-d59f2b4f0e7138260730ff1b7f3fa0d69d2275b2.zip
Revised ebuild for eagle version 5, which uses a new packaging system and adds some documentation
(Portage version: 2.2_rc1/cvs/Linux 2.6.22-ck1 x86_64)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/eagle/ChangeLog7
-rw-r--r--sci-electronics/eagle/eagle-5.1.0.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/sci-electronics/eagle/ChangeLog b/sci-electronics/eagle/ChangeLog
index 4e169d7c445e..682490787994 100644
--- a/sci-electronics/eagle/ChangeLog
+++ b/sci-electronics/eagle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/eagle
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.12 2008/02/29 20:38:42 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.13 2008/07/17 00:12:09 nixphoeni Exp $
+
+ 17 Jul 2008; Joe Sapp <nixphoeni@gentoo.org> ChangeLog:
+ Revised ebuild for eagle version 5, which uses a new packaging system and
+ adds some documentation. Thanks to Lukas Sandström for the bump notice and
+ ebuild help on bug #221847.
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> eagle-4.16_p1.ebuild,
eagle-4.16_p2.ebuild, eagle-4.16_p2-r2.ebuild:
diff --git a/sci-electronics/eagle/eagle-5.1.0.ebuild b/sci-electronics/eagle/eagle-5.1.0.ebuild
new file mode 100644
index 000000000000..36fe72dfe1c0
--- /dev/null
+++ b/sci-electronics/eagle/eagle-5.1.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-5.1.0.ebuild,v 1.1 2008/07/17 00:12:09 nixphoeni Exp $
+
+inherit eutils
+
+DESCRIPTION="EAGLE Layout Editor"
+HOMEPAGE="http://www.cadsoft.de"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_de doc"
+LICENSE="cadsoft"
+RESTRICT="strip"
+SLOT="0"
+
+# Cadsoft has used the suffix "_p" in the past which we translate to "r"
+MY_PV=${PV/_p/r}
+
+SRC_URI="ftp://ftp.cadsoft.de/pub/program/${PV%\.[0-9]}/${PN}-lin-${MY_PV}.run"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+
+# Append ${PV} since that's what upstream installs to
+INSTALLDIR="/opt/eagle-${PV}"
+case "${LINGUAS}" in
+ *de*)
+ MY_LANG="de";;
+ *)
+ MY_LANG="en";;
+esac
+# Mandatory documentation being installed
+DOCS="README_${MY_LANG} UPDATE_${MY_LANG} library_${MY_LANG}.txt"
+
+src_unpack() {
+
+ # Extract the built-in .tar.bz2 file starting at __DATA__
+ sed -e '1,/^__DATA__$/d' "${DISTDIR}/${A}" | tar xj || die "unpacking failed"
+
+}
+
+src_install() {
+
+ cd "${S}"
+ dodir ${INSTALLDIR}
+ # Copy all to INSTALLDIR
+ cp -r . "${D}"/${INSTALLDIR}
+
+ # Install wrapper (suppressing leading tabs)
+ # see bug #188368 or http://www.cadsoft.de/faq.htm#17040701
+ exeinto /usr/bin
+ newexe "${FILESDIR}/eagle_wrapper_script" eagle
+ # Finally, append the path of the eagle binary respecting INSTALLDIR and any
+ # arguments passed to the script (thanks Denilson)
+ echo "${INSTALLDIR}/bin/eagle" '"$@"' >> "${D}/usr/bin/eagle"
+
+ # Install the documentation
+ cd doc
+ dodoc ${DOCS}
+ # Install extra documentation if requested
+ use doc && dodoc elektro-tutorial.pdf manual_${MY_LANG}.pdf tutorial_${MY_LANG}.pdf
+ doman eagle.1
+ # Remove docs left in INSTALLDIR
+ rm -rf "${D}${INSTALLDIR}/doc/*"
+ cd ..
+
+ echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle"
+ doenvd "${S}/90eagle"
+
+ # Create desktop entry
+ doicon bin/${PN}icon50.png
+ make_desktop_entry "${ROOT}/usr/bin/eagle" ${PN} ${PN}icon50.png "Graphics;Electronics"
+
+}
+
+pkg_postinst() {
+
+ elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
+ elog "now to set up the correct paths."
+ elog "You must first run eagle as root to invoke product registration."
+ elog
+ elog "Please read /usr/share/doc/${PF}/UPDATE_${MY_LANG} if you are upgrading from 4.xx."
+
+}