summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-06-25 04:28:50 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-06-25 04:28:50 +0000
commitbd1c9f705e603293bb73e13d03670bce9b275c1a (patch)
treec41e64140241e34e967c1b4dce1e1c8bf081ddc8 /sci-geosciences
parentMake repoman happy. (diff)
downloadgentoo-2-bd1c9f705e603293bb73e13d03670bce9b275c1a.tar.gz
gentoo-2-bd1c9f705e603293bb73e13d03670bce9b275c1a.tar.bz2
gentoo-2-bd1c9f705e603293bb73e13d03670bce9b275c1a.zip
Fixed bug #229297, and checked for any wxpython use flag issues.
(Portage version: 2.1.5.5)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/ChangeLog6
-rw-r--r--sci-geosciences/grass/grass-6.3.0.ebuild14
2 files changed, 14 insertions, 6 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 8edfbd84d1b6..b9dd09d8ba7b 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/grass
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.58 2008/06/24 07:45:51 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.59 2008/06/25 04:28:50 nerdboy Exp $
+
+ 25 Jun 2008; Steve Arnold <nerdboy@gentoo.org> grass-6.3.0.ebuild:
+ Fixed oversight (bug #229297) and checked for any wxpython use flag issues;
+ Tested on both amd64 and x86.
*grass-6.3.0 (24 Jun 2008)
diff --git a/sci-geosciences/grass/grass-6.3.0.ebuild b/sci-geosciences/grass/grass-6.3.0.ebuild
index d073cb9fd910..8130e5d1d012 100644
--- a/sci-geosciences/grass/grass-6.3.0.ebuild
+++ b/sci-geosciences/grass/grass-6.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.1 2008/06/24 07:45:51 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.2 2008/06/25 04:28:50 nerdboy Exp $
inherit eutils distutils fdo-mime versionator wxwidgets
@@ -78,7 +78,8 @@ pkg_setup() {
elog ""
elog "This version enables the experimental wxpython interface, which"
elog "you may want to try, since the legacy GUI seems a little wonky"
- elog "in this version; just enable the wxwindows USE flag and build."
+ elog "in this version; just enable the wxwindows USE flag and rebuild"
+ elog "grass to use it."
elog ""
if use gmath; then
for d in $(eselect lapack show); do myblas=${d}; done
@@ -152,8 +153,11 @@ src_compile() {
--with-tcltk-libs=${TCL_LIBDIR}"
if use wxwindows; then
WX_GTK_VER=2.8
- need-wxwidgets gtk2
- LIBGDI="/usr/$(get_libdir)/python${PYVER}/site-packages/wx-2.8-gtk2-unicode/wx/_gdi_.so"
+ need-wxwidgets unicode
+ # The following lib should be there, based on the above and the
+ # wxpython dependency (in theory). I still need a good way to
+ # query for the location...
+ LIBGDI="/usr/$(get_libdir)/python${PYVER}/site-packages/wx-${WX_GTK_VER}-gtk2-unicode/wx/_gdi_.so"
myconf="${myconf} --with-python --with-wxwidgets=${WX_CONFIG}"
fi
else
@@ -222,7 +226,7 @@ src_compile() {
if use wxwindows; then
emake -j1
- ln -sf "${LIBGDI}" dist.x86_64-pc-linux-gnu/lib/libgdi.so \
+ ln -sf "${LIBGDI}" dist.${CHOST}/lib/libgdi.so \
|| die "making libgdi link failed"
cd gui/wxpython/vdigit
make default -j1 || die "make vdigit failed!"