summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2014-06-20 09:29:35 +0000
committerSlawek Lis <slis@gentoo.org>2014-06-20 09:29:35 +0000
commit349cec3a1273819c4862e3f7a195872ea94d8144 (patch)
treed11fa832803cd0c7b51cd78a9da4a6e750724697 /sci-libs/Shapely
parentadd py3.4 support (diff)
downloadgentoo-2-349cec3a1273819c4862e3f7a195872ea94d8144.tar.gz
gentoo-2-349cec3a1273819c4862e3f7a195872ea94d8144.tar.bz2
gentoo-2-349cec3a1273819c4862e3f7a195872ea94d8144.zip
Fixed 513950
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'sci-libs/Shapely')
-rw-r--r--sci-libs/Shapely/ChangeLog6
-rw-r--r--sci-libs/Shapely/Shapely-1.3.0.ebuild8
-rw-r--r--sci-libs/Shapely/files/setup_unicode.patch23
3 files changed, 34 insertions, 3 deletions
diff --git a/sci-libs/Shapely/ChangeLog b/sci-libs/Shapely/ChangeLog
index 78fc544faa8c..7a93ec212f5e 100644
--- a/sci-libs/Shapely/ChangeLog
+++ b/sci-libs/Shapely/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/Shapely
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/ChangeLog,v 1.1 2014/02/28 14:04:31 slis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/ChangeLog,v 1.2 2014/06/20 09:29:34 slis Exp $
+
+ 20 Jun 2014; Sławek Lis <slis@gentoo.org> +files/setup_unicode.patch,
+ Shapely-1.3.0.ebuild:
+ Fixed 513950
*Shapely-1.3.0 (28 Feb 2014)
*Shapely-9999 (28 Feb 2014)
diff --git a/sci-libs/Shapely/Shapely-1.3.0.ebuild b/sci-libs/Shapely/Shapely-1.3.0.ebuild
index 814952569578..6f3eb5bd6350 100644
--- a/sci-libs/Shapely/Shapely-1.3.0.ebuild
+++ b/sci-libs/Shapely/Shapely-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.0.ebuild,v 1.1 2014/02/28 14:04:31 slis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Shapely/Shapely-1.3.0.ebuild,v 1.2 2014/06/20 09:29:34 slis Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
@@ -28,6 +28,10 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+src_prepare() {
+ epatch "${FILESDIR}/setup_unicode.patch"
+}
+
python_test() {
esetup.py test
-} \ No newline at end of file
+}
diff --git a/sci-libs/Shapely/files/setup_unicode.patch b/sci-libs/Shapely/files/setup_unicode.patch
new file mode 100644
index 000000000000..89e1b058f0f8
--- /dev/null
+++ b/sci-libs/Shapely/files/setup_unicode.patch
@@ -0,0 +1,23 @@
+--- setup.py.orig 2014-06-20 10:27:26.638779565 +0200
++++ setup.py 2014-06-20 10:27:29.885446151 +0200
+@@ -1,4 +1,5 @@
+ #!/usr/bin/env python
++# -*- coding: utf-8 -*-
+
+ from __future__ import print_function
+
+@@ -74,8 +75,12 @@
+ readme_text = fp.read()
+ readme_text = readme_text.replace(".. include:: CREDITS.txt", "")
+
+-with open('CREDITS.txt', 'r') as fp:
+- credits = fp.read()
++if sys.version_info[0] == 3:
++ with open('CREDITS.txt', 'r', encoding='utf-8') as fp:
++ credits = fp.read()
++elif sys.version_info[0] == 2:
++ with open('CREDITS.txt', 'r') as fp:
++ credits = fp.read().decode('utf-8')
+
+ with open('CHANGES.txt', 'r') as fp:
+ changes_text = fp.read()