summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-09 18:45:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-09 18:45:48 +0000
commit464ce61bc52e57dd5f10b5374c006792b38c41a3 (patch)
treeb0cf8d32c8344136dfaa661ca0570f1439bd277d /sci-libs/adolc
parentVersion bump (diff)
downloadgentoo-2-464ce61bc52e57dd5f10b5374c006792b38c41a3.tar.gz
gentoo-2-464ce61bc52e57dd5f10b5374c006792b38c41a3.tar.bz2
gentoo-2-464ce61bc52e57dd5f10b5374c006792b38c41a3.zip
Fixed when sparse is not set (bug #425408), and import to the main tree
(Portage version: 2.2.01.20757-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/adolc')
-rw-r--r--sci-libs/adolc/ChangeLog9
-rw-r--r--sci-libs/adolc/Manifest3
-rw-r--r--sci-libs/adolc/adolc-2.3.0.ebuild37
-rw-r--r--sci-libs/adolc/metadata.xml14
4 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/adolc/ChangeLog b/sci-libs/adolc/ChangeLog
new file mode 100644
index 000000000000..0656d07a33ea
--- /dev/null
+++ b/sci-libs/adolc/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-libs/adolc
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/adolc/ChangeLog,v 1.1 2012/07/09 18:45:48 bicatali Exp $
+
+*adolc-2.3.0 (09 Jul 2012)
+
+ 09 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +adolc-2.3.0.ebuild,
+ +metadata.xml:
+ Fixed when sparse is not set (bug #425408), and import to the main tree
diff --git a/sci-libs/adolc/Manifest b/sci-libs/adolc/Manifest
new file mode 100644
index 000000000000..121b45eed9b2
--- /dev/null
+++ b/sci-libs/adolc/Manifest
@@ -0,0 +1,3 @@
+DIST ADOL-C-2.3.0.tgz 2135572 SHA256 c795d5bde1299c90376fc398f8e48b21bb5af8f893895af1958b533d14b0a878 SHA512 2ce45f9fc16f6e2f8a40011d82b38847e391e469c33522b47e24c3b070c69b7a24c2af71e1998bb3842cf2d9004613175fdd90cb039af08ecd3ed3f14419d60b WHIRLPOOL 30b3dfbffa2ae7b075fbd427e50cc4bfb4552adf009848a0e77571a3fce655f4c67d142042c6c431dfdc696930ee33027dc56b73401a34cbf9f867d3d282bcc7
+EBUILD adolc-2.3.0.ebuild 813 SHA256 a74222fb85a13dcfbe1189fa8adb7859bfb12bd03a6349c8972f7b1d4b5f62a2 SHA512 ba8bc54538a81f0f3b1d4249a12da503c941a37312b2edfc3c0e51277feab5d4bb0863930171eb7e71e3a1317bc34bbcbf5dd6dc9be1b4638786b827ec1c85fa WHIRLPOOL 0541cc8cda417f0f054db4a149a0738d7ad94b6090fa2591281437d1e3d77eeb61ff76db3afd19d49a7cec723a6376689f483c0103e282dd28b9426479af0149
+MISC metadata.xml 540 SHA256 35b4d95794e43b4780d2b6b4f480848ef300c9e6135de83594cc88c8dab721c4 SHA512 26fd988050492ea10ab2d8612a82c149db74f8a3518a1175afe81c500d4aca9d0bec31016e5daf8e93a63a1e4d7b4e4d1f186a980dec707bed6c317dcd7a495e WHIRLPOOL ed2174ca449f51b9622ca614ab8a649fd0f34c463af9e447e7f71ca84d6f648b24e01c9eff77df1110fa3be0fd925bad4f626c0c0623a60fe8cf1e6e39499fac
diff --git a/sci-libs/adolc/adolc-2.3.0.ebuild b/sci-libs/adolc/adolc-2.3.0.ebuild
new file mode 100644
index 000000000000..e09520dcffb2
--- /dev/null
+++ b/sci-libs/adolc/adolc-2.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/adolc/adolc-2.3.0.ebuild,v 1.1 2012/07/09 18:45:48 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+inherit autotools-utils toolchain-funcs
+
+MYPN=ADOL-C
+
+DESCRIPTION="Automatic differentiation system for C/C++"
+HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="|| ( EPL-1.0 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="sparse static-libs"
+
+RDEPEND="sparse? ( sci-libs/colpack )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}-${PV}"
+
+src_configure() {
+ local myeconfargs+=(
+ $(use_enable sparse)
+ $(use sparse && echo "--with-colpack="${EPREFIX}"/usr")
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ emake test
+}
diff --git a/sci-libs/adolc/metadata.xml b/sci-libs/adolc/metadata.xml
new file mode 100644
index 000000000000..7c103ede2151
--- /dev/null
+++ b/sci-libs/adolc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The ADOLC system automatically calculates exact derivatives of a
+ C/C++ function. It uses C++ overloading to record arithmetic
+ operations, which it plays back later in various ways to calculate
+ the requested values.
+</longdescription>
+<use>
+ <flag name='sparse'>Add support for sparse matrix algebra with <pkg>sci-libs/colpack</pkg></flag>
+</use>
+</pkgmetadata>