summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-04 09:25:41 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-04 09:25:41 +0000
commit256c94e2c9065efaa2505cbd29277f2263ab15a6 (patch)
tree0e2827e332b34e400b78a97c028a942ebdf6e31a /sci-libs/coinor-flopcpp
parentFix the common coinor pkg-config installation problem (diff)
downloadgentoo-2-256c94e2c9065efaa2505cbd29277f2263ab15a6.tar.gz
gentoo-2-256c94e2c9065efaa2505cbd29277f2263ab15a6.tar.bz2
gentoo-2-256c94e2c9065efaa2505cbd29277f2263ab15a6.zip
Fix the common coinor pkg-config installation problem
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/coinor-flopcpp')
-rw-r--r--sci-libs/coinor-flopcpp/ChangeLog5
-rw-r--r--sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild11
2 files changed, 14 insertions, 2 deletions
diff --git a/sci-libs/coinor-flopcpp/ChangeLog b/sci-libs/coinor-flopcpp/ChangeLog
index 136fe9a725b7..277ebb4bc3a7 100644
--- a/sci-libs/coinor-flopcpp/ChangeLog
+++ b/sci-libs/coinor-flopcpp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/coinor-flopcpp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-flopcpp/ChangeLog,v 1.2 2014/01/15 20:10:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-flopcpp/ChangeLog,v 1.3 2014/02/04 09:25:41 jlec Exp $
+
+ 04 Feb 2014; Justin Lecher <jlec@gentoo.org> coinor-flopcpp-1.1.7.ebuild:
+ Fix the common coinor pkg-config installation problem
15 Jan 2014; Sébastien Fabbro <bicatali@gentoo.org>
coinor-flopcpp-1.1.7.ebuild:
diff --git a/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild b/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
index beff56887952..4f700ff893c6 100644
--- a/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
+++ b/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild,v 1.2 2014/01/15 20:10:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-flopcpp/coinor-flopcpp-1.1.7.ebuild,v 1.3 2014/02/04 09:25:41 jlec Exp $
EAPI=5
@@ -27,9 +27,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYPN}-${PV}/FlopCpp"
+src_prepare() {
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
src_configure() {
+ # needed for the --with-coin-instdir
+ dodir /usr
local myeconfargs=(
--enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
$(use_with doc dot)
)
autotools-utils_src_configure