summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-06-24 14:21:49 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-06-24 14:21:49 +0000
commit65f78d874c84da119e138496a96ad7959bb189d8 (patch)
treedb38c8e8346acf564c26bc889af47ad2637cd204 /sci-libs/fftw
parentMarking sparc stable (diff)
downloadgentoo-2-65f78d874c84da119e138496a96ad7959bb189d8.tar.gz
gentoo-2-65f78d874c84da119e138496a96ad7959bb189d8.tar.bz2
gentoo-2-65f78d874c84da119e138496a96ad7959bb189d8.zip
Added code to fix improper category of the fftw3 info file. This fixes bug #77660.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/ChangeLog8
-rw-r--r--sci-libs/fftw/fftw-3.0.1-r2.ebuild10
-rw-r--r--sci-libs/fftw/fftw-3.1.1.ebuild6
3 files changed, 21 insertions, 3 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index f2635994c391..d0bead6137e6 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/fftw
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.33 2006/05/11 09:59:33 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.34 2006/06/24 14:21:49 markusle Exp $
+
+ 24 Jun 2006; Markus Dittrich <markusle@gentoo.org> fftw-3.0.1-r2.ebuild,
+ fftw-3.1.1.ebuild:
+ Added code to fix improper category of the fftw3 info file.
+ Thanks much to P.L.Hayes <paul@wolfbone.ath.cx> for pointing this
+ out and this fixes bug #77660.
11 May 2006; Robin H. Johnson <robbat2@gentoo.org> fftw-3.1.1.ebuild:
Bug #131320 - Use altivec only for single precision - it doesn't work with
diff --git a/sci-libs/fftw/fftw-3.0.1-r2.ebuild b/sci-libs/fftw/fftw-3.0.1-r2.ebuild
index 1065ccb569b3..556448d0214a 100644
--- a/sci-libs/fftw/fftw-3.0.1-r2.ebuild
+++ b/sci-libs/fftw/fftw-3.0.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.0.1-r2.ebuild,v 1.11 2006/01/07 01:35:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.0.1-r2.ebuild,v 1.12 2006/06/24 14:21:49 markusle Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -20,6 +20,14 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/3-tmpfile.patch
epatch "${FILESDIR}"/${P}-altivec.patch
+
+ # fix info files
+ local infofile
+ for infofile in doc/fftw*info*; do
+ sed -e 's/Texinfo documentation system/Libraries/' \
+ -i ${infofile} || die "failed to fix info files"
+ done
+
autoreconf
libtoolize --copy --force
cd "${WORKDIR}"
diff --git a/sci-libs/fftw/fftw-3.1.1.ebuild b/sci-libs/fftw/fftw-3.1.1.ebuild
index 142f4120a0b0..4755b4dfab68 100644
--- a/sci-libs/fftw/fftw-3.1.1.ebuild
+++ b/sci-libs/fftw/fftw-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.1.1.ebuild,v 1.5 2006/05/12 00:25:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.1.1.ebuild,v 1.6 2006/06/24 14:21:49 markusle Exp $
inherit flag-o-matic eutils toolchain-funcs autotools
@@ -23,6 +23,10 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-ppc-macos.patch
fi
+ # fix info file
+ sed -e 's/Texinfo documentation system/Libraries/' \
+ -i doc/fftw3.info || die "failed to fix info file"
+
# fix altivec compilation problems (bug #129304)
epatch "${FILESDIR}"/${PN}-altivec-headers.patch
eautoconf