summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-06 11:57:49 +0000
committerJustin Lecher <jlec@gentoo.org>2015-01-06 11:57:49 +0000
commit577309e39b8b2c484eba32873c039e5cd43668b8 (patch)
treedf77a37ac8b316166716a907ac597ceb36be2159 /sci-libs/htslib
parentrevbump; conversion -> distutils-r1, rm old (diff)
downloadgentoo-2-577309e39b8b2c484eba32873c039e5cd43668b8.tar.gz
gentoo-2-577309e39b8b2c484eba32873c039e5cd43668b8.tar.bz2
gentoo-2-577309e39b8b2c484eba32873c039e5cd43668b8.zip
sci-libs/htslib: Version BUmp
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/htslib')
-rw-r--r--sci-libs/htslib/ChangeLog9
-rw-r--r--sci-libs/htslib/htslib-1.1.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/sci-libs/htslib/ChangeLog b/sci-libs/htslib/ChangeLog
index f519eae06e9b..101f2066b547 100644
--- a/sci-libs/htslib/ChangeLog
+++ b/sci-libs/htslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/htslib
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/htslib/ChangeLog,v 1.4 2014/09/20 19:20:13 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/htslib/ChangeLog,v 1.5 2015/01/06 11:57:49 jlec Exp $
+
+*htslib-1.1 (06 Jan 2015)
+
+ 06 Jan 2015; Justin Lecher <jlec@gentoo.org> +htslib-1.1.ebuild:
+ Version BUmp
20 Sep 2014; Justin Lecher <jlec@gentoo.org> htslib-1.0.ebuild:
Fix pc file prefix problems
diff --git a/sci-libs/htslib/htslib-1.1.ebuild b/sci-libs/htslib/htslib-1.1.ebuild
new file mode 100644
index 000000000000..ed6b7d00ac24
--- /dev/null
+++ b/sci-libs/htslib/htslib-1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/htslib/htslib-1.1.ebuild,v 1.1 2015/01/06 11:57:49 jlec Exp $
+
+EAPI=5
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="C library for high-throughput sequencing data formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="mirror://sourceforge/samtools/${PV}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ sed \
+ -e "/libdir/s:lib$:$(get_libdir):g" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ install
+
+ rm "${ED}/usr/share/man/man1/libhts.so.1" || die
+
+ if ! use static-libs; then
+ find "${ED}" -type f -name "*.a" -delete || die
+ fi
+
+ dodoc README
+}
+