summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-26 10:21:07 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-26 10:21:07 +0000
commit0d5886a65c2447df5682f96d581889b1fe18bcd0 (patch)
treeb1c0bf888c612da73aedead87403a8c203e5473a /sci-libs/jmol-acme/jmol-acme-1.0.ebuild
parentBumped EAPI (diff)
downloadgentoo-2-0d5886a65c2447df5682f96d581889b1fe18bcd0.tar.gz
gentoo-2-0d5886a65c2447df5682f96d581889b1fe18bcd0.tar.bz2
gentoo-2-0d5886a65c2447df5682f96d581889b1fe18bcd0.zip
Straight out QA issues
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/jmol-acme/jmol-acme-1.0.ebuild')
-rw-r--r--sci-libs/jmol-acme/jmol-acme-1.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sci-libs/jmol-acme/jmol-acme-1.0.ebuild b/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
index 6e1cbd976e25..243084102943 100644
--- a/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
+++ b/sci-libs/jmol-acme/jmol-acme-1.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/jmol-acme/jmol-acme-1.0.ebuild,v 1.4 2010/01/21 11:12:09 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/jmol-acme/jmol-acme-1.0.ebuild,v 1.5 2011/06/26 10:21:07 jlec Exp $
+
+EAPI=4
inherit java-pkg-2 java-ant-2
@@ -8,7 +10,7 @@ MY_P="Acme"
# It proved difficult to recompile the whole Acme package, so we'll only take what we need.
-DESCRIPTION="Portions of the Acme collection required for jMol. Courtesy of ACME - Purveyors of fine freeware since 1972."
+DESCRIPTION="Portions of the Acme collection required for jMol"
HOMEPAGE="http://www.acme.com/"
SRC_URI="http://www.acme.com/resources/classes/${MY_P}.tar.gz"
@@ -22,10 +24,7 @@ RDEPEND=">=virtual/jre-1.4"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
mkdir -p classes
find . -name \*.class -delete
java-pkg_filter-compiler jikes