summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-11-14 19:29:59 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-11-14 19:29:59 +0000
commitaa6e6c3ec184612ab0bda7bca895db66e67a07a7 (patch)
treef21c2c37b527dbd8ee5ff16e5f1e36f43848b236 /sci-libs/libgeda/libgeda-20050820.ebuild
parentChange install loc for gaim-latex lib. Bug #112381 (diff)
downloadgentoo-2-aa6e6c3ec184612ab0bda7bca895db66e67a07a7.tar.gz
gentoo-2-aa6e6c3ec184612ab0bda7bca895db66e67a07a7.tar.bz2
gentoo-2-aa6e6c3ec184612ab0bda7bca895db66e67a07a7.zip
Version bump (#107929); remove old versions.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-libs/libgeda/libgeda-20050820.ebuild')
-rw-r--r--sci-libs/libgeda/libgeda-20050820.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/libgeda/libgeda-20050820.ebuild b/sci-libs/libgeda/libgeda-20050820.ebuild
new file mode 100644
index 000000000000..a1e5eb7b5a7c
--- /dev/null
+++ b/sci-libs/libgeda/libgeda-20050820.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeda/libgeda-20050820.ebuild,v 1.1 2005/11/14 19:29:59 plasmaroo Exp $
+
+HOMEPAGE="http://www.geda.seul.org"
+DESCRIPTION="libgeda - this library provides functions needed for the gEDA core suite"
+SRC_URI="http://www.geda.seul.org/devel/${PV}/libgeda-${PV}.tar.gz"
+
+IUSE="png static"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+
+DEPEND=">=dev-libs/glib-2.4.8
+ >=x11-libs/gtk+-2.2
+ virtual/x11
+
+ >=dev-util/guile-1.6.3
+ >=dev-util/pkgconfig-0.15.0
+ png? ( >=sci-libs/libgdgeda-2.0.15 )"
+
+src_compile () {
+ local myconf
+
+ use png || myconf='--disable-gdgeda'
+ use static && myconf="${myconf} --enable-static --disable-shared"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog README
+}