summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-07 07:10:49 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-07 07:10:49 +0000
commit1caa463bcc6de45b0604faf4362b4cd52643195e (patch)
treed89a2327dc582b156bc5acdc3283df2ebcf3315c /sci-libs/libint
parentVersion bump. (diff)
downloadgentoo-2-1caa463bcc6de45b0604faf4362b4cd52643195e.tar.gz
gentoo-2-1caa463bcc6de45b0604faf4362b4cd52643195e.tar.bz2
gentoo-2-1caa463bcc6de45b0604faf4362b4cd52643195e.zip
Version Bump bug #548674; thanks Viktor Yu. Kovalskii for the initial ebuilds
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/libint')
-rw-r--r--sci-libs/libint/ChangeLog12
-rw-r--r--sci-libs/libint/files/libint-1.1.6-as-needed.patch77
-rw-r--r--sci-libs/libint/libint-1.1.6.ebuild41
-rw-r--r--sci-libs/libint/libint-2.0.5.ebuild60
4 files changed, 188 insertions, 2 deletions
diff --git a/sci-libs/libint/ChangeLog b/sci-libs/libint/ChangeLog
index ca8873759667..9ad7e87c9bad 100644
--- a/sci-libs/libint/ChangeLog
+++ b/sci-libs/libint/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/libint
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/ChangeLog,v 1.16 2012/12/14 07:54:32 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/ChangeLog,v 1.17 2015/05/07 07:10:49 jlec Exp $
+
+*libint-1.1.6 (07 May 2015)
+*libint-2.0.5 (07 May 2015)
+
+ 07 May 2015; Justin Lecher <jlec@gentoo.org>
+ +files/libint-1.1.6-as-needed.patch, +libint-1.1.6.ebuild,
+ +libint-2.0.5.ebuild:
+ Version Bump bug #548674; thanks Viktor Yu. Kovalskii for the initial ebuilds
14 Dec 2012; Justin Lecher <jlec@gentoo.org> -libint-1.1.2.ebuild,
metadata.xml:
diff --git a/sci-libs/libint/files/libint-1.1.6-as-needed.patch b/sci-libs/libint/files/libint-1.1.6-as-needed.patch
new file mode 100644
index 000000000000..c48505314b39
--- /dev/null
+++ b/sci-libs/libint/files/libint-1.1.6-as-needed.patch
@@ -0,0 +1,77 @@
+ configure.ac | 3 +--
+ src/bin/MakeRules.in | 2 +-
+ src/lib/libderiv/Makefile.library | 2 +-
+ src/lib/libint/Makefile.library | 2 +-
+ src/lib/libr12/Makefile.library | 2 +-
+ 5 files changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index dc86e88..8cc3aac 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -317,12 +317,11 @@ LIBS=$withval
+ echo Using extra libraries: $withval
+ )
+
+-LDFLAGS=
+ LIBDIRS=
+ AC_ARG_WITH(libdirs,
+ [ --with-libdirs Specifies library directories (-Ldir1 -Ldir2).],
+ LIBDIRS=$withval
+-LDFLAGS=$withval
++LDFLAGS="$LDFLAGS $withval"
+ echo Using extra library directories: $withval
+ )
+
+diff --git a/src/bin/MakeRules.in b/src/bin/MakeRules.in
+index 5b90607..8ea5005 100644
+--- a/src/bin/MakeRules.in
++++ b/src/bin/MakeRules.in
+@@ -3,7 +3,7 @@ HAVE_MAKERULES = yes
+
+ BINOBJ = $(BUILD_CSRC:%.c=%.$(OBJSUF)) $(BUILD_CXXSRC:%.cc=%.$(OBJSUF))
+ $(BUILD_BINARY): $(BINOBJ)
+- $(LD) $^ $(LDFLAGS) $(SYSLIBS) -o $@
++ $(LD) $(LDFLAGS) $^ $(SYSLIBS) -o $@
+
+ .PHONY: install install_inc install_target uninstall clean oclean distclean targetclean realclean
+ install::
+diff --git a/src/lib/libderiv/Makefile.library b/src/lib/libderiv/Makefile.library
+index ee152ef..8debfe8 100644
+--- a/src/lib/libderiv/Makefile.library
++++ b/src/lib/libderiv/Makefile.library
+@@ -23,7 +23,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
+diff --git a/src/lib/libint/Makefile.library b/src/lib/libint/Makefile.library
+index 23e2918..01c4225 100644
+--- a/src/lib/libint/Makefile.library
++++ b/src/lib/libint/Makefile.library
+@@ -41,7 +41,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
+diff --git a/src/lib/libr12/Makefile.library b/src/lib/libr12/Makefile.library
+index 1510807..26d47a4 100644
+--- a/src/lib/libr12/Makefile.library
++++ b/src/lib/libr12/Makefile.library
+@@ -47,7 +47,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
diff --git a/sci-libs/libint/libint-1.1.6.ebuild b/sci-libs/libint/libint-1.1.6.ebuild
new file mode 100644
index 000000000000..62c4800eebeb
--- /dev/null
+++ b/sci-libs/libint/libint-1.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.6.ebuild,v 1.1 2015/05/07 07:10:49 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2 toolchain-funcs versionator
+
+MY_PV="$(replace_all_version_separators -)"
+
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
+HOMEPAGE="https://github.com/evaleev/libint"
+SRC_URI="https://github.com/evaleev/libint/archive/release-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+S="${WORKDIR}/${PN}-release-${MY_PV}"
+
+PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-deriv
+ --enable-r12
+ --with-cc=$(tc-getCC)
+ --with-cxx=$(tc-getCXX)
+ --with-cc-optflags="${CFLAGS}"
+ --with-cxx-optflags="${CXXFLAGS}"
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-libs/libint/libint-2.0.5.ebuild b/sci-libs/libint/libint-2.0.5.ebuild
new file mode 100644
index 000000000000..fa4d6f0a4f98
--- /dev/null
+++ b/sci-libs/libint/libint-2.0.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-2.0.5.ebuild,v 1.1 2015/05/07 07:10:49 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2 toolchain-funcs versionator
+
+MY_PV="$(replace_all_version_separators -)"
+
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
+HOMEPAGE="https://github.com/evaleev/libint"
+SRC_URI="https://github.com/evaleev/libint/archive/release-2-0-5.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs doc"
+
+S="${WORKDIR}/${PN}-release-${MY_PV}"
+
+DEPEND="
+ dev-libs/boost
+ doc? (
+ dev-texlive/texlive-latex
+ dev-tex/latex2html
+ )"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ --with-cxx=$(tc-getCXX)
+ --with-cxx-optflags="${CXXFLAGS}"
+ --with-cxxgen-optflags="${CXXFLAGS}"
+ --with-cxxdepend=$(tc-getCXX)
+ --with-ranlib=$(tc-getRANLIB)
+ --with-ar=$(tc-getAR)
+ --with-ld=$(tc-getLD)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+
+ use doc && emake html pdf
+}
+
+src_install() {
+ einstall
+
+ if use doc; then
+ DOCS=( doc/progman/progman.pdf )
+ HTML_DOCS=( doc/progman/progman/*.{html,png,css} )
+ einstalldocs
+ fi
+}