summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-26 09:39:04 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-26 09:39:04 +0000
commit0b116478e7db801cbee03c2e81282721142f793e (patch)
treeb8045553eaa6e2175a14ee3dec1e4ab7075bc209 /sci-libs/metis/metis-4.0.1-r1.ebuild
parentApply patch from Mateusz Dziadko <matidz.gentoo@gmail.com> to compile against... (diff)
downloadgentoo-2-0b116478e7db801cbee03c2e81282721142f793e.tar.gz
gentoo-2-0b116478e7db801cbee03c2e81282721142f793e.tar.bz2
gentoo-2-0b116478e7db801cbee03c2e81282721142f793e.zip
Bumped EAPI and corrected structure
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/metis/metis-4.0.1-r1.ebuild')
-rw-r--r--sci-libs/metis/metis-4.0.1-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sci-libs/metis/metis-4.0.1-r1.ebuild b/sci-libs/metis/metis-4.0.1-r1.ebuild
index 6a273c7fc7a6..67ab1d7e93a5 100644
--- a/sci-libs/metis/metis-4.0.1-r1.ebuild
+++ b/sci-libs/metis/metis-4.0.1-r1.ebuild
@@ -1,32 +1,32 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/metis/metis-4.0.1-r1.ebuild,v 1.17 2011/06/21 15:12:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/metis/metis-4.0.1-r1.ebuild,v 1.18 2011/06/26 09:39:04 jlec Exp $
inherit autotools eutils fortran-2
MYP=${PN}-4.0
+
DESCRIPTION="A package for unstructured serial graph partitioning"
HOMEPAGE="http://www-users.cs.umn.edu/~karypis/metis/metis/index.html"
SRC_URI="http://glaros.dtc.umn.edu/gkhome/fetch/sw/${PN}/${MYP}.tar.gz"
+SLOT="0"
KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
LICENSE="free-noncomm"
-
IUSE="doc static-libs"
-SLOT="0"
-DEPEND="
- virtual/fortran
- "
-RDEPEND="!sci-libs/parmetis"
+DEPEND="virtual/fortran"
+RDEPEND="${DEPEND}
+ !sci-libs/parmetis"
S="${WORKDIR}/${MYP}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-autotools.patch
- epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch \
+ "${FILESDIR}"/${P}-autotools.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
eautoreconf
}