summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-07 05:28:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-07 05:28:29 +0000
commit33a26846408c95bd26e671b6f367383c7229a15b (patch)
tree7962b1d69f317165d3f6436c8945271047736bc1 /sci-libs/minuit
parentVersion bump (diff)
downloadgentoo-2-33a26846408c95bd26e671b6f367383c7229a15b.tar.gz
gentoo-2-33a26846408c95bd26e671b6f367383c7229a15b.tar.bz2
gentoo-2-33a26846408c95bd26e671b6f367383c7229a15b.zip
Version bump. Added static-libs flag.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/minuit')
-rw-r--r--sci-libs/minuit/ChangeLog10
-rw-r--r--sci-libs/minuit/minuit-5.28.00.ebuild (renamed from sci-libs/minuit/minuit-5.27.02.ebuild)45
2 files changed, 25 insertions, 30 deletions
diff --git a/sci-libs/minuit/ChangeLog b/sci-libs/minuit/ChangeLog
index 0a73ed490a04..0ff8fca75a14 100644
--- a/sci-libs/minuit/ChangeLog
+++ b/sci-libs/minuit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/minuit
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/ChangeLog,v 1.15 2010/11/14 16:26:19 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/ChangeLog,v 1.16 2011/03/07 05:28:28 bicatali Exp $
+
+*minuit-5.28.00 (07 Mar 2011)
+
+ 07 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> -minuit-5.27.02.ebuild,
+ +minuit-5.28.00.ebuild:
+ Version bump. Added static-libs flag.
14 Nov 2010; Justin Lecher <jlec@gentoo.org> minuit-5.27.02.ebuild:
Keyworded for ~-linux prefix
diff --git a/sci-libs/minuit/minuit-5.27.02.ebuild b/sci-libs/minuit/minuit-5.28.00.ebuild
index a4e7e615895e..cb2519e7a4c5 100644
--- a/sci-libs/minuit/minuit-5.27.02.ebuild
+++ b/sci-libs/minuit/minuit-5.28.00.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/minuit-5.27.02.ebuild,v 1.4 2010/11/14 16:26:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/minuit-5.28.00.ebuild,v 1.1 2011/03/07 05:28:28 bicatali Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils toolchain-funcs
MY_PN=Minuit2
@@ -17,55 +17,44 @@ SRC_URI="http://seal.web.cern.ch/seal/MathLibs/${MY_PN}/${MY_PN}-${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc openmp"
+IUSE="doc openmp static-libs"
DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
S="${WORKDIR}/${MY_PN}-${PV}"
-pkg_setup() {
- if use openmp && ! tc-has-openmp; then
- ewarn "You are using gcc built without openmp"
- ewarn "Switch CXX to an OpenMP capable compiler"
- die "Need openmp"
- fi
-}
-
src_prepare() {
- epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${PN}-5.27.02-asneeded.patch
rm config/m4/ac_openmp.m4
AT_M4DIR="config/m4" eautoreconf
}
src_configure() {
- econf $(use_enable openmp)
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable openmp)
}
src_compile() {
- emake || die "emake failed"
- if use doc; then
- emake docs || die "emake docs failed"
- fi
+ emake
+ use doc && emake docs
}
src_test() {
- emake check || die "emake check failed"
- # make check only compiles the tests. run them
- for d in test/Mn*; do
- cd "${S}"/${d}
- for t in test_*; do
+ emake check
+ cd test/MnTutorial
+ local t
+ for t in test_*; do
./${t} || die "${t} failed"
- done
done
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
insinto /usr/share/doc/${PF}/MnTutorial
doins test/MnTutorial/*.{h,cxx}
if use doc; then
- insinto /usr/share/doc/${PF}
- doins "${DISTDIR}"/mn*.pdf || die "doins failed"
- dohtml -r doc/html/* || die "dohtml failed"
+ dodoc "${DISTDIR}"/mn*.pdf
+ dohtml -r doc/html/*
fi
}