summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-24 06:20:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-24 06:20:59 +0000
commit6a23c7c643d59238715a9567cf01160d65e10194 (patch)
tree93c826d6c4e12d675e4a2bbb7a5e2c8651dd5ecc /sci-libs/minuit
parentVersion bump (diff)
downloadgentoo-2-6a23c7c643d59238715a9567cf01160d65e10194.tar.gz
gentoo-2-6a23c7c643d59238715a9567cf01160d65e10194.tar.bz2
gentoo-2-6a23c7c643d59238715a9567cf01160d65e10194.zip
Version bump
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/minuit')
-rw-r--r--sci-libs/minuit/ChangeLog8
-rw-r--r--sci-libs/minuit/files/minuit-5.24.00-as-needed.patch26
-rw-r--r--sci-libs/minuit/minuit-5.24.00.ebuild70
3 files changed, 103 insertions, 1 deletions
diff --git a/sci-libs/minuit/ChangeLog b/sci-libs/minuit/ChangeLog
index e6ff9a72fc68..42ea53db409a 100644
--- a/sci-libs/minuit/ChangeLog
+++ b/sci-libs/minuit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/minuit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/ChangeLog,v 1.8 2009/01/23 14:11:22 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/ChangeLog,v 1.9 2009/09/24 06:20:58 bicatali Exp $
+
+*minuit-5.24.00 (24 Sep 2009)
+
+ 24 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +minuit-5.24.00.ebuild, +files/minuit-5.24.00-as-needed.patch:
+ Version bump
*minuit-5.22.00 (23 Jan 2009)
diff --git a/sci-libs/minuit/files/minuit-5.24.00-as-needed.patch b/sci-libs/minuit/files/minuit-5.24.00-as-needed.patch
new file mode 100644
index 000000000000..b1cf59b177a9
--- /dev/null
+++ b/sci-libs/minuit/files/minuit-5.24.00-as-needed.patch
@@ -0,0 +1,26 @@
+--- config/m4/ac_openmp.m4.orig 2009-07-17 16:35:06.000000000 +0100
++++ config/m4/ac_openmp.m4 2009-09-24 07:17:56.000000000 +0100
+@@ -87,6 +87,13 @@
+ *)
+ OPENMP_[]_AC_LANG_PREFIX[]FLAGS=$ac_cv_prog_[]_AC_LANG_ABBREV[]_openmp ;;
+ esac
++ OPENMP_LIBS=
++ if test "x$ac_option" = "x-fopenmp"; then
++ OPENMP_LIBS="-lgomp"
++ fi
++ AC_SUBST([OPENMP_LIBS])
++
+ fi
+ AC_SUBST([OPENMP_]_AC_LANG_PREFIX[FLAGS])
++
+ ])
+--- configure.in.orig 2009-09-24 06:53:14.000000000 +0100
++++ configure.in 2009-09-24 06:50:12.000000000 +0100
+@@ -43,6 +43,7 @@
+ AC_OPENMP
+ CFLAGS="$CFLAGS $OPENMP_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $OPENMP_CXXFLAGS"
++LIBS="$LIBS $OPENMP_LIBS"
+
+ dnl files to be generated
+ AC_OUTPUT(Makefile inc/Makefile inc/Minuit2/Makefile inc/Math/Makefile src/Makefile
diff --git a/sci-libs/minuit/minuit-5.24.00.ebuild b/sci-libs/minuit/minuit-5.24.00.ebuild
new file mode 100644
index 000000000000..94efc03035d6
--- /dev/null
+++ b/sci-libs/minuit/minuit-5.24.00.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/minuit/minuit-5.24.00.ebuild,v 1.1 2009/09/24 06:20:58 bicatali Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs autotools
+
+MY_PN=Minuit2
+
+DESCRIPTION="A C++ physics analysis tool for function minimization"
+HOMEPAGE="http://seal.web.cern.ch/seal/MathLibs/Minuit2/html/index.html"
+
+SRC_URI="http://seal.web.cern.ch/seal/MathLibs/${MY_PN}/${MY_PN}-${PV}.tar.gz
+ doc? ( http://seal.cern.ch/documents/minuit/mnusersguide.pdf
+ http://seal.cern.ch/documents/minuit/mntutorial.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc openmp"
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCXX)$ == *g++* ]] && \
+ ! built_with_use sys-devel/gcc openmp; then
+ ewarn "You are using gcc built without openmp"
+ ewarn "Switch CXX to an OpenMP capable compiler"
+ die "Need openmp"
+ fi
+}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ AT_M4DIR="config/m4" eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable openmp)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ # make check only compiles the tests. run them
+ for d in test/Mn*; do
+ cd "${S}"/${d}
+ for t in test_*; do
+ ./${t} || die "${t} failed"
+ done
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto /usr/share/doc/${PF}/MnTutorial
+ doins test/MnTutorial/*.{h,cxx}
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/mn*.pdf || die "doins failed"
+ dohtml -r doc/html/* || die "dohtml failed"
+ fi
+}