summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 21:45:07 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 21:45:07 +0000
commit05fbc91b222f0bb57fa81914b0329e4d87870c2b (patch)
tree26840767eaa44cc78798958d634a1a36c7785786 /sci-libs/mkl/mkl-5.2.ebuild
parentChange encoding to UTF-8 for GLEP 31 compliance (Manifest recommit) (diff)
downloadgentoo-2-05fbc91b222f0bb57fa81914b0329e4d87870c2b.tar.gz
gentoo-2-05fbc91b222f0bb57fa81914b0329e4d87870c2b.tar.bz2
gentoo-2-05fbc91b222f0bb57fa81914b0329e4d87870c2b.zip
Moved from dev-libs/mkl to sci-libs/mkl.
Diffstat (limited to 'sci-libs/mkl/mkl-5.2.ebuild')
-rw-r--r--sci-libs/mkl/mkl-5.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/mkl/mkl-5.2.ebuild b/sci-libs/mkl/mkl-5.2.ebuild
new file mode 100644
index 000000000000..ecab0e20dbcf
--- /dev/null
+++ b/sci-libs/mkl/mkl-5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-5.2.ebuild,v 1.1 2004/12/28 21:45:07 ribosome Exp $
+
+S=${WORKDIR}
+DESCRIPTION="Intel(R) Math Kernel Library"
+HOMEPAGE="http://developer.intel.com/software/products/mkl/"
+SRC_URI="http://developer.intel.com/software/products/mkl/downloads/mkl52lin_e.tar"
+
+IUSE=""
+
+# No need to, there aren't any executables and it takes a long time.
+RESTRICT="nostrip"
+
+SLOT="0"
+LICENSE="imkl-5.1"
+KEYWORDS="x86 -sparc"
+
+DEPEND="app-arch/cpio
+ app-arch/rpm"
+
+RDEPEND=">=sys-kernel/linux-headers-2.4
+ >=sys-libs/glibc-2.2.2"
+
+src_compile() {
+ mkdir opt
+
+ for x in intel-*.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+}
+
+src_install () {
+ cp -a opt ${D}
+ cd ${D}/opt/intel/mkl/
+ dodoc license.txt
+ dohtml -r mklnotes.htm mkllic.htm doc/*
+ rm -rf license.txt *.htm uninstall doc/
+
+ # Mkl enviroment
+ dodir /etc/env.d
+ echo "LDPATH=/opt/intel/mkl/lib/32/" > ${D}/etc/env.d/35mkl
+ echo "MKL_ROOT=/opt/intel/mkl" >> ${D}/etc/env.d/35mkl
+}