summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-03-03 05:21:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-03-03 05:21:04 +0000
commitb7ab6bc1ff0147603fa353f597ae3d3c4827c83c (patch)
tree3244aef41a187cf317b1b43518c83d9b62faa2df /sci-libs/nlopt
parentFix build with GCC 4.7 (bug #423813). (diff)
downloadgentoo-2-b7ab6bc1ff0147603fa353f597ae3d3c4827c83c.tar.gz
gentoo-2-b7ab6bc1ff0147603fa353f597ae3d3c4827c83c.tar.bz2
gentoo-2-b7ab6bc1ff0147603fa353f597ae3d3c4827c83c.zip
Allow C and C++ libraries to be simultaneously installed
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/nlopt')
-rw-r--r--sci-libs/nlopt/ChangeLog9
-rw-r--r--sci-libs/nlopt/nlopt-2.3-r2.ebuild119
2 files changed, 126 insertions, 2 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index d1df8e65bb2c..7b0dfd2b5650 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/nlopt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.19 2012/08/03 17:43:29 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.20 2013/03/03 05:21:04 bicatali Exp $
+
+*nlopt-2.3-r2 (03 Mar 2013)
+
+ 03 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> +nlopt-2.3-r2.ebuild:
+ Allow C and C++ libraries to be simultaneously installed
*nlopt-2.3-r1 (03 Aug 2012)
diff --git a/sci-libs/nlopt/nlopt-2.3-r2.ebuild b/sci-libs/nlopt/nlopt-2.3-r2.ebuild
new file mode 100644
index 000000000000..a2025cc13998
--- /dev/null
+++ b/sci-libs/nlopt/nlopt-2.3-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.3-r2.ebuild,v 1.1 2013/03/03 05:21:04 bicatali Exp $
+
+EAPI=5
+
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="python? *"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils python
+
+DESCRIPTION="Non-linear optimization library"
+HOMEPAGE="http://ab-initio.mit.edu/nlopt/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="cxx guile octave python static-libs"
+
+DEPEND="
+ guile? ( dev-scheme/guile )
+ octave? ( sci-mathematics/octave )
+ python? ( dev-python/numpy )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.4-fix-nlopt_hpp-location.patch
+ "${FILESDIR}"/${PN}-2.3-pkgconfig.patch
+ "${FILESDIR}"/${PN}-2.3-as-needed.patch
+)
+
+src_prepare() {
+ autotools-utils_src_prepare
+ if use python; then
+ sed -i \
+ -e '/^LTLIBRARIES/s:$(pyexec_LTLIBRARIES)::g' \
+ swig/Makefile.in || die
+ echo '#!/bin/sh' > py-compile
+ fi
+ use python && python_src_prepare
+}
+
+src_configure() {
+ if use octave; then
+ export OCT_INSTALL_DIR="${EPREFIX}"/usr/libexec/octave/site/oct/${CHOST}
+ export M_INSTALL_DIR="${EPREFIX}"/usr/share/octave/site/m
+ else
+ export MKOCTFILE=None
+ fi
+ local myeconfargs=(
+ $(use_with guile)
+ $(use_with octave)
+ $(use_with python)
+ )
+ autotools-utils_src_configure
+ if use cxx; then
+ myeconfargs+=( --with-cxx )
+ BUILD_DIR="${BUILD_DIR}_cxx" autotools-utils_src_configure
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use python; then
+ python_copy_sources swig
+ compilation() {
+ autotools-utils_src_compile \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ PYTHON_LDFLAGS="${EPREFIX}$(python_get_library -l)" \
+ PYTHON_SITE_PKG="${EPREFIX}$(python_get_sitedir)" \
+ PYTHON_VERSION="${EPREFIX}$(python_get_version)" \
+ PYTHON_INCLUDES="${EPREFIX}$(python_get_includedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir swig compilation
+ fi
+ use cxx && autotools-utils_src_compile -C "${BUILD_DIR}_cxx"
+}
+
+src_test() {
+ cd "${AUTOTOOLS_BUILD_DIR}"/test
+ local a f
+ for a in {1..9}; do
+ for f in {5..9}; do
+ ./testopt -a $a -o $f || die "algorithm $a function $f failed"
+ done
+ done
+}
+
+src_install() {
+ # build cxx first so the c lib overwrites the pc file
+ use cxx && autotools-utils_src_install -C "${BUILD_DIR}_cxx"
+ autotools-utils_src_install
+ if use python; then
+ installation() {
+ cd "${AUTOTOOLS_BUILD_DIR}"
+ rm *.la
+ emake DESTDIR=${D} install \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir swig installation
+ python_clean_installation_image
+ fi
+ local r
+ for r in */README; do newdoc ${r} README.$(dirname ${r}); done
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize ${PN}.py
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup ${PN}.py
+}