summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-01-21 23:38:27 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-01-21 23:38:27 +0000
commita5fd38bc9c2fe92d5384dd5f696089936b58a935 (patch)
tree8c1fab4330b8b584f01a4173fa388c993c5721c0 /sci-libs/vtk/vtk-5.4.2-r1.ebuild
parentFix Makefile to respect user CFLAGS (diff)
downloadgentoo-2-a5fd38bc9c2fe92d5384dd5f696089936b58a935.tar.gz
gentoo-2-a5fd38bc9c2fe92d5384dd5f696089936b58a935.tar.bz2
gentoo-2-a5fd38bc9c2fe92d5384dd5f696089936b58a935.zip
Added patch to allow compilation against boost-1.42 (fixes #301684).
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/vtk/vtk-5.4.2-r1.ebuild')
-rw-r--r--sci-libs/vtk/vtk-5.4.2-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sci-libs/vtk/vtk-5.4.2-r1.ebuild b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
index 5f4feeba9dc2..479517e67f02 100644
--- a/sci-libs/vtk/vtk-5.4.2-r1.ebuild
+++ b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.2 2010/01/16 20:16:29 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.3 2010/01/21 23:38:26 markusle Exp $
EAPI="2"
inherit eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt3 qt4 cmake-utils
@@ -44,7 +44,7 @@ RDEPEND="mpi? ( || (
DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.5 )
- boost? ( dev-libs/boost )
+ boost? ( >=dev-libs/boost-1.40.0 )
>=dev-util/cmake-2.6"
S="${WORKDIR}"/VTK
@@ -73,6 +73,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-cg-path.patch
epatch "${FILESDIR}"/${PN}-5.2.0-tcl-install.patch
+ epatch "${FILESDIR}"/${P}-boost-property_map.patch
sed -e "s:@VTK_TCL_LIBRARY_DIR@:/usr/$(get_libdir):" \
-i Wrapping/Tcl/pkgIndex.tcl.in \
|| die "Failed to fix tcl pkgIndex file"