summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-01 17:19:19 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-01 17:19:19 +0000
commit0dd56ca4a15c905d2ebf7e4de3e7ab9e06b4ac37 (patch)
treeb72f2c724a182e8a05540d26c5c100533faa0130 /sci-libs
parentVersion bump. (diff)
downloadgentoo-2-0dd56ca4a15c905d2ebf7e4de3e7ab9e06b4ac37.tar.gz
gentoo-2-0dd56ca4a15c905d2ebf7e4de3e7ab9e06b4ac37.tar.bz2
gentoo-2-0dd56ca4a15c905d2ebf7e4de3e7ab9e06b4ac37.zip
sci-libs/netcdf-cxx: Version Bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/netcdf-cxx/ChangeLog10
-rw-r--r--sci-libs/netcdf-cxx/metadata.xml4
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild37
3 files changed, 47 insertions, 4 deletions
diff --git a/sci-libs/netcdf-cxx/ChangeLog b/sci-libs/netcdf-cxx/ChangeLog
index dd0baa254103..99b425a63156 100644
--- a/sci-libs/netcdf-cxx/ChangeLog
+++ b/sci-libs/netcdf-cxx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/netcdf-cxx
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/ChangeLog,v 1.4 2013/02/20 17:06:36 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/ChangeLog,v 1.5 2014/01/01 17:19:19 jlec Exp $
+
+*netcdf-cxx-4.2.1 (01 Jan 2014)
+
+ 01 Jan 2014; Justin Lecher <jlec@gentoo.org> +netcdf-cxx-4.2.1.ebuild,
+ metadata.xml:
+ Version Bump
20 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org>
files/netcdf-cxx-4.2-config.patch:
diff --git a/sci-libs/netcdf-cxx/metadata.xml b/sci-libs/netcdf-cxx/metadata.xml
index 0c3cb8546cdc..c4b9426d48a5 100644
--- a/sci-libs/netcdf-cxx/metadata.xml
+++ b/sci-libs/netcdf-cxx/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
NetCDF (network Common Data Form) is an interface for scientific
data access and a freely-distributed software library that provides an
implementation of the interface. The netCDF library also defines a
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild
new file mode 100644
index 000000000000..5f02d4a7ca1a
--- /dev/null
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-cxx/netcdf-cxx-4.2.1.ebuild,v 1.1 2014/01/01 17:19:19 jlec Exp $
+
+EAPI=5
+
+inherit autotools-utils versionator
+
+MYP=${PN}4-${PV}
+
+DESCRIPTION="C++ library for netCDF"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-cxx4/archive/v4.2.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs"
+
+RDEPEND=">=sci-libs/netcdf-4.2"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.2-config.patch )
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ autotools-utils_src_test -j1
+}