summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-09-13 16:25:29 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-09-13 16:25:29 +0000
commit1cc85f93ebc366af554a4bf59ee826be18e8b7f5 (patch)
treedd2c2d0ab89365dc882eb8c6e067fe3529245a74 /sci-libs
parentMarked ppc/ppc64 stable for bug #336720. (diff)
downloadgentoo-2-1cc85f93ebc366af554a4bf59ee826be18e8b7f5.tar.gz
gentoo-2-1cc85f93ebc366af554a4bf59ee826be18e8b7f5.tar.bz2
gentoo-2-1cc85f93ebc366af554a4bf59ee826be18e8b7f5.zip
Initial commit for getdata. Ebuild by Matěj Laitl <strohel@gmail.com> (bug #335017).
(Portage version: 2.2_rc81/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/getdata/ChangeLog11
-rw-r--r--sci-libs/getdata/getdata-0.6.3.ebuild37
-rw-r--r--sci-libs/getdata/metadata.xml15
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/getdata/ChangeLog b/sci-libs/getdata/ChangeLog
new file mode 100644
index 000000000000..34397428e2a6
--- /dev/null
+++ b/sci-libs/getdata/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/getdata
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/ChangeLog,v 1.1 2010/09/13 16:25:29 ayoy Exp $
+
+*getdata-0.6.3 (13 Sep 2010)
+
+ 13 Sep 2010; Dominik Kapusta <ayoy@gentoo.org> +getdata-0.6.3.ebuild,
+ +metadata.xml:
+ Initial commit for getdata. Ebuild by Matěj Laitl <strohel@gmail.com>
+ (bug #335017).
+
diff --git a/sci-libs/getdata/getdata-0.6.3.ebuild b/sci-libs/getdata/getdata-0.6.3.ebuild
new file mode 100644
index 000000000000..b5b8dff352e2
--- /dev/null
+++ b/sci-libs/getdata/getdata-0.6.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/getdata-0.6.3.ebuild,v 1.1 2010/09/13 16:25:29 ayoy Exp $
+
+EAPI=2
+
+DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
+HOMEPAGE="http://getdata.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma python"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ python? ( dev-lang/python )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf="\
+ --disable-idl \
+ --without-libslim \
+ --with-libz \
+ --docdir=/usr/share/doc/${P} \
+ $(use_enable python) \
+ $(use_with bzip2 libbz2) \
+ $(use_with lzma liblzma)"
+ econf ${myconf} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "Installing docs failed"
+}
diff --git a/sci-libs/getdata/metadata.xml b/sci-libs/getdata/metadata.xml
new file mode 100644
index 000000000000..7ff4f54968b2
--- /dev/null
+++ b/sci-libs/getdata/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd></herd>
+ <maintainer>
+ <email>ayoy@gentoo.org</email>
+ <name>Dominik Kapusta</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <use>
+ <flag name="lzma">Support for encodings provided by liblzma</flag>
+ </use>
+</pkgmetadata>
+