summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-28 11:51:25 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-28 11:51:25 +0000
commit3e16c894ba30d76363589f59eea2bc62e6583eaf (patch)
tree03e637a5bea31a61dd077d1e6dbee491d5447b6d /sci-libs
parentVersion bump. (diff)
downloadgentoo-2-3e16c894ba30d76363589f59eea2bc62e6583eaf.tar.gz
gentoo-2-3e16c894ba30d76363589f59eea2bc62e6583eaf.tar.bz2
gentoo-2-3e16c894ba30d76363589f59eea2bc62e6583eaf.zip
Version Bump #321505; Added support for ogg R; prelimary support for PREFIX
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/ChangeLog10
-rw-r--r--sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch26
-rw-r--r--sci-libs/vtk/files/vtk-5.6.0-cg-path.patch36
-rw-r--r--sci-libs/vtk/files/vtk-5.6.0-libpng14.patch22
-rw-r--r--sci-libs/vtk/metadata.xml3
-rw-r--r--sci-libs/vtk/vtk-5.4.2-r1.ebuild3
-rw-r--r--sci-libs/vtk/vtk-5.6.0.ebuild234
7 files changed, 330 insertions, 4 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index baa1c80868ed..f1e227c77737 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.67 2010/05/22 09:19:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.68 2010/05/28 11:51:24 jlec Exp $
+
+*vtk-5.6.0 (28 May 2010)
+
+ 28 May 2010; Justin Lecher <jlec@gentoo.org> vtk-5.4.2-r1.ebuild,
+ +vtk-5.6.0.ebuild, +files/vtk-5.6.0-boost-property_map.patch,
+ +files/vtk-5.6.0-cg-path.patch, +files/vtk-5.6.0-libpng14.patch:
+ Version Bump #321505; Added support for ogg R; prelimary support for
+ PREFIX
22 May 2010; Justin Lecher <jlec@gentoo.org> vtk-5.4.2.ebuild,
vtk-5.4.2-r1.ebuild:
diff --git a/sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch b/sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch
new file mode 100644
index 000000000000..d6b7bda88eb6
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch
@@ -0,0 +1,26 @@
+diff --git a/Infovis/vtkBoostGraphAdapter.h b/Infovis/vtkBoostGraphAdapter.h
+index 5d113ac..d84cb98 100644
+--- a/Infovis/vtkBoostGraphAdapter.h
++++ b/Infovis/vtkBoostGraphAdapter.h
+@@ -50,7 +50,7 @@ namespace boost {
+ // These need to be defined before including other boost stuff
+
+ // Forward declarations are required here, so that we aren't forced
+- // to include boost/property_map.hpp.
++ // to include boost/property_map/property_map.hpp.
+ template<typename> class property_traits;
+ class read_write_property_map_tag;
+
+diff --git a/Infovis/vtkTreeLayoutStrategy.cxx b/Infovis/vtkTreeLayoutStrategy.cxx
+index 4a764ea..74d0b53 100644
+--- a/Infovis/vtkTreeLayoutStrategy.cxx
++++ b/Infovis/vtkTreeLayoutStrategy.cxx
+@@ -388,7 +388,7 @@ void vtkTreeLayoutStrategy::PrintSelf(ostream& os, vtkIndent indent)
+ #include "vtkTreeToBoostAdapter.h"
+ #include <boost/graph/visitors.hpp>
+ #include <boost/graph/depth_first_search.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/pending/queue.hpp>
+
+ using namespace boost;
diff --git a/sci-libs/vtk/files/vtk-5.6.0-cg-path.patch b/sci-libs/vtk/files/vtk-5.6.0-cg-path.patch
new file mode 100644
index 000000000000..984bf5008497
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.6.0-cg-path.patch
@@ -0,0 +1,36 @@
+diff --git a/CMake/FindCg.cmake b/CMake/FindCg.cmake
+index ceb41de..5eb6003 100644
+--- a/CMake/FindCg.cmake
++++ b/CMake/FindCg.cmake
+@@ -82,6 +82,7 @@ ELSE (APPLE)
+ FIND_PROGRAM( CG_COMPILER cgc
+ /usr/bin
+ /usr/local/bin
++ /opt/nvidia-cg-toolkit/bin
+ DOC "The Cg Compiler"
+ )
+ GET_FILENAME_COMPONENT(CG_COMPILER_DIR "${CG_COMPILER}" PATH)
+@@ -89,6 +90,7 @@ ELSE (APPLE)
+ FIND_PATH( CG_INCLUDE_PATH Cg/cg.h
+ /usr/include
+ /usr/local/include
++ /opt/nvidia-cg-toolkit/include
+ ${CG_COMPILER_SUPER_DIR}/include
+ DOC "The directory where Cg/cg.h resides"
+ )
+@@ -98,6 +100,7 @@ ELSE (APPLE)
+ /usr/lib
+ /usr/local/lib64
+ /usr/local/lib
++ /opt/nvidia-cg-toolkit/lib
+ ${CG_COMPILER_SUPER_DIR}/lib64
+ ${CG_COMPILER_SUPER_DIR}/lib
+ DOC "The Cg runtime library"
+@@ -108,6 +111,7 @@ ELSE (APPLE)
+ /usr/lib
+ /usr/local/lib64
+ /usr/local/lib
++ /opt/nvidia-cg-toolkit/lib
+ ${CG_COMPILER_SUPER_DIR}/lib64
+ ${CG_COMPILER_SUPER_DIR}/lib
+ DOC "The Cg runtime library"
diff --git a/sci-libs/vtk/files/vtk-5.6.0-libpng14.patch b/sci-libs/vtk/files/vtk-5.6.0-libpng14.patch
new file mode 100644
index 000000000000..db1f87d3afb2
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.6.0-libpng14.patch
@@ -0,0 +1,22 @@
+diff --git a/IO/vtkPNGReader.cxx b/IO/vtkPNGReader.cxx
+index d1f5c2f..0bf00e4 100644
+--- a/IO/vtkPNGReader.cxx
++++ b/IO/vtkPNGReader.cxx
+@@ -116,7 +116,7 @@ void vtkPNGReader::ExecuteInformation()
+ // minimum of a byte per pixel
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ // add alpha if any alpha found
+@@ -225,7 +225,7 @@ void vtkPNGReaderUpdate2(vtkPNGReader *self, OT *outPtr,
+ // minimum of a byte per pixel
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+ {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ // add alpha if any alpha found
diff --git a/sci-libs/vtk/metadata.xml b/sci-libs/vtk/metadata.xml
index c3f48289d643..827b79a1cd51 100644
--- a/sci-libs/vtk/metadata.xml
+++ b/sci-libs/vtk/metadata.xml
@@ -8,8 +8,9 @@
<name>Markus Dittrich</name>
</maintainer>
<use>
- <flag name='patented'>Build patented classes</flag>
<flag name='boost'>Add support for boost</flag>
<flag name='cg'>Use nvidia's cg shaders</flag>
+ <flag name='patented'>Build patented classes</flag>
+ <flag name='R'>Enable support for dev-lang/R</flag>
</use>
</pkgmetadata>
diff --git a/sci-libs/vtk/vtk-5.4.2-r1.ebuild b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
index a956a1eca5a4..99f61852ca8e 100644
--- a/sci-libs/vtk/vtk-5.4.2-r1.ebuild
+++ b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.10 2010/05/22 09:19:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.11 2010/05/28 11:51:24 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -24,7 +24,6 @@ RDEPEND="mpi? ( || (
sys-cluster/openmpi
sys-cluster/lam-mpi
sys-cluster/mpich2[cxx] ) )
- python? ( >=dev-lang/python-2.0 )
cg? ( media-gfx/nvidia-cg-toolkit )
tcl? ( >=dev-lang/tcl-8.2.3 )
tk? ( >=dev-lang/tk-8.2.3 )
diff --git a/sci-libs/vtk/vtk-5.6.0.ebuild b/sci-libs/vtk/vtk-5.6.0.ebuild
new file mode 100644
index 000000000000..22242c165a3a
--- /dev/null
+++ b/sci-libs/vtk/vtk-5.6.0.ebuild
@@ -0,0 +1,234 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0.ebuild,v 1.1 2010/05/28 11:51:24 jlec Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+
+inherit eutils flag-o-matic java-pkg-opt-2 python qt4 versionator toolchain-funcs cmake-utils
+
+# Short package version
+SPV="$(get_version_component_range 1-2)"
+
+DESCRIPTION="The Visualization Toolkit"
+HOMEPAGE="http://www.vtk.org"
+SRC_URI="http://www.${PN}.org/files/release/${SPV}/${P}.tar.gz
+ examples? ( http://www.${PN}.org/files/release/${SPV}/${PN}data-${PV}.tar.gz )
+ doc? ( http://www.${PN}.org/doc/release/${SPV}/${PN}DocHtml-${PV}.tar.gz )"
+
+LICENSE="BSD LGPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="boost cg doc examples java mpi ogg patented python qt4 tcl tk threads R"
+RDEPEND="
+ mpi? ( virtual/mpi[cxx,romio] )
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ tcl? ( >=dev-lang/tcl-8.2.3 )
+ tk? ( >=dev-lang/tk-8.2.3 )
+ java? ( >=virtual/jre-1.5 )
+ qt4? (
+ x11-libs/qt-core:4
+ x11-libs/qt-opengl:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-sql )
+ examples? (
+ x11-libs/qt-core:4[qt3support]
+ x11-libs/qt-gui:4[qt3support] )
+ R? ( dev-lang/R )
+ dev-libs/expat
+ dev-libs/libxml2
+ media-libs/freetype
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/tiff
+ virtual/opengl
+ x11-libs/libXmu"
+
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.5 )
+ boost? ( >=dev-libs/boost-1.40.0 )
+ mpi? ( >=dev-util/cmake-2.8 )
+ >=dev-util/cmake-2.6"
+
+S="${WORKDIR}"/VTK
+
+pkg_setup() {
+ echo
+ einfo "Please note that the VTK build occasionally fails when"
+ einfo "using parallel make. Hence, if you experience a build"
+ einfo "failure please try re-emerging with MAKEOPTS=\"-j1\" first."
+ echo
+
+ java-pkg-opt-2_pkg_setup
+
+ use python && python_set_active_version 2
+ use qt4 && qt4_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cg-path.patch
+ epatch "${FILESDIR}"/${PN}-5.2.0-tcl-install.patch
+ epatch "${FILESDIR}"/${P}-boost-property_map.patch
+ epatch "${FILESDIR}"/${P}-libpng14.patch
+ sed -e "s:@VTK_TCL_LIBRARY_DIR@:/usr/$(get_libdir):" \
+ -i Wrapping/Tcl/pkgIndex.tcl.in \
+ || die "Failed to fix tcl pkgIndex file"
+}
+
+src_configure() {
+ # general configuration
+ local mycmakeargs=(
+ -Wno-dev
+ -DVTK_INSTALL_PACKAGE_DIR=/$(get_libdir)/${PN}-${SPV}
+ -DCMAKE_SKIP_RPATH=YES
+ -DVTK_DIR="${S}"
+ -DVTK_INSTALL_LIB_DIR=/$(get_libdir)/
+ -DVTK_DATA_ROOT:PATH="${EPREFIX}"/usr/share/${PN}/data
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DBUILD_SHARED_LIBS=ON
+ -DVTK_USE_SYSTEM_FREETYPE=ON
+ -DVTK_USE_SYSTEM_JPEG=ON
+ -DVTK_USE_SYSTEM_PNG=ON
+ -DVTK_USE_SYSTEM_TIFF=ON
+ -DVTK_USE_SYSTEM_ZLIB=ON
+ -DVTK_USE_SYSTEM_EXPAT=ON
+ -DVTK_USE_SYSTEM_LIBXML2=ON
+ -DBUILD_TESTING=OFF
+ -DBUILD_EXAMPLES=OFF
+ -DVTK_USE_HYBRID=ON
+ -DVTK_USE_GL2PS=ON
+ -DVTK_USE_RENDERING=ON)
+
+ # use flag triggered options
+ mycmakeargs+=(
+ $(cmake-utils_use boost VTK_USE_BOOST)
+ $(cmake-utils_use cg VTK_USE_CG_SHADERS)
+ $(cmake-utils_use doc DOCUMENTATION_HTML_HELP)
+ $(cmake-utils_use_build doc DOCUMENTATION)
+ $(cmake-utils_use java VTK_USE_JAVA)
+ $(cmake-utils_use mpi VTK_USE_MPI)
+ $(cmake-utils_use ogg VTK_USE_OGGTHEORA_ENCODER)
+ $(cmake-utils_use patented VTK_USE_PATENTED)
+ $(cmake-utils_use qt4 VTK_USE_QT)
+ $(cmake-utils_use tcl VTK_WRAP_TCL)
+ $(cmake-utils_use tk VTK_USE_TK)
+ $(cmake-utils_use threads VTK_USE_PARALLEL)
+ $(cmake-utils_use R VTK_USE_GNU_R) )
+
+ # mpi needs the parallel framework
+ if use mpi && use !threads; then
+ mycmakeargs+=(-DVTK_USE_PARALLEL=ON)
+ fi
+
+ if use java; then
+ mycmakeargs+=(
+ -DVTK_WRAP_JAVA=ON
+ -DJAVA_AWT_INCLUDE_PATH=`java-config -O`/include
+ -DJAVA_INCLUDE_PATH:PATH=`java-config -O`/include
+ -DJAVA_INCLUDE_PATH2:PATH=`java-config -O`/include/linux)
+
+ if [ "${ARCH}" == "amd64" ]; then
+ mycmakeargs+=(-DJAVA_AWT_LIBRARY=`java-config -O`/jre/lib/${ARCH}/libjawt.so)
+ else
+ mycmakeargs+=(-DJAVA_AWT_LIBRARY:PATH=`java-config -O`/jre/lib/i386/libjawt.so)
+ fi
+ fi
+
+ if use python; then
+ mycmakeargs+=(
+ -DVTK_WRAP_PYTHON=ON
+ -DPYTHON_INCLUDE_PATH=$(python_get_includedir)
+ -DPYTHON_LIBRARY=$(python_get_library)
+ -DVTK_PYTHON_SETUP_ARGS:STRING=--root="${D}")
+ fi
+
+ if use qt4 ; then
+ mycmakeargs+=(
+ -DVTK_USE_GUISUPPORT=ON
+ -DVTK_USE_QVTK=ON
+ -DVTK_USE_QVTK_QTOPENGL=ON
+ -DQT_WRAP_CPP=ON
+ -DQT_WRAP_UI=ON
+ -DVTK_INSTALL_QT_DIR=/$(get_libdir)/qt4/plugins/${PN}
+ -DDESIRED_QT_VERSION=4
+ -DQT_MOC_EXECUTABLE="${EPREFIX}"/usr/bin/moc
+ -DQT_UIC_EXECUTABLE="${EPREFIX}"/usr/bin/uic
+ -DQT_INCLUDE_DIR="${EPREFIX}"/usr/include/qt4
+ -DQT_QMAKE_EXECUTABLE="${EPREFIX}"/usr/bin/qmake)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # install docs
+ dohtml "${S}"/README.html || die "Failed to install docs"
+
+ # install Tcl docs
+ docinto vtk_tcl
+ dodoc "${S}"/Wrapping/Tcl/README || \
+ die "Failed to install Tcl docs"
+
+ # install examples
+ if use examples; then
+ dodir /usr/share/${PN} || \
+ die "Failed to create data/examples directory"
+
+ cp -pPR "${S}"/Examples "${D}"/usr/share/${PN}/examples || \
+ die "Failed to copy example files"
+
+ # fix example's permissions
+ find "${D}"/usr/share/${PN}/examples -type d -exec \
+ chmod 0755 {} \; || \
+ die "Failed to fix example directories permissions"
+ find "${D}"/usr/share/${PN}/examples -type f -exec \
+ chmod 0644 {} \; || \
+ die "Failed to fix example files permissions"
+
+ cp -pPR "${WORKDIR}"/VTKData "${D}"/usr/share/${PN}/data || \
+ die "Failed to copy data files"
+
+ # fix data's permissions
+ find "${D}"/usr/share/${PN}/data -type d -exec \
+ chmod 0755 {} \; || \
+ die "Failed to fix data directories permissions"
+ find "${D}"/usr/share/${PN}/data -type f -exec \
+ chmod 0644 {} \; || \
+ die "Failed to fix data files permissions"
+ fi
+
+ #install big docs
+ if use doc; then
+ cd "${WORKDIR}"/html
+ rm -f *.md5 || die "Failed to remove superfluous hashes"
+ einfo "Installing API docs. This may take some time."
+ insinto "/usr/share/doc/${PF}/api-docs"
+ doins -r ./* || die "Failed to install docs"
+ fi
+
+ # environment
+ echo "VTK_DATA_ROOT=/usr/share/${PN}/data" >> "${T}"/40${PN}
+ echo "VTK_DIR=/usr/$(get_libdir)/${PN}-${SPV}" >> "${T}"/40${PN}
+ echo "VTKHOME=/usr" >> "${T}"/40${PN}
+ doenvd "${T}"/40${PN}
+}
+
+pkg_postinst() {
+ if use patented; then
+ ewarn "Using patented code in VTK may require a license."
+ ewarn "For more information, please read:"
+ ewarn "http://public.kitware.com/cgi-bin/vtkfaq?req=show&file=faq07.005.htp"
+ fi
+
+ if use python; then
+ python_mod_optimize vtk
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup vtk
+ fi
+}