summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2010-04-17 17:14:03 +0000
committerSteve Arnold <nerdboy@gentoo.org>2010-04-17 17:14:03 +0000
commit4e75ac9f1b2e8b54e7c58be12b2c37860e495092 (patch)
treea5350646437f8aabb375c887941ab606ecdef0bb /sci-libs
parentWorks only with python-2 (#315331). Thanks to arfrever for the patch and ohno... (diff)
downloadgentoo-2-4e75ac9f1b2e8b54e7c58be12b2c37860e495092.tar.gz
gentoo-2-4e75ac9f1b2e8b54e7c58be12b2c37860e495092.tar.bz2
gentoo-2-4e75ac9f1b2e8b54e7c58be12b2c37860e495092.zip
Update for latest stable 1.2.x release; closes bug 307639.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libgeotiff/ChangeLog9
-rw-r--r--sci-libs/libgeotiff/files/libgeotiff-1.2.5-listgeo-link-hack.patch15
-rw-r--r--sci-libs/libgeotiff/files/libgeotiff-1.2.5-make.patch10
-rw-r--r--sci-libs/libgeotiff/libgeotiff-1.2.5.ebuild53
4 files changed, 86 insertions, 1 deletions
diff --git a/sci-libs/libgeotiff/ChangeLog b/sci-libs/libgeotiff/ChangeLog
index 5ff362c21a54..099ffa5c17a7 100644
--- a/sci-libs/libgeotiff/ChangeLog
+++ b/sci-libs/libgeotiff/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/libgeotiff
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeotiff/ChangeLog,v 1.28 2010/01/02 18:09:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeotiff/ChangeLog,v 1.29 2010/04/17 17:14:03 nerdboy Exp $
+
+*libgeotiff-1.2.5 (17 Apr 2010)
+
+ 17 Apr 2010; Steve Arnold <nerdboy@gentoo.org> +libgeotiff-1.2.5.ebuild,
+ +files/libgeotiff-1.2.5-listgeo-link-hack.patch,
+ +files/libgeotiff-1.2.5-make.patch:
+ Update for latest stable 1.2.x release; closes bug #307639.
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
libgeotiff-1.3.0_beta1.ebuild:
diff --git a/sci-libs/libgeotiff/files/libgeotiff-1.2.5-listgeo-link-hack.patch b/sci-libs/libgeotiff/files/libgeotiff-1.2.5-listgeo-link-hack.patch
new file mode 100644
index 000000000000..eaa06da1a2bb
--- /dev/null
+++ b/sci-libs/libgeotiff/files/libgeotiff-1.2.5-listgeo-link-hack.patch
@@ -0,0 +1,15 @@
+--- bin/Makefile.in.orig 2009-10-10 12:04:15.972291516 -0700
++++ bin/Makefile.in 2009-10-10 12:07:34.459886566 -0700
+@@ -49,10 +49,10 @@
+ ${CC} ${COPTS} makegeo.o -L${libdir} ${LIBS} -o $@
+
+ geotifcp$(EXEEXT): geotifcp.o ${GEOTIFFDIR}/libgeotiff.a
+- ${CC} ${COPTS} geotifcp.o -L${libdir} ${LIBS} -o $@
++ ${CC} ${COPTS} geotifcp.o -L${libdir} ../libgeotiff.a ${LIBS} -o $@
+
+ listgeo$(EXEEXT): listgeo.o ${GEOTIFFDIR}/libgeotiff.a
+- ${CC} ${COPTS} listgeo.o -L${libdir} ${LIBS} -o $@
++ ${CC} ${COPTS} listgeo.o -L${libdir} ../libgeotiff.a ${LIBS} -o $@
+
+ csv2html$(EXEEXT): csv2html.o ${GEOTIFFDIR}/libgeotiff.a
+ ${CC} ${COPTS} csv2html.o -L${libdir} ${LIBS} -o $@
diff --git a/sci-libs/libgeotiff/files/libgeotiff-1.2.5-make.patch b/sci-libs/libgeotiff/files/libgeotiff-1.2.5-make.patch
new file mode 100644
index 000000000000..719a3e0b5384
--- /dev/null
+++ b/sci-libs/libgeotiff/files/libgeotiff-1.2.5-make.patch
@@ -0,0 +1,10 @@
+--- Makefile.in.orig 2009-10-10 10:32:26.665288828 -0700
++++ Makefile.in 2009-10-10 10:35:36.098484182 -0700
+@@ -104,6 +104,7 @@
+ ${LD_SHARED} ${OBJS} ${LIBS} -o $(GEOTIFF_SO)
+ rm -f libgeotiff.$(SO_EXT)
+ ${LN} $(GEOTIFF_SO) libgeotiff.$(SO_EXT)
++ ${LN} $(GEOTIFF_SO) libgeotiff.$(SO_EXT).$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ Progs: $(GEOTIFF_SO)
+ ${CD} ${BIN};\
diff --git a/sci-libs/libgeotiff/libgeotiff-1.2.5.ebuild b/sci-libs/libgeotiff/libgeotiff-1.2.5.ebuild
new file mode 100644
index 000000000000..307079b1ca9b
--- /dev/null
+++ b/sci-libs/libgeotiff/libgeotiff-1.2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libgeotiff/libgeotiff-1.2.5.ebuild,v 1.1 2010/04/17 17:14:03 nerdboy Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Library for reading TIFF files with embedded tags for geographic (cartographic) information"
+HOMEPAGE="http://geotiff.osgeo.org/"
+SRC_URI="ftp://ftp.remotesensing.org/pub/geotiff/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc python"
+
+RDEPEND=">=media-libs/tiff-3.9.1
+ media-libs/jpeg
+ sci-libs/proj"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.4-soname.patch
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-listgeo-link-hack.patch
+ filter-ldflags -Wl,-O1
+ eautoconf
+ eautomake
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+
+ if use doc; then
+ emake dox || die "emake dox failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dobin bin/makegeo || die "dobin makegeo failed"
+
+ if use python; then
+ dobin csv/*.py || die "dobin python failed"
+ fi
+
+ dodoc README
+ newdoc csv/README README.csv
+ use doc && dohtml docs/api/*
+}